現象
2019 の Microsoft Exchange Server や Exchange Server 2016 は、 InternetWebProxyパラメーターを使用してインターネットに接続する Exchange Server を使用する web プロキシ サーバーを設定して、インターネットに直接アクセスがないことを想定しています。OAuth の接続は、接続が正常に動作している場合でも、テスト OAuthConnectivityコマンドレットを使用してテストする場合は常に失敗することが発生する可能性があります。
原因
この問題は、テスト OAuthConnectivityコマンドレットは Exchange Server の設定、 InternetWebProxy設定を受け付けないために発生します。したがって、Exchange Server がインターネットに直接接続するのにはブロックされている場合は、OAuth 接続を正しくテストはありません。
状態
マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。
解決策
この問題を解決するには、以下の更新プログラムのいずれかをインストールします。Exchange Server 2019、2019 の Exchange Server の2019 の Exchange Server 用の累積的な更新の 1または後で累積的な更新をインストールします。
Exchange Server の 2016 の Exchange Server 2016 2016 の Exchange Server 用の累積的な更新 12または後で累積的な更新をインストールします。
関連情報
Microsoft がソフトウェア更新プログラムを説明するために使用される用語について説明します。