データをバブル チャートで表示する

適用先
Excel for Microsoft 365 Excel 2024 Excel 2021

バブル チャートは、データ ポイントの代わりにバブルを使用する散布図の一種です。 バブル サイズは、3 番目のデータ ディメンションを追加します。 バブル チャートでは、散布図のように項目軸を使用しません。 横軸と縦軸はどちらも数値軸です。 バブル チャートには、x 値と y 値に加えて、z (サイズ) 値がプロットされます。

バブル チャートでのデータのプロットについて

データに 3 つのデータ系列と関連する値がある場合は、散布図の代わりにバブル チャートを使用できます。 3 番目のデータ系列の値によってバブル サイズが決まります。 バブル チャートは多くの場合、財務データを表示するために使用します。 さまざまなバブル サイズは、特定の値を強調するのに役立ちます。

バブル チャートを作成するには、データをワークシートの行または列に配置します。 最初の行または列に x 個の値を示し、隣接する行または列に対応する y 値とバブル サイズ (z) 値を一覧表示します。 たとえば、次の画像に示すようにワークシートのデータを整理します。

バブル チャート

このバブル チャートでは、製品数が横軸に表示され、売上額が縦軸に表示され、市場シェアのパーセンテージがバブルのサイズで表されます。

次のようなデータの場合は、バブル チャートの使用を検討してみてください。

  • データ ポイントごとに 3 つの値 バブルごとに 3 つの値が必要です。 これらの値はワークシートの行または列に配置できますが、次の順序で指定する必要があります: x 値、y 値、z 値。
  • 複数のデータ系列 バブル チャートに複数のデータ系列をプロットする (複数のバブル系列) ことは、散布図に複数のデータ系列をプロットする (複数の散布系列) と似ています。 散布図では x 値と y 値のセットを使用しますが、バブル チャートでは x 値、y 値、z 値のセットを使用します。

バブル チャートを作成するときは 2-D 形式または 3-D 効果のバブル表示を選択できます。

バブル チャートと 3-D 効果付きバブル チャート

複雑なバブル チャートを作成する

書式設定されたバブル チャート

次の手順は、同様の結果のバブル チャートを作成する方法を示しています。 このグラフでは、サンプルのワークシート データを使っています。 このデータはワークシートにコピーすることも、独自のデータを使用することもできます。

  1. 空のワークシートにサンプル ワークシート データをコピーするか、バブル チャートでプロットしたいデータが入力されているワークシートを開きます。 サンプルのワークシート データをコピーするには

    1. 新しいブックまたはワークシートを作成します。
    2. ヘルプ トピックから使用例を選びます。
    3. Ctrl+C キーを押します。
    4. ワークシートでセル A1 を選択し、 Ctrl+V キーを押します。
    製品数 売上 市場シェアのパーセンテージ
    5 ¥5,500 3%
    14 ¥12,200 12%
    20 ¥60,000 33%
    18 ¥24,400 10%
    22 ¥32,000 42%

    注

    ワークシートに、4 つ以上の行または列が入力されていることを確認します。 3 行または 3 列以下のデータからバブル チャートを作成すると、グラフでバブルが正しくプロットされません。

  2. バブル チャートにプロットするデータを選びます。

    注

    選択範囲に行見出しまたは列見出しを含めないでください。 データを含む見出しを選択すると、グラフで誤った結果が生成されることがあります。

  3. [挿入] タブの [グラフ] グループで [散布図] の横にある矢印をクリックします。 散布図の横にある矢印を選ぶ

  4. 3-D 効果アイコンのバブルを選択します。

  5. グラフのグラフ エリアをクリックします。 グラフ ツールが表示されます。

  6. [デザイン] タブの [グラフ ツール] の [グラフ スタイル] で使用するグラフのスタイルをクリックします。

  7. グラフに凡例が表示されている場合は、凡例をクリックして、 Delete キーを押します。

  8. グラフのサイズを変更するには、[ 書式 ] タブの [ サイズ ] グループで、[ 図形の高さ と 図形の幅 ] ボックスで目的の図形サイズを選択してから、 Enter キーを押します。 バブル チャートでは、図形の高さと幅の両方に 3.5" を使用しました。 Outlook のリボンの画像

  9. グラフ タイトルの書式を設定してグラフに配置するには、グラフ領域をクリックし、次の操作を行います。

    1. グラフで、グラフ タイトルをクリックして、表示するテキストを入力します。 バブル チャートでは、「 Industry Market Share Study」と入力しました。
    2. グラフ タイトルのサイズを小さくするには、タイトルを右クリックして、 [フォント] を選択し、目的のサイズを入力します。 バブル チャートには 12 を使用しました。
    3. グラフのタイトルをプロット エリアに合わせるには、グラフのタイトルをクリックし、目的の位置にドラッグします。
  10. 横軸タイトルを追加するには、グラフのグラフ領域をクリックして次の操作を行います。

    1. グラフの横にあるプラス記号をクリックします。
    2. [軸ラベル] を選択し、[第 1 横軸] を選択します。
    3. [軸ラベル] テキスト ボックスを選択し、テキストを入力します。 [グラフ要素] メニューバブル チャートでは、「Number of products」と入力しました。
  11. 縦軸をクリックするか、グラフ要素の一覧 ([書式設定] タブの [現在の選択範囲] グループの [グラフの要素] ボックス) から選びます。

  12. [書式] タブの [現在の選択範囲] グループの [選択対象の書式設定] をクリックします。

  13. [軸のオプション] で、次の操作を行います。

    1. [ 最小] に 0 (ゼロ) を入力します。
    2. [ 最大] に、必要な数値を入力します。 バブル チャートでは、「 80000」と入力しました。
  14. [軸の書式設定] ダイアログ ボックスで [番号] をクリックします。

  15. [ 数値] の [小 数点以下の桁数 ] ボックスに「 0 (ゼロ) と入力し、右上隅の下矢印をクリックして、[ 閉じる] を選択します。

  16. グラフのプロット領域、グラフ領域、グラフ タイトル、横軸の書式設定で特殊効果を使用するには、グラフの要素をクリックするかグラフ要素の一覧から選択して ([書式] タブの [現在の選択範囲] グループの [グラフの要素] ボックスから選びます)、次の操作を行います。

    1. [書式] タブの [図形のスタイル] グループで、[図形の効果] の横にある [詳細] ボタンをクリックします。
    2. 使う効果をクリックします。 図形スタイルの選択を示す Excel リボン
  17. ブックに適用される既定のテーマとは異なるテーマの色を使うには、次の操作を行います。

    1. [印刷レイアウト] タブの [テーマ] グループで [テーマ] をクリックします。 Excel リボンのテーマ ボタン
    2. 使用するテーマをクリックします。 各テーマにマウス ポインターを合わせると、グラフに適用したときにどのように表示されるかをプレビューできます。

グラフは、他の類似したグラフの基礎として使用できるテンプレートとして保存できます。 詳細については、「ユーザー設定のグラフをテンプレートとして保存する」を参照してください。