までが更新された後、印刷キューのプロパティを変更すると、Windows エクスプ ローラーがクラッシュします。

現象

次のシナリオを検討してください。

  • プリンターをインストールするには、Windows 7 または Windows 2013 を実行しているコンピューターで、インボックス プリンター ドライバーをWindows Server 2008 R2。

  • 新しいプリンター ドライバーまたは更新されたプリンター ドライバーをインストールし、そのプリンター ファイルの更新Unidrv.dllします。

  • 印刷キューのプロパティを変更しようとして、インボックス プリンター ドライバーを使用します。

このシナリオでは、Windows エクスプローラーがクラッシュし、次のエラー メッセージが表示されます。

Windows エクスプローラーが動作を停止しました。Windows では、問題の解決方法をオンラインで確認し

、プログラムの再起動を試みる可能性があります。


この問題は、プロセスが更新または更新される複数の状況Unidrv.dll。 たとえば、Windows Service Pack、更新プログラムロールアップ パッケージ、またはサードパーティ製プリンター ドライバーをインストールします。

原因

この問題は、新しいバージョンの印刷キューUnidrv.dll既存の印刷キューの更新をトリガーする場合に発生します。 この更新プロセスは、インボックス ドライバーを使用する印刷キューにレジストリ値を追加するドライバーのアップグレードを開始します。

解決方法

重要
このセクションの手順は慎重に実行してください。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する前に、問題が発生した 場合に 復元するためにレジストリをバックアップします。

この問題を解決するには、「問題を解決する」セクション参照してください。 自分でこの問題を解決するには、「自分で解決する」セクションに進んでください。


Fix it で解決する

この問題を解決するには、[修正 ] ボタンまたはリンクをクリックします。 次に 、[ファイルの ダウンロード] ダイアログ ボックスで [実行] をクリックし、修正ウィザードの手順に従います。



  • このウィザードは英語版のみである場合があります。 しかし、自動的な解決は英語版以外の Windows でも機能します。

  • 問題のあるコンピューターとは別のコンピューターを操作している場合、Fix it ソリューションをフラッシュ ドライブまたは CD に保存することで、問題のあるコンピューターで実行することができます。

  • マイクロソフトではフィードバックをお待ちしております。 フィードバックを送信したり、このソリューションに関する問題を報告したりするには、ブログの"問題を解決する" ブログにコメントを残してください。または、メール メッセージを 送信 してください。



この問題を解決するには、ドライバーのアップグレードによって追加されたレジストリ エントリを削除します。 この場合、次の手順を実行します。

  1. [デバイスとプリンター] を開き、問題の印刷キューのプリンター名を特定します。

    この例では、"HP Laser Jet 4100 Series PCL6" が問題のプリンターです。


  2. レジストリ エディターを開きます。 これを行うには、[スタート] を クリックし、検索regedit.exe入力して、Enter キーを押します。

  3. 次のレジストリ キーを見つけて展開します。

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers

  4. 手順 1 で識別された問題プリンターと同じ名前のレジストリ サブキーを展開し 、[PrinterDriverData] をクリックします


  5. PrinterDriverData レジストリ サブキーをバックアップします。 この場合、次の手順を実行します。

    • PrinterDriverData を右クリックし、[エクスポート] をクリックします

    • [ファイル 名] ボックスに、エクスポートするレジストリ キーに使用する名前を入力します。

    • [ 保存] をクリックして、選択したレジストリ キーをエクスポートして保存します。

  6. 右側のウィンドウで DMCExist レジストリ値を右クリックし、[削除] をクリック します。 削除 の確認 を求めるメッセージが表示されたら、[はい] をクリックします。

    注: 複数の印刷キューで同じ問題が発生している場合は、それらのプリンターで同じ手順を繰り返します。

  7. レジストリ エディターを終了します。

  8. 印刷スプーラー サービスを停止し、再起動します。 これを行うには、次のいずれかの方法を使用します。

    方法 1: サービス 本体を使用する:

    1. [ スタート] をクリックし、検索ボックスに「services.msc」と入力して、Enter キーを押します。

    2. 印刷 スプーラーを開き、[停止] を クリックし、[スタート] を クリックします

    方法 2: コマンド プロンプトを使用する:

    1. 管理者としてコマンド プロンプトを開きます。

    2. 次のコマンドを実行して、印刷スプーラー サービスを停止します

      。Net Stop スプーラー

    3. 次のコマンドを実行して、印刷スプーラー サービスを開始します

      。Net Start スプーラー

  9. 問題が解決された場合は、テストして確認します。


この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。 明示的か黙示的かにかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

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