現象
Integration Manager を起動すると
、ADODB.connection で内部エラーが発生する可能性があります。 数値 3706。 プロバイダーが見つかりません。 正しくインストールされていない可能性があります。
原因
通常、このエラーは、InstallShield ディレクトリのキー (C:\Program Files\InstallShield インストール情報) の破損/無効なキーが原因で発生します。
解決策
1. Integration Managerusing の [プログラムの追加/削除] のすべてのバージョンを削除します。
2. レジストリ内HKEY_LOCAL_MACHINE\Software\Microsoft\Great Plains\Integration Manager\キーを削除します。 また、レジストリ内HKEY_CURRENT_USER\Software\Microsoft\Great Plains\Integration Manager\キーを削除します。
3.
%IM% <-where-where IM が以前
%Program Files%\IM\
%Program Files%\%Common Files%\CBOM\
4 にインストールされているディレクトリが削除されていることを確認します。 次のファイルが %System% ディレクトリに存在しない必要があります。
Cbomlibx.dllCbom.dll Cbom.tlbTtgcomnx.dllTtgscrx.dllTtgvbolex.dllTtgvbole.dll最も簡単な方法は
、%System% で Ttg*.* を検索し、それらを削除してから Cb*.dll から検索して削除する方法です。 削除する前に、これらのファイルが実際に上記のファイルの 1 つである必要があります。
これにより、マシン上の Integration Manager への参照が完全に削除されます。
5. 最新バージョンの MDAC (2.8) をインストール
http://msdn.microsoft.com/data/Default.aspx。 現在の MDAC のバージョンを確認するには、新しいバージョンHKEY_LOCAL_MACHINE\Software\Microsoft\DataAccessしてください。
6. バックアップ フォルダーを作成し、C:\Program Files\InstallShield のインストール情報から作成したバックアップ フォルダーに内容を切り取る。
7. Integration Manager のリリース 7.5 Service Pack 3 を再インストールし、Service Pack 4 を適用します。
[https://mbs.microsoft.com/fileexchange/?fileID=59682871-a5e0-4660-a36f-4be0d07aecfc]をクリックして Service Pack 3 をダウンロードします。
[https://mbs.microsoft.com/downloads/customer/IM75sp4.zip]をクリックして Service Pack 4 をダウンロードします。
この記事は TechKnowledge Document ID:34645 でした