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現象

次のような状況で問題が発生します。

  • Microsoft Skype for Business Server 2015 オンプレミスおよび Exchange ハイブリッド環境にご使用いただけます。

  • Skype for Business Server 2015 フロントエンド プールは、プロキシを使用して、インターネットに直接アクセスする必要はありません。

  • オンプレミスの Exchange CAS サーバーを指す Skype for Business Server OAuth 構成設定 (-ExchangeAutodiscoverUrl-)を設定します。

  • Skype for Business の会話履歴構成設定を使用して、サーバー側の会話履歴機能を有効にします。

  • Exchange オンライン メールボックスを作成してアカウントを設定します。

このシナリオでは、アカウントのユーザーは、サーバー側の会話履歴の機能を使用して、Exchange オンライン メールボックスに会話履歴を保存することはできません。また、オンプレミス ユーザーは影響を受けません。

原因

この問題は、Exchange CAS サーバーがプロキシ サーバーを使用する代わりに、自動検出要求を Exchange Online に直接リダイレクトしているために発生します。Exchange オンプレミス サーバーは Exchange Online に直接接続できないため、接続は失敗します。

また、オンプレミスのメールボックスはローカル リソースため、自動検出プロセスは正常に機能します。

解決方法

この問題を解決するには、2019 年 1 月の累積的な更新プログラム 6.0.9319.537を Skype for Business Server 2015、フロントエンド サーバーおよびエッジ サーバー用にインストールします。

注記プロキシ サーバー構成にプロキシ バイパス リスト プロキシ内のローカル ドメイン名への参照が含まれている場合は、各フロントエンド サーバーの LysSvc.exe.config ファイルの構成セクションに、バイパス リストのないプロキシ サーバーの詳細を入力する必要があります。

netsh を使用して、昇格されたコマンド ラインを介してプロキシ バイパス リストを確認できます。

  1. [スタート]に移動し、cmd と入力します。

  2. [コマンドプロンプト] を右クリックし、[管理者として実行] を選択します。

  3. 次のコマンドを入力し、次のコマンド入力します。 netsh winhttp ショー プロキシ

ローカル ドメインがプロキシ バイパス リストに明示的に設定されているかどうかを確認します(この例では、ローカル ドメイン名contoso.comします)。

現在の WinHTTP プロキシ設定: プロキシサーバー: 192.168.1.60:8080 バイパスリスト : *.contoso.com;*.local;

その場合は、次の例に従って、各フロントエンド サーバーの C:\プログラム ファイル\Skype for ビジネス サーバー 2019\Core\LysSvc.exe.config で利用可能な LysSvc.exe.config の構成セクションに次のエントリを追加する必要があります。:

<デフォルトプロキシ> <プロキシ プロキシアドレス="http://192.168.1.60:8080" バイパスローカル="true" /> </デフォルトプロキシ>

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