適用先
Exchange Server 2019 Exchange Server 2016

現象

次の 1 つ以上の現象が発生します。

  • ユーザーがメール メッセージを受信したり、メールボックスに接続したりすることはできません。

  • Microsoft Exchange Serverは応答を停止し、フリーズしているように見えます。

  • noderunner プロセスが消費するメモリが多すぎます。

原因

Exchange Serverの noderunner プロセスでは、一部の項目にインデックスを作成しようとすると、メモリが過剰に消費される可能性があります。 この動作により、サーバーでさまざまなパフォーマンスの問題が発生します。

解決方法

この問題を解決するには、noderunner プロセスで使用できるメモリの量を制限します。 各 Exchange サーバーで次の手順を実行します。

  1. %ExchangeInstallPath%Bin\Search\Ceres\Runtime\1.0 フォルダー内の Noderunner.exe.config ファイルを見つけます。

  2. Noderunner.exe.config ファイルを開き、<nodeRunnerSettings memoryLimitMegabytes="0"/> XML ノードを見つけます。

  3. memoryLimitMegabytes パラメーターを、インストールされているサーバー メモリの 25% の値に設定します。 値をメガバイト単位で入力します。 これらの手順を完了した後も問題が解決しない場合 は、memoryLimitMegabytes の値を 5% 下げてから、もう一度テストします。

    注: Exchange Server 2019 がインストールされ、メモリが 128 GB のサーバーの場合は、memoryLimitMegabytes パラメーターを 10000 から 32000 (10 から 32 GB) の値に設定します。 memoryLimitMegabytes の値を低く設定すると、検索パフォーマンスが影響を受けます。

  4. 次の PowerShell コマンドを実行して、Microsoft Exchange Search ホスト コントローラー サービスを再起動します:Restart-Service HostControllerService

  5. PowerShell またはコマンド プロンプト ウィンドウで次のコマンドを実行して IIS を再起動します:IISReset /restart

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