現象

Microsoft Dynamics GP またはワークステーションの Microsoft Dynamics SL で Business Portal を起動すると、次のエラー メッセージが表示されます。

エラー: Active Directory にユーザー 'domain\user' のサービス プリンシパル名 (SPN) が見つかりません

原因

この問題は、次の条件に当てはまる場合に発生します。

  • 仮想サーバーは、サーバーの全体管理SharePoint拡張されます。

  • Kerberos 認証が選択されています。

  • Active Directory ディレクトリ サービスは、Kerberos 認証を使用するように構成されていません。

解決策

この問題を解決するには、Kerberos 認証ではなく NTLM 認証を使用します。注意 Kerberos 認証を使用する必要があります。詳細については、次の Microsoft Web サイトを参照してください。

http://www.microsoft.com/windowsserver2003/technologies/security/kerberos/default.mspx NTLM 認証を有効にするには、次の手順に従います。

  1. IIS (IIS) を実行しているサーバーで、[スタート] Microsoft インターネット インフォメーション サービス、[実行] の順にクリックし、「cmd」と入力し、[OK]をクリックします。

  2. コマンド プロンプトで以下のコマンドを入力し、Enter キーを押します。

    cd Drive:\inetpub\adminscripts注 ドライブを、Windows Server 2003 がインストールされているハード ディスク ドライブの名前に置き換える。

  3. コマンド プロンプトで以下のコマンドを入力し、Enter キーを押します。

    cscript adsutil.vbs w3svc/xx/NTAuthenticationProvidersNote xx を仮想サーバー ID 番号に置き換える。 仮想サーバー ID 番号を確認するには、次の手順に従います。

    1. IIS を実行しているサーバーで、[スタート] をクリックし、[すべてのプログラム]をポイントし、[管理ツール] をポイントし、[インターネット インフォメーション サービス(IIS) マネージャー] をクリックします。

    2. コンピューター名を展開し 、[Web サイト]を展開し、Business Portal をインストールした Web サイトを右クリックし、[プロパティ] をクリック します

    3. [Web サイト] タブをクリック し、[アクティブ なログ形式 ] ボックスの横にある [ プロパティ] をクリック します。

    4. .log ファイルのパスとファイル名をメモします。 パスとファイル名は次のようになります。

      W3SVCxx\exyymmdd.log このパスでは 、xx は 仮想サーバー ID 番号を表します。

  4. 仮想サーバーで NTLM 認証を有効にするには、コマンド プロンプトで次のコマンドを入力し、Enter キーを押します。

    cscript adsutil.vbs w3svc/xx/NTAuthenticationProviders "NTLM"Note xx を手順 3 でメモした仮想サーバー ID 番号に置き換える。

  5. IIS を再起動します。 これを行うには、次の手順に従います。

    1. [スタート ] をクリック、[実行] をクリックし、「cmd」と入力して 、[OK] をクリックします

    2. コマンド プロンプトで「iisreset」と入力し、Enter キーを押します。

    3. コマンド プロンプトで「exit」と入力し、Enter キーを押します。

  6. ワークステーションで Microsoft Internet Explorerを起動し、アドレス バーに次の URL を入力します。

    http://xx/sites/businessportalNote xx をサーバーの名前に置き換える。

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