メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

scanreg /restore コマンドを使用して以前のレジストリを復元すると、次のエラー メッセージが表示される場合があります。

Microsoft レジストリ チェッカ

システムの復元に失敗しました。

現象

この現象は、保存されているレジストリのうち、最も古いものを復元しようとしたことが原因で発生します。Scanreg.ini ファイルの MaxBackupCopies 設定によって指定された最大数のレジストリが既に保存されています。


最も古いレジストリを復元しようとすると、Windows は現在のレジストリのバックアップを試みます。復元する同じレジストリのバックアップが Windows によって上書きされるため、復元処理が失敗します。


注 : 最も古いレジストリのバックアップが、現在のレジストリのバックアップで置き換えられるため、そのレジストリを復元に使用できなくなります。

原因

この問題を解決するには、scanreg /restore コマンドを実行する前に、次のいずれかの操作を行います。

  • 保存されている 1 つまたは複数のレジストリのバックアップの名前を変更して、バックアップをさらに追加できるようにします。

  • Scanreg.ini ファイル内の MaxBackupCopies 設定の値を増やして、現在のレジストリのバックアップを追加できるようにします。

また、レジストリ ファイルを手動で復元して、現在のレジストリが自動的にバックアップされることを回避できます。この方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。

220878 エラー メッセージ : システムの復元に失敗しました。

解決方法

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 245412 (最終更新日 2001-02-01) をもとに作成したものです。

関連情報

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×