メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

現象

いくつかのウィンドウのドッキングを解除した場合、または Microsoft Visual Studio 2008 Service Pack 1 (SP1) IDE のウィンドウ レイアウトを変更するとき、1 つまたは複数の以下の問題が発生することがあります。

シナリオ 1

次のような状況で問題が発生します。

  • Visual Studio 2008 SP1 の IDE でアプリケーションをデバッグするとします。

  • ブレークポイントにヒットしたときは、[ウォッチ] ウィンドウや、[呼び出し履歴] ウィンドウをアンドックします。

  • デバッグを続行して、次のステートメントを入力します。

  • [デバッグの停止] をクリックします。

このシナリオでは、IDE がクラッシュします。

シナリオ 2

次のような状況で問題が発生します。

  • Visual Studio 2008 SP1 の IDE でいくつかのウィンドウのドッキングを解除します。

  • 他の場所に、windows の再装着します。

  • 全画面表示モードとその他のモードの間でウィンドウのレイアウトを変更します。

このシナリオでは、IDE がクラッシュします。

原因

この問題は、Visual Studio シェルのエンジンの内部問題のために発生します。

解決方法

修正プログラムの情報

サポートされている修正プログラムは、マイクロソフトから入手可能です。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この問題が発生しているシステムにのみ適用してください。この修正プログラムは、今後さらにテストを行う場合があります。したがって、この問題の影響が深刻でない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことをお勧めします。この修正プログラムを MSDN コード ギャラリーからダウンロードするには、次のマイクロソフト Web サイトを参照してください。

http://code.msdn.microsoft.com/KB960075注: MSDN コード ギャラリーの修正プログラムは利用可能な言語を表示します。 自分の言語が一覧に表示されない場合は、その言語用のコード ギャラリー リソース ページが使用できないためです。注: さらなる問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストの作成が必要な場合があります。 この修正プログラムの対象外の追加の質問および問題については、通常のサポート料金が適用されます。 マイクロソフト カスタマー サービス サポートの電話番号一覧または別のサービス リクエストの作成については、次のマイクロソフト Web サイトを参照してください。

http://support.microsoft.com/contactus/?ws=support

必要条件

Visual Studio 2008 SP1 がこの修正プログラムを適用するためにインストールする必要があります。

再起動の必要性

この修正プログラムの適用後にコンピュータを再起動する必要はありません。

修正プログラムの置き換えに関する情報

この修正プログラムによって他の修正プログラムが置き換わることはありません。

ファイル情報

この修正プログラムのグローバル バージョンには、次の表に記載されているファイル属性 (またはそれ以降のファイル属性) が含まれています。 これらのファイルの日付と時刻は世界協定時刻 (UTC) で記載されています。 ファイル情報に表示される時刻は、ローカル時刻に変換されています。 UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。

ファイル名

ファイル バージョン

ファイル サイズ

日付

時刻

プラットフォーム

Msenv.dll

9.0.30729.4108

9,354,040

03-May-2009

09:57

x86

回避策

この問題を回避するには、既定の場所からウィンドウの位置を変更しないでください。

状態

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細情報

ソフトウェア更新プログラムに関する用語の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。

824684 マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×