現象
コンピュータを再起動したり休止したセッションを再開したりすると、次の現象が発生することがあります。
-
コンピュータをシャットダウンして再起動するまで、USB (Universal Serial Bus) キーボードまたはマウスが機能しなくなります。
-
デバイス マネージャを開くと、USB デバイスが [不明なデバイス] ノードの下に表示されます。
-
コンピュータの Windows レジストリに次のキーが追加されます。
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\USB\VID_0000&PID_0000
原因
この問題は、以下の両方の条件に該当する場合に発生する可能性があります。
-
コンピュータの BIOS (Basic Input/Output System) 設定で USB レガシ サポートが有効になっています。
-
コンピュータで USB デバイスを管理するために Intel 82801BA I/O Controller Hub (ICH2) チップが使用されています。
コンピュータで Intel 82801BA I/O Controller Hub (ICH2) チップが使用されているかどうかを確認するには、デバイス マネージャの [USB (Universal Serial Bus) コントローラ] ノードを展開し、次のようなデバイスを探します。Intel(r) 82801BA USB Universal Host Controller
コンピュータの再起動時や休止したセッションからの再開時には USB デバイスの再検出が行われますが、このときにデバイスが正しく列挙されない場合があります。この現象は、ユニバーサル ホスト コントローラ ドライバ (UHCD) で適用しようとした設定が、USB レガシ サポートの設定と競合するために発生します。
解決方法
この問題を解決するには、Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法 修正プログラム (英語版) の属性は次のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。 日付 時刻 バージョン サイズ ファイル名 ------------------------------------------------------- 05-Oct-2001 12:24 5.0.2195.4475 82,080 Halaacpi.dll 05-Oct-2001 12:24 5.0.2195.4475 66,816 Halacpi.dll 05-Oct-2001 12:24 5.0.2195.4475 82,976 Halmacpi.dll
回避策
この問題を回避するには、BIOS で USB レガシ サポートを無効にします。ただし、コンピュータに接続されている入力デバイスがすべて USB の場合は、この方法を実行するのは望ましくない場合があります。詳細については、この資料の「詳細」を参照してください。
状況
マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。
この問題は、Windows 2000 Service Pack 3 で最初に修正されました。詳細
USB レガシ サポート機能がサポートされているコンピュータでは、通常、コンピュータの BIOS 設定でこの機能を有効または無効にできます。使用中のハードウェアで USB レガシ エミュレーションがサポートされているかどうかについては、コンピュータに付属のマニュアルを参照するか、ハードウェアの製造元に確認してください。ハードウェアの製造元への連絡方法については、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
65416 ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (A ~ K)
60781 ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (L ~ P)
60782 ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (Q ~ Z) Windows 2000 Datacenter Server 用の修正プログラムの入手方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
265173 Datacenter Program と Windows 2000 Datacenter Server 複数の修正プログラムのインストールを 1 回の再起動のみで行う方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
296861 複数の Windows 更新プログラムまたは修正プログラムを同時にインストールし、再起動を 1 回で済ませる方法 Windows 2000 と Windows 2000 の修正プログラムを同時にインストールする方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
249149 Microsoft Windows 2000 および Windows 2000 ホットフィックスのインストール この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。 他社テクニカル サポートのお問い合わせ窓口は、ユーザーの便宜のために提供されているものであり、将来予告なしに変更されることがあります。マイクロソフトは、掲載している情報に対して、いかなる責任も負わないものとします。