Applies ToMicrosoft Dynamics CRM 2011

現象

壁有効であるエンティティを含むマネージド ソリューションをインポートするとします。マネージド ソリューションをインポートしようとすると、エラーで失敗します。"マネージド ソリューションは、アンマネージ基本インスタンスを持つターゲット ・ システム上の保存のコンポーネントを上書きできません。 このエラーの最も可能性の高いシナリオは、アンマネージド ソリューションが新しいアンマネージ保存コンポーネントをターゲット システムにインストールされていることと、管理下には、同じ保存コンポーネントをインストールするのには、同じ発行元からのマネージド ソリューションを試行しています。 この、ソリューションの無効なレイヤー上のターゲット ・ システムとは許可されていません」

原因

エンティティが有効になっている壁の場合は、アンマネージの 2 つのビューは、そのエンティティに追加されます。

  • < エンティティ >s がフォローされています。

  • < エンティティ >s のフォロー

マネージド ソリューションには、エンティティをエクスポートすると、管理された状態にこれらのアンマネージのビューがエクスポートされます。別の環境でのマネージド ソリューションをインポートしようとすると、移行先の組織に同じエンティティがある場合は、' 壁を有効に ' の状態で、インポートは失敗します。エラー メッセージが示すとおり、配置先の環境には、これらの同じビューでは、既に含まれているためですが、管理されていない状態で、問題があります。マネージド ソリューションは、ソリューションの無効なレイヤー上のターゲット ・ システムであり、できないと、これらのコンポーネントを上書きできません。

解決策

ソリューションをエクスポートする前にエクスポートされているエンティティのアクティビティ フィードの構成を無効にします。これを行うには、次の手順に従います。1. 設定に移動し、投稿の構成] をクリックしてください

a. エクスポートされる各エンティティを選択します。

b. ボタンをクリックします 'アクティブ' 投稿の構成のリボン コントロールで

c. 後必要なエンティティを非アクティブ化したが、すべてのカスタマイズを発行します。2. 管理された状態でもう一度新しいソリューションをエクスポートします。これらのエンティティの投稿の構成を非アクティブ化、アンマネージのビューはエンティティから一時的に削除し、エンティティをエクスポートする場合は含まれません。マネージド ソリューションのビューが存在しないため矛盾が生じないようにないビューを配置先の環境にインポートする場合。

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。