現象
[マイ フロー] の [デスクトップ フロー] タブにアクセスすると、次のいずれかのエラーが表示される場合があります。
1. Microsoft Dataverse を使用するには、アクセス許可が必要です
2. SecLib::CheckPrivilege に失敗しました。 ユーザー: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx, PrivilegeName: prvReadEntity, PrivilegeId: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxxxxx, Required Depth: Basic, BusinessUnitId: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx, MetadataCache Privileges Count: xx, User Privileges Count: xx
3. id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx を持つユーザーにロールが割り当てられていない。 prvWriteWorkflow 特権を持つロールが必要です。
原因
UI フローの一覧を表示するには、"prvReadEntity" アクセス許可を持つロールがユーザーに割り当てられている必要があります。 上記の最初のエラー メッセージの場合、ユーザーにはロールが割り当て済みですが、それらのロールには "prvWriteWorkflow" アクセス許可が付与されません。 2 番目の場合、ユーザーにはロールが割り当てられていない。 どちらの場合も、"Environment Maker" などの "prvWriteWorkflow" アクセス許可を持つロールをユーザーに割り当てる必要があります。
ユーザーには、選択した環境のデスクトップ フローを表示するアクセス許可が付与されません。 環境に対して Environment Maker などのロールが割り当てられていないか、そのユーザーのロールに "prvWriteWorkflow" というアクセス許可が割り当てられていない。
解決方法
特定の環境にアクセスするには、Power Platform 管理者に連絡し、Environment Maker ロール、または "prvWriteWorkflow" アクセス許可を持つ別のロールを付与することを求めます。
その特定の環境を使用する必要がない場合は、ページの上部にある [環境] メニューから別の環境を選択するか、Power Platform 管理センターにアクセスして独自の環境を作成してみてください。
パブリック ドキュメントでは、各ユーザーがアクセスできる対象 に関するサインイン アカウントの比較の詳細を確認できます。