現象
一部のエンティティに対して表示され、ルックアップ結果に表示されるレコードは表示されません。
たとえば、Queues エンティティはここで想定されるが、存在しません。
原因
考えられる 3 つの原因
-
エンティティが UCI (モバイル クライアント) に対して有効になっていない
-
エンティティは UCI アプリに追加されません。
-
複数エンティティ参照の場合、エンティティがアプリに追加されていない場合、ルックアップ コントロールはエンティティのメタデータを取得し、その中にタブや検索レコードを表示しない)
-
ユーザーと Teams を表示する所有者参照に関する一般的な問題。 ユーザーがアプリに追加しなかったため、Teams は表示されません。
-
-
エンティティが UCI アプリに追加された場合に関係なく、レコードが表示される必要があるため、これは単一のエンティティ参照コントロールに関係ありません。
-
-
エンティティが新しいカスタム エンティティで、[ルックアップについて] に表示されない場合、アクティビティの 1 つとして構成されていない可能性があります。
緩和策
それぞれの原因の解決方法
-
エンティティを有効にする。 この設定はエンティティ デザイナーで行います。 ConnectionRole のような一部のコア エンティティは、ユーザーが構成できないので、UCI ではサポートされていないので、設計では編集できません。
-
エンティティを UCI アプリに追加します。
たとえば、Team エンティティを UCI アプリに追加します。
-
このエンティティがルックアップに関連するアクティビティの 1 つとして表示されるには、[アクティビティ] ボックスがオンになっています。