Applies ToDynamics Dynamics 365

現象

選択したレコード タグは空です。または、選択した値がルックアップ コントロールの結果リストに正しく表示される場合でも、"名前なし" と表示されます。

例えば 

SelectedRecordShowsNoName

原因

タグに表示されるテキストは、アイテムが結果リストでどのように表示されるのかには関係ない。 タグ テキストはエンティティの主フィールドです。 既定では、プライマリ フィールドは "名前" です。 User エンティティの場合、"氏名" です。 プライマリ フィールドは UI の必須フィールドですが、空の場合があります。

  • レコードにはプライマリ フィールドの値が含まれる場合、この列がビューに存在しなっている可能性があります。 表示されているビューを確認して、プライマリ フィールドが一番左に存在し、両方が存在します。

たとえば、アカウント参照ビューのプライマリ列を確認します。

LookupViewPrimaryColumn

  • レコードのプライマリ フィールドには値が設定されていない。 これは、データベースの移行に問題がある可能性があります。

緩和策

原因ごとに解決方法

  • ビューに列が表示されている場合。 ビューに列を追加します。

[列の追加] をクリックしてプライマリ列を追加する

LookupViewPrimaryColumn

通常、プライマリ列はユーザー エンティティの名前またはフル ネームです。

LookupViewPrimaryColumnName

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。