適用先
TFS 2017 TFS 2018

現象

Microsoft Azure の米国政府のクラウド内のリソースを更新しようとすると、Team Foundation サーバー上のリリースを使用して開始される展開が失敗する可能性がありますのでとすると、次のエラーが表示される可能性があります。

Azure のアクセス トークンを取得できませんでした。

Json Web トークン (JWT) のサービス ・ プリンシパルの id 'ServicePrincipalID' を取得できませんでした。 例外メッセージ: AADSTS90038: クラウドの間の要求では、機密性の高いクライアントはサポートされていません。

原因

Azure の米国政府のクラウドの AAD 機関 URL は、ログイン us.microsoftonline.comからlogin.microsoftonline.usに変更されました。 、展開時に、リリースは、更新プログラムを認証するためにアクセス トークンを取得しようとします。 組み込みの配置のタスクは、アクセス トークンと失敗の古い URL をクエリします。

解決方法

この問題を解決するには、次の手順を実行します。

  1. Azure の拡張機能の VSIX ファイルを必要に応じてダウンロードしてください。

  2. TFS 管理者のアカウントを使用して管理者の資格情報でコマンド プロンプトを実行し、それに応じて次のコマンドを使用して、Team Foundation サーバーに拡張機能をアップロードします。

    • TFS 2017 の

      "C:\Program を Team Foundation Server 15.0\Tools\TfsConfig.exe"publishextension/vsixfilepath:"< Azure VSIX ファイルのパス >"

    • TFS 2018 の

      "C:\Program を Team Foundation Server 2018\Tools\TfsConfig.exe"publishextension/vsixfilepath:"< Azure VSIX ファイルのパス >"

メモ拡張機能を適用した後に、すべての Team Foundation サーバーまたはコンピューターを再起動する必要はありません。 

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