現象
次のような状況を考えます。
-
Windows Server 2012 R2 ドメイン環境では、ドメインのメンバー サーバーのグループがあります。これらのメンバー サーバーは、(gMSA) を使用する 1 つまたは複数のサービスを実行しています。
-
サービスを実行するために使用されるユーザーのパスワードが自動的に更新します。
このシナリオでは、いくつかのサービス、gMSA でできないことがありますパスワードの変更後すぐに短い期間ログに記録します。サービスのダウンタイムが発生します。さらに、サービスには、「アクセスが拒否されました」エラーが返されます。
原因
この問題は、パスワードの変更がすべてのドメイン コント ローラーにレプリケートされた後に発生します。ただし、gMSA サーバーがパスワード ロール オーバー期間中に短い時間、古いパスワードを使用するされます。GMSA サーバーがこのような状況で、更新されたパスワードを持つドメイン コント ローラーにログオンしようとすると、「アクセスが拒否されました」エラーが返されます。
解決策
この問題を解決するには、Windows Server 2012 R2 の更新プログラムのロールアップ、または修正プログラムをリリースしました。
更新プログラムのロールアップは、修正プログラムで修正される問題に加えて他の多くの問題を修正します。更新プログラムのロールアップを使用することをお勧めします。更新プログラムのロールアップは、この修正プログラムよりサイズが大きいです。したがって、更新プログラムのロールアップのダウンロードにはより長い時間がかかります。
Windows Server 2012 R2 の更新プログラムのロールアップを取得します。この問題を解決するのには、2014年 11 月日にリリースされた更新プログラムのロールアップをインストールします。
Windows Server 2012 R2 の修正プログラムを取得します。サポートされている修正プログラムは、マイクロソフトのサポートから使用できます。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この修正プログラムは、この資料に記載された問題があったシステムのみに対して適用してください。この修正プログラムは、今後さらにテストを行う場合があります。したがって、この問題の影響が深刻でない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことをお勧めします。
修正プログラムをダウンロードできる場合は、このサポート技術情報の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、マイクロソフト カスタマー サービス サポートにお問い合わせのうえ、修正プログラムを入手してください。