現象
Microsoft SQL Server 2008 または SQL Server 2008 R2 で、透過的なデータ暗号化 (TDE) が有効になっているデータベースがあることを前提として、データベースに対する書き込み操作が、WRITELOG または LOGBUFFER で無限に待機します。 データベースが完全回復モードであり、スケジュールされたログバックアップが定期的に実行されている場合、SQL Server のエラーログの最初と最後のログシーケンス番号 (LSN) 番号は、問題が発生した後の元のログバックアップでも同じです。 この期間中にユーザーアクティビティが予期されるかどうかを確認することもお勧めします。 ユーザーアクティビティがないために発生した書き込み操作がないため、LSN 番号が変更されないことがあります。 SQL Server の関連するエラーログエントリは次のとおりです。
ログがバックアップされました。 データベース: <DataBaseName>、作成日 (時刻): <date><時刻>、最初の lsn: 76383:11154:1、最後の lsn: 76383:11154:1.... これは情報メッセージだけです。 ユーザー操作は必要ありません。ログがバックアップされました。 データベース: <DataBaseName>、作成日 (時刻): <date><時刻>、最初の lsn: 76383:11154:1、最後の lsn: 76383:11154:1.... これは情報メッセージだけです。 ユーザー操作は必要ありません。
この問題は、完全回復モードのデータベースに固有のものではありません。他の回復モードのデータベースでも、同じ問題が発生する可能性があります。 さらに、システムテーブルの sysprocessesで、SPID がロールバック状態になっていることもあります。
原因
この問題は、TDE に関するいくつかの基本的な例外が原因で発生します。
解決方法
この問題は、SQL Server の次の累積的な更新プログラムで最初に修正されました。 この修正プログラムを適用した後、SQL Server は、問題が発生したときにデータベースをオフラインにします (WRITELOG または LOGBUFFER を無期限に待つ代わりに)、SQL Server サービスを再起動しなくても、データベースをオンラインに戻すことができます。 一部のシナリオでは、ユーザーの介入なしに SQL Server によってデータベースが自動的にオンラインに戻ります。 関連情報は、SQL Server のエラーログに記録されます。この修正プログラムを実行しても、問題は解決されません。 ただし、問題が再発した場合、追加の診断情報 (種類とエラーの重大度に基づく) が SQL Server のエラーログに記録されることがあります。 実際の例外を特定して修正する必要があります。そのためには、修正プログラムを適用した後に入手できる追加の診断情報を参照してください。
SQL Server 2008 R2 SP2 の累積更新プログラム13 /en-us/help/2967540
SQL Server 2008 SP3 の累積更新プログラム17 /en-us/help/2958696
SQL Server 用の新しい累積更新プログラムには、以前の累積的な更新プログラムに含まれていたすべての修正プログラムとすべてのセキュリティ修正が含まれています。 SQL Server の最新の累積的な更新プログラムを確認します。
状態
マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。