メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

現象

次のような状況で問題が発生します。

  • Microsoft SQL Server 2016、2014、または2012を使用している。

  • AlwaysOn 可用性グループの一部であるデータベースを使用しています。

  • プライマリレプリカでは、サイズを小さくするためにデータベースファイルを圧縮します。

  • プライマリレプリカは、トランザクションログに記録されているすべての変更をセカンダリレプリカに送信します。

  • セカンダリレプリカでは、redo スレッドによって、トランザクションログから可用性グループの一部であるデータベースに変更が適用されます。

このシナリオでは、レプリカは中断されます。さらに、次のようなエラーメッセージが表示されることがあります。

<タイムスタンプ> spid41s エラー: 3456、レベル:21、状態: 1. <タイムスタンプ> spid41s は、ログレコード (#) を再実行できませんでした。トランザクション ID (#)、ページ (#)、データベース ' <dbname> ' (データベース ID #)。 ページ: LSN = (#)、アロケーションユニット = #、type = #。 ログ: オペコード = #、context #、PrevPageLSN: (#) データベースのバックアップから復元するか、データベースを修復します。 <タイムスタンプ> spid41s AlwaysOn 可用性グループデータベース ' <dbname> ' のデータ移動は、次の理由で中断されました: "system" (ソース ID 2;ソース文字列: ' SUSPEND_FROM_REDO ')。 データベースでデータの移動を再開するには、データベースを手動で再開する必要があります。 可用性データベースを再開する方法については、「SQL Server Books Online」を参照してください。 <タイムスタンプ> spid41s エラー: 3313、深刻度:21、状態: 2> <. データベース ' <dbname> ' でログに記録された操作をやり直しているときに、エラーがログレコード ID (#) で発生しました。 通常、特定のエラーは、Windows イベントログサービスでエラーとして記録されています。 完全バックアップからデータベースを復元するか、データベースを修復します。

原因

この問題は、データベースエンジンがシステムページ (GAM、PFS) で注文前の LSNs を検出した場合に、やり直し処理中に変更が適用されると発生します。

解決方法

この問題は、SQL Server の次の累積的な更新プログラムで最初に修正されました。

SQL Server 用の新しい累積更新プログラムには、以前の累積的な更新プログラムに含まれていたすべての修正プログラムとすべてのセキュリティ修正が含まれています。 SQL Server の最新の累積的な更新プログラムをダウンロードしてインストールすることをお勧めします。

この更新プログラムにより、この問題が発生しなくなります。 問題が既に発生している場合は、次の手順に従って AlwaysOn 可用性グループに再度参加します。

  1. 既存の AlwaysOn セカンダリレプリカを削除します。

  2. 影響を受けたデータファイルに対して、次のコマンドを実行して、データベースから割り当てられていない領域を削除します。

    DBCC SHRINKFILE(<file_id>, TRUNCATEONLY)

  3. データベースとログファイルをバックアップします。

  4. データベースとログを AlwaysOn セカンダリレプリカに復元します。

  5. AlwaysOn 可用性グループに参加します。

状態

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

関連情報

ソフトウェアの更新を説明するために Microsoft が使用する 用語 について説明します。

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×