現象
Microsoft CRM 1.2、Microsoft Business Solutions-CRM 1.0、または Microsoft Dynamics CRM 3.0 で、次のエラーメッセージが表示されます。
ユーザー認証が無効です。 プラットフォームに渡されたユーザー認証が有効ではありません。
このエラーメッセージは、次のいずれかの操作を行った後に表示されます。
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Microsoft CRM にログオンします。
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Microsoft CRM ユーザーのビジネスユニットを変更します。
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Microsoft CRM の Outlook (Outlook クライアント) でオンラインに移動します。
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Outlook 用 Microsoft CRM 3.0 クライアントで、いずれかの Microsoft CRM フォルダーをクリックします。
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Microsoft CRM 3.0 レコードをマージしようとしています。
原因
原因1
この問題は、以下のいずれかまたは複数の条件に該当する場合に発生することがあります。
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役割は、プログラムのユーザーに割り当てられません。
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ユーザーレコードの部署が最近プログラムで変更されています。 Microsoft CRM 1.2、microsoft Business Solutions-CRM 1.0、および Microsoft Dynamics CRM 3.0 でビジネスユニットが変更されると、ユーザーに割り当てられていたすべての役割が削除されます。 また、Microsoft Dynamics CRM 3.0 では、ビジネスユニットが変更された場合、コンピューターを再起動するまで、Outlook 用 Microsoft Dynamics CRM クライアントで変更を利用することはできません。
原因2
この問題は、Microsoft CRM server コンピューターアカウントが Active Directory PrivUserGroup グループと SQLAccessGroup グループのメンバーでない場合に発生する可能性があります。
原因3
この問題は、結合される下位レコードを所有するユーザーが Active Directory から削除された場合に発生することがあります。
解決方法
解決方法 1
Microsoft CRM 1.2、Microsoft Business Solutions-CRM 1.0、Microsoft Dynamics CRM 3.0
この問題を解決するには、適切な役割をユーザーに割り当てます。 これを行うには、次の手順を実行します。
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システム管理者の役割を持つユーザーとして Microsoft CRM にログオンします。
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[ ホーム] をクリックし、[設定] をクリックし、[ 事業単位の設定] をクリックして、[ ユーザー] をクリックします。
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問題が発生したユーザーレコードをダブルクリックします。
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[ ロール] をクリックし、[ ロールの管理] をクリックして、このユーザーに適切なロールを選択します。
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[ OK] をクリックし、[ 保存して閉じる] をクリックします。
Outlook クライアントでオンラインに移行したときに "Symptoms" セクションに記載されているエラーメッセージが表示され、ユーザーに割り当てられている部署を変更した場合は、次の手順に従います。
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ユーザーが Outlook クライアントでオフラインになっていることを確認します。
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Microsoft CRM で、ユーザーの部署を元の事業単位に変更します。 これを行うには、次の手順を実行します。
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Microsoft CRM を開き、[ ホーム]、[ 設定]、[ ビジネスユニットの設定]、[ ユーザー] の順にクリックします。
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ユーザーレコードをダブルクリックします。
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[ アクション] をクリックし、[ 事業単位の変更] をクリックします。
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ユーザーに割り当てられていた元の事業単位をクリックし、[ OK] をクリックして、[ 保存して閉じる] をクリックします。
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Outlook クライアントで、[ オンラインにする] をクリックします。
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オンラインになったら、Microsoft CRM でユーザーの部署を変更します。
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Microsoft Office Outlook を終了して、もう一度開きます。
解決方法 2
この問題を解決するには、コンピューターアカウントを PrivUserGroup グループに追加し、さらに Active Directory の SQLAccessGroup グループに追加します。
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ドメインコントローラーで、[Active Directory ユーザーとコンピューター] を起動します。
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[ PrivUserGroup] を右クリックし、[ プロパティ] をクリックします。
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[ メンバー ] タブをクリックし、[ 追加] をクリックして、CRM server コンピューターアカウントを追加します。
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[Active Directory ユーザーとコンピューター] で、[ Sqlaccessgroup] を右クリックし、[ プロパティ] をクリックします。
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[ メンバー ] タブをクリックし、[ 追加] をクリックして、CRM server コンピューターアカウントを追加します。
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Microsoft CRM server で [ スタート] をクリックし、[ 実行] をクリックして、「 cmd」と入力します。
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コマンドプロンプトで「 iisreset」と入力します。
解決方法 3
この問題を解決するには、下位レコードを有効な Microsoft CRM ユーザーに割り当てます。
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Microsoft CRM を起動します。
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結合する下位レコードをダブルクリックします。
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[ アクション] をクリックし、[ 割り当て] をクリックして、[ 別のユーザーに割り当て] をクリックします。
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ユーザーの一覧から新しい所有者を選択し、[ OK] を2回クリックします。
参照情報
この記事では、技術文書31789について説明しました。