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現象

Microsoft Dynamics CRM を使用しながら、オンプレミス ユーザー必要があります認証の資格情報を 24 時間に 1 回。Microsoft Dynamics CRM Outlook クライアントのユーザーと web クライアントの両方のユーザーの可能性があります。

これは、クレーム認証を有効になっている展開にのみ発生します。

原因

この問題の原因の 1 つクレームは、24 時間の値に設定されて SessionSecurityTokenLifetimeInHours を設定します。これは、既定値です。

解決策

SessionSecurityTokenLifetimeInHours を設定する要求は、24 以外のものに更新する必要があります。この例では、1 週間に設定します。

1. Dynamics CRM 探索ロールがインストールされているサーバー、PowerShell コマンド ウィンドウを開きます。
2. ウィンドウから次のコマンドを実行します。

$Settings = get CrmSetting-SettingType ClaimsSettings DwsServerUrl https://CrmDiscoverServer.domain.com ・ $creds の資格情報
$Setting.SessionSecurityTokenLifetimeInHours = '168'
セット-CrmSetting-DwsServerUrl https://CrmDiscoverServer.domain.com -$creds を $setting に資格情報

3. が終わったら、なったことを確認の有効期間値 168 を実行して、以下のコマンドです。

Get-CrmSetting-SettingType ClaimsSettings DwsServerUrl https://CrmDiscoverServer.domain.com ・ $creds の資格情報

4. 次に、フロント エンド サーバーで IIS を再起動します。
5. 最後に、現象のセクションで定義されている問題が発生しているすべてのユーザーに対して Outlook を再起動します。

メモ:

上記の例では、URL のhttps://CrmDiscoverServer.domain.comは、Microsoft Dynamics CRM の展開での検出のサーバーの役割を持つサーバーの URL を更新する必要があります。

ユーザーの資格情報の認証プロンプトをも発生するで、次の手順を実行するには、このプロンプトで発生 7 日間 Outlook またはお使いのブラウザーを再起動しない限り。再起動する Outlook のブラウザーは、セキュリティ トークンを自動的に更新され、認証プロンプトを表示しないようにできます。

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