現象
Microsoft Dynamics CRM 2011 では、Microsoft Dynamics CRM 組織に多数のユーザーやチームがあることを想定しています。 Microsoft Dynamics CRM 組織内のセキュリティ ロールを変更すると、タイムアウト エラーが発生します。 さらに、次のエラー メッセージは、プラットフォームのトレースに表示されます。
MessageProcessor は、'役割' のメッセージ 'ReplacePrivileges' の処理に失敗します。
System.InvalidOperationException: ExecuteReader には、開いていると使用可能な接続が必要です。 接続の現在の状態を終了します。
System.InvalidOperationException: Microsoft Dynamics CRM には、エラーが発生しました。
エラー メッセージ: 要求がタイムアウトになりました。
エラーの詳細: 要求がタイムアウトになりました。
原因
この問題は、ユーザーおよびチームにセキュリティ ロールの変更が伝達されることにより発生します。
解決方法
この問題を Microsoft Dynamics CRM 2011 の最新の累積的な更新プログラムのロールアップで解決します。Microsoft Dynamics CRM 2011 の最新の累積的な更新プログラムのロールアップに関する詳細については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックします。
2555051 Microsoft Dynamics CRM 2011 の更新プログラムおよび修正プログラム 注: この問題は、Microsoft Dynamics CRM 2011 の更新プログラム ロールアップ 3 で最初修正されました。Microsoft Dynamics CRM 2011 の更新プログラムのロールアップ 3 については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックします:
2547347 Microsoft Dynamics CRM 2011 の更新プログラム ロールアップ 3 があります。
状態
マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。
詳細情報
ソフトウェア更新プログラムに関する用語の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
824684 マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明Microsoft ビジネス ソリューションの CRM ソフトウェアの修正プログラムと更新プログラム パッケージの用語の詳細については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックします。
887283 Microsoft ビジネス ソリューションの CRM ソフトウェアの修正プログラムと更新プログラム パッケージの名前付け規則