現象
[Debtor/Creditor Maintenance Options ] ウィンドウまたは [会社のセットアップ オプション ] ウィンドウをクリックして開くと、[税の登録] フィールドが空白のままで、国コードが GB の場合、ウィンドウを閉じることはできません。 次のメッセージが示されています。
有効な税登録番号を入力してください。
[税の登録] フィールドで OB 番号の検証に失敗しました。
原因
国コードが会社/負債者/クレジット者に対して 'GB' に設定され、VAT Daybook がインストールされている場合は、 税登録 フィールドで検証が実行されます。 国コード GB の税登録フィールドを空白にすることはできません。 (VAT Daybook アクセスは Microsoft Dynamics GP |ツール|セットアップ |システム |VAT Daybook を使用します。)
ほとんどの場合、ユーザーは税登録番号を入力しましたが、正しい形式で入力しませんでした。 文字やスペースを含めることはできません。
解決方法
[税の登録] フィールドに入力する必要がある場合は、次の点を確認してください。
オプション 1 - 有効な税登録番号 があり、まだこのメッセージが表示されている場合は、Dynamics GP に誤って入力している可能性があります。 このフィールドに対して検証が実行され、数字を文字やスペースなしで入力する必要があります。
例:
会社には独自の一意の税登録番号が必要です。
たとえば、税登録番号が GB 999 9999 73 の場合
次のように、Microsoft Dynamics GP の [税登録] フィールドに入力 999999973
(文字またはスペースなし)
オプション 2 - 'sa' ログインでテストし、システム管理者が同じウィンドウで同じエラーを受け取るかどうかを確認します。 そうでない場合は、ユーザー ID が破損している可能性があります。 問題のあるユーザーのセキュリティを新しい一時ユーザー ID にコピーし、ユーザーに同じ問題が発生するかどうかを確認します。 そうでない場合は、問題のユーザー ID を削除し、設定し直します。
[税の登録] フィールドを "空白" にする必要がある場合、回避策は次のとおりです。
オプション 1 - [Debtor] または [Creditor Maintenance Options] ウィンドウまたは [会社のセットアップ オプション] ウィンドウでスタックしている場合は、[オプション] ウィンドウをドラッグして、メインの [Debtor] ウィンドウまたは [クレジット メンテナンス] ウィンドウまたは [会社のセットアップ] ウィンドウで [GB] の国コードを削除します。 ( 'GB' の国コードをクリア した後、変更を受け入れるにはフィールドを TAB オフにする必要があります)。 これで、[オプション] ウィンドウを閉じることができます。 [Debtor/Creditor/Company] ウィンドウに 'GB' の国コードをもう一度再入力し、[保存] をクリックします。 (CR 86997)
オプション2 - VAT Daybook を使用していない場合は、Microsoft Dynamics GP |に移動して、そのアクセスを無効または削除できます。ツール|セットアップ |システム |VAT 日帳を使用し、会社の [VAT 日帳を使用する] 列のチェック ボックスをオフにします。