現象
Business Portal を起動すると、ユーザー名とパスワードの入力を求めるメッセージが表示される場合があります。 この問題は、次の製品で発生します。
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Microsoft Dynamics GP のビジネス ポータル
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Microsoft Business Solutions のビジネス ポータル - Great Plains
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Microsoft Dynamics SL のビジネス ポータル
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Microsoft Business Solutions のビジネス ポータル - Solomon
原因
原因 1
この問題は、IIS (IIS) の構成設定Microsoft インターネット インフォメーション サービス発生する可能性があります。 「解決策」セクションの「解決策 1」を参照してください。
原因 2
この問題は、Microsoft Internet Explorer の構成設定が原因で発生している可能性があります。 「解決策」セクションの「解決策 2」を参照してください。
原因 3
この問題は、ユーザーロールとWindows SharePointロールが正しく同期されていない場合に発生する可能性があります。 「解決策」セクションの「解決策 3」を参照してください。
原因 4
この問題は、ユーザーが削除され、Active Directory ディレクトリ サービスで同じユーザー名を使用して再追加された場合に発生する可能性があります。ユーザーのセキュリティ ID (SID) は、Active Directory のセキュリティ ID (SID) が Windows SharePoint Services (WSS) に記載されているのとは異なる場合があります。 「解決策」セクションの「解決策 4」を参照してください。
原因 5
この問題は、問題が発生している特定のユーザーの Ntuser.dat ファイルが破損している場合に発生する可能性があります。 「解決策」セクションの「解決策 5」を参照してください。
原因 6
この問題は、会社のロゴがビジネス ポータルのページに追加され、ユーザーがロゴを含むファイルに対する NTFS ファイル システムのアクセス許可を持たないことです。 「解決策」セクションの「解決策 6」を参照してください。
原因 7
この問題は、ユーザーが *.aspx ファイルの物理ファイルに対する適切 ASP.NET 場合に発生する可能性があります。 「解決策」セクションの「解決策 7」を参照してください。
原因 8
この問題は、Web アプリケーションで Kerberos SharePoint使用している場合に発生する可能性があります。 「解決策」セクションの「解決策 8」を参照してください。
解決策
解決方法 1
IIS で構成設定を確認するには、次の手順に従います。
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ローカルの管理アクセス許可を持つユーザーとして IIS を実行しているサーバーにログオンします。
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[ スタート] をクリックし 、[実行] をクリックし、「inetmgr」と入力して 、[OK] をクリックします。
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ビジネス ポータルがインストールされている Web サイトを右クリックし、[プロパティ] をクリック します。
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[ディレクトリ セキュリティ ] タブをクリック します。
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[認証 とアクセス制御] ウィンドウで、[ 編集] を クリックします。
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[Integrated Windows Authentication] チェック ボックスをオンにし、[OK] をクリックします。
注意 このウィンドウWindows [統合認証] チェック ボックスがオンの唯一のチェック ボックスである必要があります。 IIS で基本認証が有効になっている場合は、そのセッションで Web サイトにアクセスする度にログオンするように求Internet Explorerされます。 ダイジェスト認証が有効になっている場合は、Web サイトにアクセスする度にログオンするように求めるメッセージも表示されます。 ただし、ダイジェスト認証には Active Directory が必要であり、ユーザー名とパスワードは暗号化されます。 -
Business Portal がインストールされている Web サイトを展開し、BusinessPortal仮想ディレクトリを右クリックし、[プロパティ] をクリックして、このセクションの前の手順 5 から 7 を繰り返します。
解決方法 2
次の手順に従って、Internet Explorer構成設定を確認します。
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このInternet Explorer、ビジネス ポータルでローカル イントラネット ゾーンと信頼済みサイト ゾーンの 2 つを使用するかどうかを決定します。 これを行うには、Business Portal を起動し、ビジネス ポータル サイトの [Internet Explorer] ウィンドウの右下隅に表示されているゾーンをメモします。
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[ツール ] をクリックし、[インターネット オプション] をクリックし、[セキュリティ] タブ をクリック します。
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Business Portal で使用するゾーンに応じて、[ローカルイントラネット]または [信頼済みサイト] をクリックし、[カスタム レベル]をクリックします。
注意 このセクションの前の手順 1 を参照して、Business Portal で使用するゾーンを決定してください。 -
すべてのオプションが [有効ActiveXに設定してください。
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[ユーザー 認証] セクション で、[現在の ユーザー名と パスワードを使用した自動ログオン] チェック ボックスがオンに設定されています。
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キャッシュから正しくないパスワードを消去するには、適切な手順を使用します。
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Windows Internet Explorer 7 を使用している場合は、[全般]タブをクリックし、[削除] をクリックして、[パスワードの削除]をクリックします。
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Windows Internet Explorer 6 を使用している場合は、[コンテンツ]タブをクリックし、[オートコンプリート] をクリックして、[パスワードのクリア]をクリックします。
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[議論] オプションが 有効になっていないか確認Internet Explorer。 これを行うには、[表示] を クリックし、[ エクスプローラーバー] をクリックし、[議論] の横にあるチェック マークをクリックして削除 します。
注意 問題Internet Explorer発生しているユーザーごとに、ワークステーションごとに構成する必要があります。
解決方法 3
この問題を解決するには、Business Portal でロール同期を実行します。 この場合、次の手順を実行します。
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すべての会社のビジネス ポータルで管理者ロールが割り当てられているユーザーとして、Business Portal を起動します。
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[サイトの設定をクリックし、[ユーザーとアクセス許可]をクリックし、[ロールの管理] をクリックし、[ロールの同期の確認] をクリックします。
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[すべて ] をクリックし、[チェック] を クリックします。
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エラーが報告された場合は、[更新] を クリックします。
注意 この機能は、Microsoft Dynamics GP 10.0 の Business Portal または Microsoft Dynamics SL 7.0 の Business Portal には存在しません。
解決策 4
この問題を解決するには、ValidateBPUser ユーティリティを実行して、無効な SID を持つユーザーを特定します。 この場合、次の手順を実行します。
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ValidateBPUser.exeユーティリティをダウンロードします。 このユーティリティをValidateBPUser.exe、次の Microsoft Web サイトにアクセスしてください。
https://mbs.microsoft.com/fileexchange/?fileID=8069b581-a52b-4705-90c7-0ed728fe0b9e注意 ビジネス ポータルを実行しているコンピューターにユーティリティをダウンロードします。
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特定の環境に基づいて、ValidateBPusers.exe.configの次の 2 つのパラメーターを変更します。
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WebServerRootUrl
ビジネス ポータルをホストしている URL です。 たとえば、Business Portal を既定の Web サイトにインストールした場合、URL は http://IISComputerName。 -
BusinessPortalBPSharePointRootSiteUrl これは、サイト ルート URL SharePoint
ビジネス ポータルです。 これは、ファイル内の wssObjectModelSiteURL パラメーターBusinessFramework.configします。
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ValidateBPUser.exe ユーティリティを実行します。 これを行うには、次の手順に従います。注: BP 管理者 (すべての会社) ロールが割り当てられているビジネス ポータル ユーザーとしてユーティリティ
を実行してください。 ユーザーが BP 管理者ロールに割り当てられていない場合は、ユーザー名とパスワードの入力を求められます。-
MS-DOS ウィンドウで、ユーティリティを保存したディレクトリに移動し、コマンド プロンプトで次のコマンドを入力します。
validateBPUsers.exe詳細
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ウィンドウを閉じるには、「exit」と入力します。
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ユーティリティは、新しいBusinessPortalSharepointSIDMismatches.xmlします。 このファイルには、Active Directory の SID が、アクティブ ディレクトリ内の SID に対応していないすべてのユーザーがWSS。 既定では、このファイルは次のフォルダーにあります。
C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN
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一致しない SID を持つユーザーがファイルに含まれている場合は、Microsoft Dynamics のテクニカル サポートにお問い合わせください。
解決策 5
破損した Ntuser.dat ファイルを解決するには、ユーザー プロファイルを再作成します。ユーザー プロファイルを再作成する方法の詳細については、次の記事番号をクリックして、Microsoft サポート技術情報の記事を表示します。
811151 破損したユーザー プロファイルから新しいプロファイルにデータをコピーする方法
解決策 6
この問題を解決するには、ロゴを含むファイルに対するフル コントロール NTSF アクセス許可をユーザーに付与します。 この場合、次の手順を実行します。
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ロゴを含むファイルを探します。 これを行うには、[サイト名] をクリック設定、[全般] 設定 をクリックし、[ポータルロゴの変更] をクリックします。
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ファイルを右クリックし、[プロパティ] を クリックします。
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[セキュリティ] タブで 、[追加] を クリックします。
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[選択するオブジェクト名を入力してください] 領域に、メッセージが表示されるユーザーの名前を入力し、[名前の確認] をクリックして、[OK]をクリックします。
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[アクセス 許可] 領域で 、[フル コントロール ] オプションの [ 許可] をクリック し 、[OK] をクリックします。
解決策 7
この問題を解決するには、Web サイトで使用されるすべての物理ファイルに対する explicate 権限を与える必要があります。 または、引き続きエラーが発生するかどうかを確認するテストとして、ユーザーを Business Portal コンピューターのローカル管理者にしてください。
解決策 8
この問題を解決するには、Business Portal Web アプリケーションの NTLM 認証を有効にします。 これを行うには
、Sharepoint 3.0 の適切なバージョンに対して次の手順 に従います。-
Business Portal サーバーで 、[スタート] をクリックし、[コントロール パネル] をクリックし、[管理ツール] をクリックして、[SharePoint 3.0 サーバーの全体管理] をクリックします。
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[アプリケーション管理] タブをクリックします。
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[アプリケーション セキュリティ] で、[認証プロバイダー] をクリックします。
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右上隅で Business Portal Web アプリケーションが選択されている必要があります。
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[既定] をクリックします。
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[IIS 認証] 設定、[統合認証] チェック ボックスWindowsオンにしてください。 また、NTLM が選択されている必要があります。
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[保存] をクリックします。
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IIS を再起動します。
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ビジネス ポータルを起動し、問題がまだ発生するかどうかを確認します。
Sharepoint 2010
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Business Portal サーバーで、[スタート] をクリックし、[すべてのプログラム] をクリックし、[SharePoint 2010 製品] をクリックし、[SharePoint 2010 サーバーの全体管理] をクリックします。
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[Web アプリケーションの管理] をクリックします。
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ビジネス ポータル Web アプリケーションがインストールされているサイトをクリックして強調表示します。
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[セキュリティ] セクションで、[ 認証プロバイダー] をクリックし、[既定] を クリックします。
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[IIS Authentication 設定 セクションで、[Integrated Windows authentication] チェック ボックスがオンに設定されています。 また、NTLM が選択されている必要があります。
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[保存] をクリックします。
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IIS を再起動します。
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ビジネス ポータルを起動し、問題がまだ発生するかどうかを確認します。