Microsoft Business Solutions-Navision 4.0 および Microsoft Navision 4.0 は、Microsoft Dynamics NAV 4.0 の一部です。 Microsoft Business Solutions-Navisionまたは Microsoft Navision 4.0 へのすべての参照は、Microsoft Dynamics NAV に関連します。
現象
Microsoft Dynamics NAV を実行しているコンピューターで、次のエラー メッセージが表示される場合があります。
[TableName] テーブルを読み取 るアクセス許可が付与 されていない。 アクセス許可を変更する必要がある場合は、システム マネージャーにお問い合わせください。
注意 エラー メッセージの [TableName] は、Microsoft Dynamics NAV 内の任意のテーブルの名前にできます。
原因
この問題は、Microsoft Dynamics NAV が、手動または C/AL コードを使用してアクセスされるテーブルのアクセス許可をチェックするために発生します。 この検証は、テーブルが使用されていない場合や空の場合でも行われます。
注意 この問題は、Microsoft Dynamics NAV 4.0 より前のバージョンでは発生しません。
解決策
この問題を解決するには、テーブルの読み取りアクセス許可をユーザーに付与します。 これは、使用されていないテーブルに対しても行います。 これを行うには、次の手順に従います。
-
[ツール] メニューの [セキュリティ] をクリックし、[ロール] をクリックし、[アクセス許可] をクリックします。
[ アクセス許可] テーブルが表示されます。 -
[オブジェクトの 種類] 列で 、[テーブル データ] を選択します。
-
[オブジェクト ID] 列 に、テーブル番号を入力します。
-
[はい] が次のアクセス許可の横にのみ表示されます。
-
読み取りアクセス許可
-
実行アクセス許可
注意 他のすべてのアクセス許可から "はい" を削除します。
-
-
テーブルを閉じます。