現象
オンラインモードで Microsoft Outlook を使用して特定のメールメッセージにアクセスすると、RPC クライアントアクセスサービスが予期せずクラッシュまたは再開します。 この問題が発生すると、次のエラーがイベントログに記録されます。 注: 場合によっては、イベントのエントリがまだ記録されているにもかかわらず、サービスがクラッシュしないことがあります。次の場所に保存されている RCA ログにログが記録されます。
C:\Program Files\Microsoft\Exchange \ 15 \ ログイン \ RPC クライアントアクセス2015-04-23T19:05:35.961Z,3,603,/o=<id>/ou=exchange administrative group(fydibohf23spdlt)/cn=recipients/cn=5dd9b1444df54688b0d2367fbc5e47aa-crashmbx,,OUTLOOK.EXE,15.0.4711.1000,Classic,,,,ncacn_http,Client=MSExchangeRPC,,,,fault,00:00:00.2970000,,"Watson: [IndexOutOfRangeException] Index was outside the bounds of the array. at M.E.D.TextConverters.Internal.Format.FormatStore.TextStore.AddText(TextRunType runType, Char[] textBuffer, Int32 offset, Int32 count) at M.E.D.TextConverters.Internal.Format.FormatStore.AddMarkupText(Char[] textBuffer, Int32 offset, Int32 count) at M.E.D.TextConverters.Internal.Html.HtmlFormatConverterWithEncapsulation.OutputEncapsulatedMarkup() at M.E.D.TextConverters.Internal.Html.HtmlFormatConverterWithEncapsulation.Process(HtmlTokenId tokenId) at M.E.D.TextConverters.ConverterStream.Read(Byte[] buffer, Int32 offset, Int32 count) at M.E.D.TextConverters.Internal.RtfCompressed.RtfCompressCommon.ReadMoreData() at M.E.D.TextConverters.Internal.RtfCompressed.RtfCompressConverter.Run() at M.E.D.TextConverters.ConverterStream.Read(Byte[] buffer, Int32 offset, Int32 count) at M.E.D.S.BodyReadStream.<>c__DisplayClassb.<Read>b__a() at M.E.D.S.ConvertUtils.<>c__DisplayClass1`1.<CallCtsWithReturnValue>b__0() at M.E.D.S.ConvertUtils.CallCts(Trace tracer, String methodName, LocalizedString exceptionString, CtsCall ctsCall) at M.E.D.S.ConvertUtils.CallCtsWithReturnValue[T](Trace tracer, String methodName, LocalizedString exceptionString, CtsCallWithReturnValue`1 ctsCall) at M.E.D.S.BodyReadStream.Read(Byte[] buffer, Int32 offset, Int32 count) at M.E.D.S.Util.StreamHandler.CopyStreamData(Stream readStream, Stream writeStream, Nullable`1 numBytes, Int32 t",,,.in,
原因
この問題は、TextConverter でバッファーコピー操作が実行されるときに、 textconverterクラスで発生するロジックエラーが原因で発生します。
解決方法
この問題を解決するには、Exchange Server 2013 の累積更新プログラム 14またはexchange server 2013 の累積的な更新プログラム14 をインストールします。
回避策
この問題を回避するには、RCA ログを使用して、サービスの停止を引き起こすメールボックスを特定します。 その後、メールボックスユーザーは Outlook の設定をオンラインモードからキャッシュモードに変更することをお勧めします。 また、ユーザーが特定のメールメッセージを直接、または Outlook のルールを使用して、.pst またはローカルフォルダーにコピーまたは移動しないようにします。 問題の原因となっているメッセージを特定するには、すべてのメッセージを .pst ファイルに1つずつコピーまたは移動します。 移動できないメッセージは、問題の原因であることを示しています。 この問題が発生すると、接続が失われたり、RPC クライアントアクセスサービスがクラッシュしたりする原因になります。
状態
マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。