Applies ToWindows 8.1 Windows 8.1 Enterprise Windows 8.1 Pro

現象

8.1 の Windows ベースのコンピューターでは、Runtimebroker.exe プロセスがクラッシュします。また、Runtimebroker.exe プロセスがクラッシュした後、Windows ストアに接続されていないことを示すエラー メッセージが表示されます。この問題は、次の 1 つまたは複数の条件に該当する場合に発生します。

  • Microsoft Visual Studio または Microsoft PowerShell から Windows ストア アプリの開発者ライセンスを取得しようとするとします。

  • アプリケーションで購入のユーザー インターフェイス (UI) を呼び出すしようとする前に、アプリの価格が表示されます。

  • アプリケーションの完全なバージョンに、アプリケーションの試用版を変換しようとするとします。

  • アプリの購入価格を取得しようとするとします。

  • アプリケーションの領収書を取得しようとするとします。

  • 禁止されたアプリ一覧を更新しようとするとします。

原因

この問題は、コンピューターに古いバージョンの WSShared.dll ファイルが格納されているために発生します。したがって、WSShared.dll ファイルでは、コンピューターに保存されている WinStoreUI.dll ファイルの新しいバージョンが一致しません。

解決策

更新プログラムの情報

この更新プログラムの入手方法

この更新プログラムは Windows Update から入手できます。

必要条件

この更新プログラムを適用するには Windows 8.1 を実行しなければなりません。

レジストリ情報

このパッケージの更新プログラムを使用するのには、レジストリを変更する必要はありません。

再起動の必要性

この更新プログラムを適用した後、コンピューターを再起動する必要があります。

更新プログラムの置き換えに関する情報

この更新プログラムを適用しても、以前にリリースされた更新プログラムが置き換えられることはありません。

詳細

ソフトウェア更新プログラムの用語の詳細については、次の文書番号をクリックして、マイクロソフト サポート技術情報の資料を参照してください。

824684マイクロソフトのソフトウェア更新プログラムを記述するために使用される一般的な用語説明

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