メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

現象

次のような状況を考えます。

  • Windows Server 2008 R2、Windows Server 2008 または Windows Server 2003 を実行しているコンピューター上には、Windows 展開サービス (WDS) サーバーの役割をインストールします。

  • Windows 展開サービスの 1 つまたは複数のオペレーティング システム イメージを展開するのにには、ローカル エリア ネットワーク (LAN) で、Windows 7 のブート イメージまたは Windows Server 2008 R2 のブート イメージを使用します。

  • 基に、ACPI プロセッサ (ACPI APIC UP) ハードウェア アブストラクション レイヤー (HAL) か、ACPI APIC の HAL (ACPI APIC MP) HAL を ACPI マルチプロセッサを使用するクライアントにイメージを展開しようとするとします。

このシナリオでは、イメージは表示されない利用可能なオペレーティング システム イメージのメニューに展開プロセス中にします。したがって、クライアントにイメージを展開することはできません。

注: 起動イメージを Windows Server 2008 と Windows Vista のブート イメージにも、この問題が発生します。の詳細については、マイクロソフト サポート技術情報の記事を表示するのには次の資料番号をクリックします:

935772 ACPI APIC の HAL のオペレーティング システム イメージを展開できませんブート イメージに Windows Vista または Windows Server 2008 のブート イメージは、展開プロセスで使用される場合

原因

Wdsclient.dll モジュールで Wdsclient.dll モジュールは、利用可能なオペレーティング システム イメージのメニューを表示するときに、ACPI APIC を HAL に基づいているイメージが誤って除外されているために、問題が発生します。

解決策

修正プログラムの情報

サポートされている修正プログラムは、マイクロソフトから入手可能です。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この修正プログラムは、この資料に記載された問題があったシステムのみに対して適用してください。この修正プログラムは、今後さらにテストを行う場合があります。したがって、この問題の影響が深刻でない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことをお勧めします。

修正プログラムをダウンロードできる場合は、このサポート技術情報の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、マイクロソフト カスタマー サービス サポートにお問い合わせのうえ、修正プログラムを入手してください。

注: さらなる問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストの作成が必要な場合があります。この修正プログラムの対象外の追加の質問および問題については、通常のサポート料金が適用されます。マイクロソフト カスタマー サービス サポートの電話番号一覧または別のサービス リクエストの作成については、次のマイクロソフト Web サイトを参照してください。

http://support.microsoft.com/contactus/?ws=support注: [修正プログラムのダウンロード] フォームには、修正プログラムが提供されている言語が表示されます。お使いの言語が表示されない場合は、その言語の修正プログラムが利用できないためです。

必要条件

このパッケージの修正プログラムを使用するために、レジストリを変更する必要はありません。

  • Windows Server 2003 Service Pack 2 (SP2)

  • Windows サーバー 2008

  • Windows Server 2008 Service Pack 2 (SP2)

  • Windows Server 2008 R2

  • Windows 7 の場合

  • Windows Vista Service Pack 1 (SP1)

注: これらは、オペレーティング システムを Windows 7 の Windows 自動インストール キット (Windows AIK) をインストールすることができます。Windows 7 のブート イメージまたは Windows Server 2008 R2 のブート イメージに修正プログラムを適用するのにには、Windows 7 の Windows AIK を使用します。

レジストリ情報

この修正プログラムを適用しても、以前にリリースされた修正プログラムが置き換えられることはありません。

再起動の必要性

この修正プログラムの適用後にコンピュータを再起動する必要はありません。

修正プログラムの置き換えに関する情報

この修正プログラムを適用しても、以前にリリースされた修正プログラムが置き換えられることはありません。

ファイル情報

この修正プログラムのグローバル版では、次の表に示す各属性を持つファイル群がインストールされます。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。お使いのローカル コンピューター上にあるこれらのファイルの日付および時刻は、現在の夏時間 (DST) との差と一緒にローカル時刻で表示されます。また、ファイルに対して特定の操作を実行すると、日時が変更される場合があります。

Windows 7 および Windows Server 2008 R2 のファイル情報メモ

重要 Windows 7 の修正プログラム、および Windows Server 2008 R2 の修正プログラムは、同じパッケージに収められています。ただし、修正プログラムのリクエスト ページにある修正プログラムは各オペレーティング システムの下に一覧表示されています。一方または両方のオペレーティング システムに適用される修正プログラム パッケージをリクエストするには、ページ上の "Windows 7/Windows Server 2008 R2" の下に一覧表示されている修正プログラムを選択します。必ず資料の「対象製品」を参照して、各修正プログラムの適用対象である実際のオペレーティング システムを確認してください。

X86 ベースの Windows 7 ブート イメージの

ファイル名

ファイル バージョン

ファイル サイズ

日付

時刻

プラットフォーム

Wdsclient.dll

6.1.7600.20650

532,480

21-Feb-2010

15:55

x86

X64 ベースの Windows 7 のイメージを起動し、Windows Server 2008 R2 の x64 ベースのイメージを起動します

ファイル名

ファイル バージョン

ファイル サイズ

日付

時刻

プラットフォーム

Wdsclient.dll

6.1.7600.20650

624,128

21-Feb-2010

16:09

x64

Windows Server 2008 R2 の IA 64 ベースのブート イメージの

ファイル名

ファイル バージョン

ファイル サイズ

日付

時刻

プラットフォーム

Wdsclient.dll

6.1.7600.20650

1,351,680

21-Feb-2010

15:03

IA-64

状況

マイクロソフトは、この問題を「対象製品」セクションに記載されているマイクロソフト製品の問題として認識しています。

詳細

Windows 7 または Windows Server 2008 R2 のブート イメージ ファイルの 2 番目のイメージには、この修正プログラムを適用する必要があります。そのためには、以下の手順を実行します。

注: 2 番目のイメージは、Windows プレインストール環境 (Windows PE) イメージです。

  1. Windows 展開サービス サーバーで、Windows 7 の Windows 自動インストール キット (AIK) をインストールします。
    Windows 7 の Windows AIK を取得するには、次のマイクロソフト web サイトを参照してください:http://www.microsoft.com/downloads/details.aspx?familyid=696DD665-9F76-4177-A811-39C26D3B3B34&displaylang=en
    注: Windows AIK の Windows 7 でサポートされているオペレーティング システムを実行している別のコンピューターに Windows 7 の Windows AIK をインストールすることもできます。

  2. [スタート] ボタン すべてのプログラム] をクリックして、 Microsoft Windows AIK展開ツールのコマンド プロンプトを右クリックをクリックし、[管理者として実行] を選択します。

    UAC 管理者のパスワードまたは確認を求められる場合は、パスワードを入力、または確認します。

  3. 抽出、Windows6.1 ・ KB980711 ・プラットフォームの .cab ファイルの修正プログラム パッケージを一時フォルダーです。これを行うには、以下の手順を実行します。

    1. [スタート] ボタン 、[実行] をクリックして、 「cmd」と入力し、 OKをクリックしますします。

    2. コマンド プロンプトで、次のコマンドを入力し、ENTER キーを押します。

      Expand.exe CabFilePath ・ R ・ f: * TempFolderPath注:

      • CabFilePathプレース ホルダーは、CAB ファイルのパスを表します。

      • TempFolderPathプレース ホルダーは、一時フォルダーのパスを表します。

  4. 更新処理でダウンロードで使用できないようにするのには問題のあるブート イメージを無効にします。これを行うには、Windows 展開サービス Microsoft 管理コンソール (MMC) スナップインを開き、更新するブート イメージを右クリックし、無効にするを選択し。

  5. BootWimPathに、Windows 展開サービス サーバーから問題のあるブート イメージをエクスポートします。これを行うには、ブート イメージを右クリックし、イメージのエクスポートを選択し、します。 BootWimPathには、ブート イメージをエクスポートします。

    注:

    • BootWimPathプレース ホルダーは、Boot.wim ファイルのエクスポート先のローカル ディレクトリを表します。

    • 別のコンピューターに Windows AIK をインストールする場合は、Boot.wim ファイルをそのコンピューター上のディレクトリにコピーしてください。次に、そのコンピューターに手順 6 から手順 8 を実行します。

  6. 読み取りアクセスおよび書き込みアクセスのためのブート イメージをマウントします。これを行うには、コマンド プロンプトで次のコマンドを入力し、ENTER キーを押します。

    dism/mount-wim/wimfile:BootWimPath /index:2/mountdir:MountLocation注:

    • MountLocationプレース ホルダーは、イメージをマウントする場所を表します。

    • ブートのインデックス番号が 2 では、イメージをマウントすることを確認します。

  7. TempFolderPathフォルダーから Wdsclient.dll ファイルを次のフォルダーにコピーします。

    • MountLocation\Windows\Winsxs\Platform_microsoft-windows-imagebasedsetup-media_ID

    • MountLocation\sources

    注:

  8. のプレース ホルダーの値の例は、31bf3856ad364e35_6.1.7600.16385_none_6fe42cf3e82ff497 です。

  9. Boot.wim ファイルをアンマウントし、すべての変更をコミットします。これを行うには、コマンド プロンプトで次のコマンドを入力し、ENTER キーを押します。

    Dism.exe /unmount-wim /mountdir:MountLocation /commit

  10. Windows 展開サービス サーバーに、更新された Boot.wim ファイルを追加します。これを行うには、Windows 展開サービス MMC スナップインを開き、ブート イメージを右クリックし、ブート イメージの追加を選択および更新された Boot.wim ファイルへのパスを指定し、

  11. Windows 展開サービス MMC スナップインでは、それが有効であるかどうかを確認するのには追加したブート イメージを右クリックします。

    注: 無効にするか、問題のあるブート イメージを削除する必要があります。

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×