UML クラス図を作成する

適用先
Visio Plan 1 Visio Professional 2024 Visio Professional 2021 Visio Professional 2019 Visio Professional 2016

UML クラス図を作成して、システムのクラス、その属性とメソッド、オブジェクト間の関係の静的ビューを表示できます。 アプリケーションの概要を説明します。

個人顧客向けの銀行の会計システムを示す UML クラス図のサンプル。

新しいクラス図を開始すると、UML 2.5 標準に準拠した図形と共に UML クラス ステンシルが表示されます。

(Visio の Professional エディションには UML クラス図とステンシルのサポートが含まれますが、Standard エディションにはサポートされていません)。

  1. Visio を起動します。 または、既にファイルを開いている場合は、[ ファイル>新規作成] をクリックします。
  2. [検索] ボックスに「 UML class」と入力します。
  3. UML クラス図を選択します。
  4. ダイアログ ボックスで、空のテンプレートまたは 3 つのスターター図のいずれかを選択します。 (選択すると、各項目の説明が右側に表示されます。)次に、[ メートル法 ] または [米国単位] を選択します。
  5. [作成] を選択します。
  6. ダイアグラムが開きます。 図の横に [図形] ウィンドウが表示されるはずです。 表示されない場合は、[表示] >[作業ウィンドウ] に移動し、[図形] が選択されていることを確認します。 それでも表示されない場合は、左側の [図形の展開 ] ウィンドウ ボタンをクリックします。
  7. [表示] タブで、[接続ポイント] の横のチェック ボックスがオンになっていることを確認します。 このオプションをオンにすると、図形の接続を開始するときに接続ポイントが表示されます。
  8. 次に、図に取り込みたい図形を、[図形] ウィンドウからページにドラッグします。 テキスト ラベルの名前を変更するには、ラベルをダブルクリックします。
  9. クラス、列挙、またはインターフェイスの図形にメンバーを追加するには、メンバー図形を図形パネルからそれぞれの図形にドラッグします。 既存のメンバーを右クリックして、メンバーを挿入するオプションを選択して、新しいメンバーを追加することもできます。
    既存のメンバーを右クリックし、メンバーを挿入するオプションを選択して、新しいメンバーを追加します。
  10.  UML コネクタで 2 つの図形を接続し、図形間のリレーションシップを表します。 リレーションシップの種類を変更するには、コネクタを右クリックします。 [ コネクタタイプの設定 ] メニューから目的のリレーションシップを選択します。
    コネクタを右クリックし、[コネクタの種類の設定] を選択して、コネクタの種類のオプションを表示します。
  11.  クラス、列挙、またはインターフェイス図形のサイズを変更するには、図形ヘッダーをクリックして選び、黄色のコントロール ポイント (図形の右端) を左右に動かして図形の幅を狭めたり増やしたりします。
  12.  クラス図形にパラメーター フィールドとステレオタイプ フィールドを追加するには、図形を選択して右クリックし、ポップアップ メニューから対応するオプションを選択します。
    図形を右クリックして、クラス図形にパラメーター フィールドとステレオタイプ フィールドを追加します。

クラス図を作成するためのヒント

  • 各要素とその関係を特定します。
  • 各クラスが何を担当しているかを明確に特定します。
  • 複雑になりすぎる可能性がある不要なプロパティを図に含めないでください。

クラス表記

記号 意味
⁠-⁠ 属性または操作がプライベートです。
⁠+⁠ 属性または操作がパブリックです。

関連項目

Visio での UML 図