UML ステート マシン図を作成する

適用先
Visio Plan 1 Visio Professional 2024 Visio Professional 2021 Visio Professional 2019 Visio Professional 2016

UML ステート マシン図を作成して、設計されたシステムの一部の動作を示すことができます。

オブジェクトがイベントにどのように応答するかは、オブジェクトの状態によって異なります。 ステート マシン図は、外部刺激に対する物体の応答を表します。 オブジェクトには、コンピューター プログラム、デバイス、またはプロセスがあります。

ATM システムを示す UML ステート マシン図のサンプル。

まず、Visio のバージョンに応じて、UML 2.5 または 2.0 標準に準拠した図形を持つステート マシン ステンシルに付属する UML ステート マシン 図を開きます。

  1. Visio を起動します。 または、既にファイルを開いている場合は、[ ファイル>新規作成] をクリックします。
  2. [検索] ボックスに「 UML state machine」と入力します。
  3. UML ステート マシン図を選択します。
  4. ダイアログ ボックスで、[ メートル法 ] または [米国単位] を選択します。
  5. [作成] を選択します。
  6. ダイアグラムが開きます。 図の横に [図形] ウィンドウが表示されるはずです。 表示されない場合は、[表示] >[作業ウィンドウ] に移動し、[図形] が選択されていることを確認します。 それでも表示されない場合は、左側の [図形の展開 ] ウィンドウ ボタンをクリックします。
  7. [表示] タブで、[接続ポイント] の横のチェック ボックスがオンになっていることを確認します。 これで、図形の接続を開始すると、接続ポイントが表示されます。
  8. 次に、図に取り込みたい図形を、[図形] ウィンドウからページにドラッグします。 テキスト ラベルの名前を変更するには、ラベルをダブルクリックします。

関連項目

Visio での UML 図