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Symptômes

Considérez le scénario suivant. Par défaut, la recherche Exchange est activée pour une base de données de boîtes aux lettres dans un environnement Microsoft Exchange Server 2010. Vous utilisez Microsoft Outlook en mode en ligne pour rechercher un mot clé ou une expression contenant une lettre ou un chiffre unique dans une boîte aux lettres. Dans ce scénario, vous recevez le message d’erreur suivant, même s’il existe des correspondances pour le mot clé dans la boîte aux lettres :

Aucun résultat trouvé pour lemot-clé. Par ailleurs, l’événement suivant est enregistré dans le journal de l’application :

Nom du journal : ApplicationSource : MSExchangeIS Mailbox Store : ID d’événement de Date: 9877Task catégorie : content IndexingLevel : ErrorKeywords : ClassicUser : N/AComputer : description de l' ordinateur: fonction d’indexation du contenu « CISearch :: EcGetRowsetAndAccessor » a reçu un code d’erreur inhabituel et inattendu de MSSearch. Base de données Mailbox : code d’erreur de base de données de boîte aux lettres: 0x80041606

Remarque : 0x80041606 = QUERY_E_TOOCOMPLEX

Cause

Ce problème survient parce que la recherche Exchange a une limite de recherche de préfixe codée en dur de nœuds 200 000 pour une recherche de caractère unique. Lorsque la recherche d’un préfixe dépasse cette limite, la recherche renvoie QUERY_E_TOOCOMPLEX.Par conséquent, 0x80041606 est enregistré dans le cadre de l’ID d’événement 9877. Par défaut, toutes les recherches qui utilisent le mode Outlook Online dans un environnement Exchange 2010 sont des recherches préfixées. L’utilisation de chiffres ou de lettres uniques entraîne la recherche par le système de tous les nombres ou mots qui commencent par un chiffre ou une lettre dans l’ensemble de la base de données de boîte aux lettres. Si la limite par défaut de 200 000 nœuds est atteinte, la recherche renvoie l’erreur.Remarque La méthode la plus courante pour atteindre la limite de 200 000 pour les nœuds consiste à rechercher un mot ou une expression contenant un chiffre unique ou une lettre. Il y a également d’autres causes moins courantes, telles que la saisie de recherches très complexes avec de nombreux ANDs, ors et procéder. Par ailleurs, les combinaisons complexes de plages de dates et de termes de recherche, de nombreuses entrées dans les champs à et de ou d’une combinaison de ces éléments peuvent entraîner l’atteinte de la limite.

Résolution

Pour résoudre ce problème, installez la mise à jour cumulative suivante :

2608646 Description de la mise à jour cumulative 6 pour Exchange Server 2010 Service Pack 1 Important Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour plus de protection, effectuez une sauvegarde du Registre avant de le modifier. Vous serez alors en mesure de le restaurer en cas de problème. Pour plus d'informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

322756 Comment sauvegarder et restaurer le Registre dans Windows   Après avoir installé le correctif de mise à jour, procédez comme suit pour définir le nombre maximal de nœuds de restriction de requête sur 1 million (décimal) :

  1. Vérifiez le nombre d’ID d’événement 9877 avec les événements 0x80041606 dans le journal des applications reçu sur un serveur de boîte aux lettres Exchange Server 2010 particulier au cours du mois précédent, puis créez un enregistrement du numéro.

  2. Cliquez sur Démarrer .windows icontapez regedit dans la zone Démarrer la recherche , puis appuyez sur entrée.

  3. Recherchez la clé de Registre suivante et cliquez dessus :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\ExSearch

  4. Cliquez sur modifier, pointez sur nouveau, puis cliquez sur clé.

  5. Tapez MaxRestrictionNodes, puis appuyez sur entrée.

  6. Sous MaxRestrictionNodes, cliquez sur modifier, pointez sur nouveau, puis cliquez sur valeur DWORD.

  7. Tapez Asr, puis appuyez sur entrée.

  8. L’entrée de registre doit maintenant ressembler à ce qui suit : HKEY_LOCAL_MACHINE \SOFTWARE\Microsoft\ExchangeServer\v14\ExSearch\MaxRestrictionNodes\Server

  9. Cliquez sur modifier, puis sur modifier.

  10. Dans la zone données de la valeur , tapez 1 million (décimal). Remarque La valeur par défaut de l’entrée MaxRestrictionNodes\Server est 200000 (décimal) avant d’apporter des modifications au registre.

  11. Fermez l'Éditeur du Registre.

Remarques

  • Après avoir redémarré le service Microsoft Exchange Search Indexer, archivez l’application pour les ID d’événement suivants :

    • ID d’événement 130 échec de la conversion du GUID MailboxDB lu depuis la clé de Registre MaxRestrictionNodes vers un GUID

    • ID d’événement 131 échec de l’ouverture de la clé de Registre MaxRestrictionNodes

    • ID d’événement 132 échec de la définition de la propriété MaxRestrictionNodes dans l’indexeur

  • Si vous recevez l’un de ces événements, il est possible que vous ayez entré la clé de registre ou la valeur DWORD de manière incorrecte. Il est possible que vous n’ayez pas correctement orthographié la nouvelle clé ou la valeur DWORD. Apportez les corrections nécessaires, puis redémarrez le service Microsoft Exchange Search Indexer. Recherchez les nouvelles instances d’ID d’événement 130, 131 ou 132.

  • Consultez le journal des applications hebdomadaire et mensuel qui dépend du nombre d’ID d’événement 9877 avec l’erreur 0x80041606 dans le journal de l’application.

  • Si vous continuez à recevoir un nombre important de ces événements, vous pouvez augmenter la valeur de façon incrémentielle sur 2 millions (décimal).

  • Ne augmentez pas la valeur au-delà de 2 millions (décimal), car cela risque de réduire les performances du serveur.

  • Si vous avez augmenté la valeur de 2 millions (décimal) et que vous recevez toujours quelques-uns de ces événements par semaine ou par mois, il s’agit du comportement attendu. Ce comportement pourrait être dû au fait que les utilisateurs effectuent des recherches très complexes (voir la section « symptômes » pour plus d’informations).

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.

Informations supplémentaires

Pour plus d’informations sur la recherche Exchange, visitez le site Web de Microsoft suivant :

Informations générales sur la recherche ExchangePour plus d’informations sur la désactivation ou l’activation de la recherche Exchange, visitez le site Web Microsoft suivant :

Informations générales sur la désactivation ou l’activation de la recherche ExchangePour plus d’informations sur l’entrée MaxRestrictionNodes , visitez le site Web Microsoft suivant :

Informations générales sur l’entrée MaxRestrictionNodes

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