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Symptômes

Lorsque vous utilisez la commande shutdown pour essayer d’arrêter ou de redémarrer un ordinateur Microsoft Windows Server 2003 à distance, l’ordinateur ne s’arrête pas.

Par exemple, lorsque vous tapez shutdown /s /m \\ nom_ordinateur /t 003
à partir d’un ordinateur distant, un des messages d’erreur suivants peut s’afficher :

nom_ordinateur: l’ordinateur traite une autre action et par conséquent le ne peut pas être arrêté. Attendre que l’ordinateur ait terminé son action et essayez à nouveau. (21)



Périphérique n’est pas prêt

Cause

Ce problème peut se produire si vous utilisez Connexion Bureau à distance avec le commutateur /console pour ouvrir la session de console (session 0) de l’ordinateur Windows Server 2003, puis vous utilisez Fermer la session pour mettre fin à la connexion. Par exemple, le problème peut se produire si vous suivez ces étapes dans l’ordre indiqué :

  1. Utilisez connexion Bureau à distance pour se connecter à distance à la session de console de l’ordinateur Windows Server 2003. Pour ce faire, cliquez sur Démarrer, sur exécuter, tapez mstsc /console dans la zone Ouvrir , puis cliquez sur OK. Tapez le nom de l’ordinateur, puis cliquez sur se connecter.

  2. Une fois la session de console s’ouvre, cliquez sur Démarrer, puis cliquez sur Fermer la session pour déconnecter la session de console.

  3. À partir d’une invite de commande, tapez shutdown /r /m \\ nom_ordinateur /t 003
    à partir de l’ordinateur distant, pour redémarrer l’ordinateur à distance.

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone service clientèle de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l’adresse suivante :

http://support.microsoft.com/contactus/?ws=supportRemarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

Conditions préalables

Aucunes conditions préalables ne sont requises.

Nécessite un redémarrage

Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace aucun autre correctif.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriés dans le temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet Fuseau horaire dans l’outil Date et heure dans le Panneau de configuration.
Date Time Version Size File name
------------------------------------------------------------
07-Jan-2004 00:58 5.2.3790.116 540,160 Winlogon.exe

Solution de contournement

Pour contourner ce problème, appliquez l’une des méthodes suivantes :

  • Déconnectez la session console au lieu de fermer la session. Par exemple, cliquez sur le bouton Fermer la session de console et puis, lorsque vous recevez le message suivant, cliquez sur OK pour confirmer l’action :

    Ceci déconnectera votre session Windows. Vos programmes continueront à s’exécuter pendant que vous êtes déconnecté. Vous pouvez vous reconnecter à cette session ultérieurement en vous connectant à nouveau.

  • Utiliser une connexion Bureau à distance sans la console switch pour vous connecter à l’ordinateur Windows Server 2003.

Pour arrêter le serveur à distance une fois que ce problème s’est déjà produite, utilisez Connexion Bureau à distance pour vous reconnecter au serveur et puis utilisez le bouton Fermer pour se déconnecter du serveur. Vous pouvez ensuite utiliser la commande shutdown pour arrêter ou pour redémarrer le serveur à distance.

État

Microsoft a confirmé qu’il s’agit d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à » de cet article.

Plus d'informations

Pour plus d’informations sur l’utilisation de connexion Bureau à distance avec Windows Server 2003, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

814585 comment faire : connecter des clients aux Services Terminal Server dans Windows Server 2003



Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft

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