Symptômes
Dans un environnement Microsoft Exchange Server 2010, vous exécutez la cmdlet Enable-Mailbox pour créer une boîte aux lettres d’un utilisateur Active Directory existant. Toutefois, l’alias de boîte aux lettres de l’utilisateur contient le caractère « ? » inattendue. Ce problème se produit lorsque les conditions suivantes sont remplies :
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Vous exécutez la cmdlet Enable-Mailbox sans le paramètre Alias .
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Le nom complet de l’utilisateur contient le caractère «, ».
Cause
Ce problème se produit parce que la cmdlet Enable-Mailbox dans Exchange Server 2010 génère l’alias de boîte aux lettres de l’utilisateur basée sur le nom complet de l’utilisateur lorsque le paramètre Alias n’est pas spécifié. Toutefois, le caractère «, » n’est pas un caractère valide pour le paramètre Alias . Par conséquent, si le nom d’affichage contient ce caractère, Exchange Server 2010 convertir le caractère sur le caractère « ? ».
Résolution
Pour résoudre ce problème, installez le correctif cumulatif suivant :
Description de du correctif cumulatif 2 pour Exchange Server 2010 Service Pack 1
Solution de contournement
Il existe deux méthodes pour contourner ce problème.
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En utilisant la console de gestion Exchange :
Vous pouvez activer une boîte aux lettres pour un seul compte d’utilisateur à la fois. Cela vous permet de spécifier l’alias de boîte aux lettres. Pour plus d’informations sur la façon d’activer une boîte aux lettres d’un utilisateur existant dans la console de gestion Exchange, visitez le site Web Microsoft suivant :
Boîtes aux lettres activation de Remarque Pour plus d’un utilisateur à la fois ne vous permet pas de spécifier les attributs d’alias de boîte aux lettres. Les alias de boîte aux lettres peuvent être générés correctement par Exchange Server 2010. -
À l’aide d’Exchange Management Shell :
Vous pouvez spécifier le paramètre Alias lorsque vous exécutez la cmdlet Enable-Mailbox dans Exchange Management Shell. Pour plus d’informations sur la cmdlet Enable-Mailbox , visitez le site Web Microsoft suivant :
État
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».