Microsoft로 로그인
로그인하거나 계정을 만듭니다.
안녕하세요.
다른 계정을 선택합니다.
계정이 여러 개 있음
로그인할 계정을 선택합니다.

소개

AD DS (active Directory 도메인 서비스)는 Active Directory에서 만든 사용자, 컴퓨터, 그룹 및 트러스트에 고유한 Sid (보안 식별자)를 할당 합니다. Sid는 단순하게 증가 하는 RID (상대 식별자)와 연결 되는 도메인 접두사로 구성 됩니다. 각 Active Directory 도메인에는 10억 Rid로 구성 된 전역 RID 풀이 할당 됩니다. 각 Active Directory 도메인 컨트롤러가 새 보안 사용자를 만들 수 있도록 하기 위해 각 도메인 컨트롤러는 RID 마스터에서 현재 및 대기 RID 풀을 할당 합니다. 도메인의 글로벌 RID 풀과 도메인의 개별 도메인 컨트롤러에 있는 로컬 풀을 모두 사용 하는 경우, 더 이상 도메인에 사용자, 컴퓨터 및 그룹을 추가로 만들 수 없습니다. 이 문제를 해결 하려면 개체 및 응용 프로그램을 만들어 새 도메인으로 마이그레이션할 수 있습니다. 이 문서에서는 논리 오류로 인해 RID 풀 요청이 너무 많은 경우 발생할 수 있는 상황에 대해 설명 합니다. 이로 인해 글로벌 RID 풀 소모를 야기 하 게 됩니다.

증상

드문 경우 지만 Active Directory 도메인 컨트롤러에 많은 양의 RID 리소스가 소모 될 수 있습니다. 이 동작은 전역 RID 풀을 소모 합니다. 이 문제가 발생 하면 다음 문제 중 하나가 발생할 수 있습니다.

  • 전역 RID 풀의 Rid는 시간에 따라 지속적으로 사용 됩니다.

  • 글로벌 RID 풀에서 사용 되는 Rid 수가 예상 보다 크므로 도메인 수명 동안 의도적으로 만들어진 보안 주체의 수를 고려 합니다.

  • DCDIAG RID Manager 테스트는 RidSetReferences 특성 검색에 실패 했음을 나타냅니다. 또한 다음과 같은 오류 메시지가 나타납니다.

    테스트 시작: RidManager 경고: #b0에 rIdSetReferences 특성이 없습니다. CN =name, OU = 도메인 컨트롤러, dc =name, dc =name, dc =name, dc =이름 Rid 집합 참조를 가져올 수 없습니다. 8481에서 실패 했습니다. 검색에서 데이터베이스의 특성을 검색 하지 못했습니다. ......................... RidManager 테스트 실패 이름

KB 2618669의 핫픽스는 Windows Server 2008 R2 기반 도메인 컨트롤러에서이 동작을 감지 하 고 방지할 수 있는 기능을 제공 합니다.

이 동작은 다음의 RTM 릴리스에 포함 됩니다. 

  • Windows Server 2019 이후 출시 된 OS 버전

  • Windows Server 2019

  • Windows Server 2016

  • Windows Server 2012 R2

  • Windows Server 2012

원인

드문 경우 지만, 도메인 컨트롤러가 글로벌 RID 풀에서 30 초 마다 Rid에 대 한 되풀이 요청을 실행할 수 있습니다. RID 풀 업데이트에 대 한 반복 요청을 오랜 시간 동안 계속 하도록 허용 하는 경우 전역 RID 풀에 너무 많은 RID 사용량이 발생할 수 있습니다. 극단적인 경우 전역 RID 풀이 완전히 모두 소모 될 수 있습니다.

해결 방법

전역 RID 풀에서 너무 많은 RID 사용량을 방지 하려면 다음 작업을 수행 하는 것이 좋습니다.

  • 모든 기존 Windows Server 2008 R2 도메인 컨트롤러에서 (9 월 2016, KB3185278) 다음에 릴리스된 최신 월간 업데이트를 설치 합니다.

  • 업데이트를 Windows Server 2008 R2 설치 미디어에 통합 합니다. 이렇게 하면 이후 도메인 컨트롤러에도이 업데이트가 적용 됩니다.

  • RTM 릴리스에서이 기능을 포함 하는 최신 OS 버전에 Active Directory 역할을 배포 합니다.

핫픽스 정보

Microsoft에서 지원 되는 핫픽스를 구할 수 있습니다. 그러나이 핫픽스는이 문서에서 설명 하는 문제만 해결 하기 위한 것입니다. 이 문서에서 설명 하는 문제가 발생 하는 시스템에만이 핫픽스를 적용 하세요. 이 핫픽스에는 추가 테스트가 표시 될 것입니다. 따라서이 문제의 영향이 심각 하지 않으면이 핫픽스를 포함 하는 다음 소프트웨어 업데이트가 나올 때까지 기다리는 것이 좋습니다. 핫픽스를 다운로드할 수 있는 경우이 기술 자료 문서 맨 위에 있는 "핫픽스 다운로드 가능" 섹션을 참조 하세요. 이 섹션이 표시 되지 않으면 Microsoft 고객 지원 서비스에 문의 하 여 핫픽스를 구합니다. 참고 추가 문제가 발생 하거나 문제 해결이 필요한 경우 별도의 서비스 요청을 만들어야 할 수 있습니다. 이 특정 핫픽스에 한정 되지 않는 추가 지원 질문 및 문제에는 일반적인 지원 비용이 적용 됩니다. Microsoft 고객 서비스의 전체 목록 및 지원 전화 번호를 확인 하거나 별도의 서비스 요청을 만들려면 다음 Microsoft 웹 사이트를 방문 하세요.

http://support.microsoft.com/contactus/?ws=support 참고 "핫픽스 다운로드 가능" 양식에는 핫픽스를 사용할 수 있는 언어가 표시 됩니다. 언어가 표시 되지 않으면 해당 언어에 대 한 핫픽스를 사용할 수 없기 때문입니다.

상태

Microsoft는 "적용 대상" 절에 나열한 제품에서 이 문제를 확인했습니다.

추가 정보

소프트웨어 업데이트 용어에 대 한 자세한 내용은 다음 문서 번호를 클릭 하 여 Microsoft 기술 자료 문서를 참조 하세요.

824684 Microsoft 소프트웨어 업데이트를 설명하는 데 사용되는 표준 용어에 대한 설명

도움이 더 필요하세요?

더 많은 옵션을 원하세요?

구독 혜택을 살펴보고, 교육 과정을 찾아보고, 디바이스를 보호하는 방법 등을 알아봅니다.

커뮤니티를 통해 질문하고 답변하고, 피드백을 제공하고, 풍부한 지식을 갖춘 전문가의 의견을 들을 수 있습니다.

이 정보가 유용한가요?

언어 품질에 얼마나 만족하시나요?
사용 경험에 어떠한 영향을 주었나요?
제출을 누르면 피드백이 Microsoft 제품과 서비스를 개선하는 데 사용됩니다. IT 관리자는 이 데이터를 수집할 수 있습니다. 개인정보처리방침

의견 주셔서 감사합니다!

×