Microsoft로 로그인
로그인하거나 계정을 만듭니다.
안녕하세요.
다른 계정을 선택합니다.
계정이 여러 개 있음
로그인할 계정을 선택합니다.

증상

이 핫픽스는 두 특정 현상을 해결합니다.

  • 볼륨 섀도 복사본 서비스 작성자에서 시간 초과 오류가 발생 합니다.

  • 백업 하는 동안 및 시간 동안 섀도 복사본이 손실 됩니다. 입/출력 수준이 높은 경우.

볼륨 섀도 복사본 서비스 작성자에서 시간 초과 오류가 발생

경우에 따라 백업 프로세스 동안 일부 볼륨 섀도 복사본 서비스 작성자는 백업이 발생할 시간 제한 오류로 실패할 수 있습니다. 볼륨 섀도 복사본 서비스 작성자는 프로그램이 나 섀도 복사본 저장소 영역에 정보를 저장 하려면 볼륨 섀도 복사본 서비스를 사용 하는 서비스입니다. 예를 들어, NTBackup 프로그램을 사용할 때 백업이 성공적으로 수행 되지 않을 수 있습니다 및 다음과 같은 오류 메시지가 나타날 수 있습니다.

볼륨 섀도 복사본을 만드는 동안 오류가 반환: 800423f4 (또는 값 800423f2 또는 800423f3)

볼륨 섀도 복사본 서비스 작성자 문제를 진단 하려면 백업 실패 후 즉시 vssadmin 명령을 실행 합니다.

  1. 시작을 클릭합니다 하 고을 클릭합니다
    실행합니다.

  2. Vssadmin 목록 작성기를 입력 합니다.

이 명령은 볼륨 섀도 복사본 서비스 작성자 및 각 작성자의 현재 상태를 나열합니다. 예를 들어, 출력은 Microsoft SQL Server 데스크톱 엔진 (MSDE) 또는 Microsoft Active Directory 디렉터리 서비스 기록기가 실패 했음을 나타낼 수 있습니다. 몇 가지 작가, MSDE 기록기, SQL 기록기, 새로운 기술을 디렉터리 서비스 (NTDS) 기록기, Windows 인터넷 이름 지정 시스템 (WINS) 기록기, 동적 호스트 구성 프로토콜 (DHCP) 작성자에 시간 초과 오류가 발생할 수 있는 원격 저장소 작성기, 인증 기관 기록기 및 Microsoft Exchange 기록기. 다음은 샘플 출력입니다.

C:\ VSSADMIN LIST WRITERS
[...]
작성자 이름: 'NTDS'
작성자 Id: {b2014c9e-8711-4c5c-a5a9-3cf384484757}
작성자 인스턴스 Id: {26ed439f-4a52-481d-963d-5db5b695d9e7}
상태: [10] 실패
마지막 오류: 다시 시도 가능한 오류

또한 응용 프로그램 이벤트 로그에서 검토 하 여 특정 시간 초과 오류를 확인할 수 있습니다. 몇 가지 예:

이벤트 ID: 12290
설명:
볼륨 섀도 복사본 서비스 경고: NTDS ESENT 오류 {b2014c9e-8711-4c5c-a5a9-3cf384484757}:-2402. hr = 0x00000000.

이벤트 ID: 2004
설명:
그림자 6 시간 초과 (20000ms)을 복사 합니다.

백업 하는 동안 및 시간 동안 섀도 복사본이 손실 됩니다. 입/출력 수준이 높은 경우

다른 관련된 증상은 그 그림자를 공유 네트워크 폴더의 복사본이 삭제 되었을 수 있습니다. 이 문제가 발생 하면 다음과 같은 이벤트 오류가 기록 됩니다.

이벤트 종류: 오류
이벤트 원본: VolSnap
이벤트 범주: 없음
이벤트 ID: 25
설명:


Diff 영역 파일이 적시에 확장 되지 못했습니다 볼륨 이름 볼륨의 섀도 복사본이 중단 되었습니다. 나중에이 문제를 방지 하려면이 시스템에서 IO 로드를 감소 하는 것이 좋습니다.

메시지 볼륨 이름 에 백업이 예정 된 볼륨 이름입니다.

원인

이 문서의 앞부분에서 설명 하는 현상은 다음과 같은 이유 중 하나로 인해 발생할 수 있습니다.

  • 볼륨 섀도 복사본 서비스 작성자 시간 초과

  • 섀도 복사본 삭제

  • 큰 감사 로그

볼륨 섀도 복사본 서비스 작성자 시간 초과

오랫동안 섀도 복사본을 만드는 동안 특정 볼륨 섀도 복사본 서비스 작성자의 시간이 초과 되는 문제가 발생할 수 있습니다. 특히 속도가 느린 하드 디스크, 메모리 부족 또는 낮은 CPU 속도; 하는 컴퓨터에서이 문제가 발생 또는 설치 된 컴퓨터에서 (예를 들어, 도메인 컨트롤러 컴퓨터)에서 디스크 쓰기 캐시 비활성화 합니다.

섀도 복사본을 만드는 복잡 한 프로세스 간 호출 시퀀스를 포함합니다. 프로세스 간 호출을 통해 모든 중요 한 볼륨 섀도 복사본 서비스 작성자에서 (같은 SQL, Exchange Server, 운영 체제 서비스 및 다른 프로그램) 섀도 복사본을 만드는 동안 데이터 버퍼를 플러시할 합니다. 또한 Exchange 작성자 같은 일부 볼륨 섀도 복사본 서비스 작성자에서 시간 간격 동안 섀도 복사본을 만들 수 있도록 미리 정의 된 시간 간격에 대 한 쓰기를 기다립니다. 작성자에서 섀도 복사본의 내용이 해당 데이터 버퍼와 일치 하 게 됩니다 때문에 쓰려고 대기 합니다. 그러나 CPU 속도가 낮거나, 메모리 사용 또는 입/출력 수준이 높은 없으면 다음과 같은 문제가 발생할 수 있습니다.

  • 작성자에서 데이터 버퍼를 플러시하지 않습니다.

  • 쓰기 전에 작성자에서 시간 간격을 기다리지 않습니다.

이 문제가 발생 하면 섀도 복사본이 만들어지지가 않습니다.

중요: 볼륨 섀도 복사본 서비스 작성자는 다른 조건 때문에 비슷한 오류와 함께 실패할 수 있습니다. 이러한 조건을 디스크 공간 부족 또는 컴퓨터의 부적절 한 구성에 포함 됩니다. 이 핫픽스는 백업 하는 동안 볼륨 섀도 복사본 서비스 작성자에서 임의로 발생할 수 있는 특정 시간 초과 오류만 해결 합니다. 다른 잠재적인 볼륨 섀도 복사본 서비스 오류 작성자 오류를 생성할 수 있는 이벤트 로그를 검토 하 여 것이 좋습니다.

섀도 복사본 삭제

특히 디스크 쓰기 캐시를 사용 하지 않으면 (예를 들어, 도메인 컨트롤러 컴퓨터)에 때 높은 수준의 입력/출력 경우 섀도 복사본 삭제 시키는 Volsnap.sys 드라이버에서 문제가 발생할 수도 있습니다.

기본적으로 Microsoft Windows Server 2003에 포함 된 섀도 복사본 공급자에서 섀도 복사본을 만들 백업 목적을 위해 사용 됩니다. 섀도 복사본은 기록 중 복사 구현을 사용 하 여 구현 됩니다. 차이점이 섀도 복사본 저장소 영역에 복사 됩니다. 볼륨 섀도 복사본 서비스에서 섀도 복사본 관리 도구를 사용할 수 있습니다 하거나 vssadmin 명령을 사용할 수 있습니다.

Windows Server 2003의 원본 릴리스 버전을 위해 섀도 복사본을 만드는 할당 된 초기 섀도 복사본 저장소 영역 100 mb (메가바이트) 경우 그러나 실제 사용 되는 공간은 훨씬 작습니다. 시간이 지남에 따라 할당 된 공간에 더 많은 데이터가 원래 볼륨의 수정 될 때 증가할 수 있습니다. 그러나 원래 볼륨의 입출력 트래픽이 많은 경우 섀도 복사본 저장소 영역 빠르게 늘어날 수 없습니다 충분히 기록 중 복사 변경 내용을 모두 저장 하기. 그러면 원래 볼륨의 모든 섀도 복사본이 삭제 됩니다. 이 문제는 도메인 컨트롤러 구성에서 더욱 크게 나타납니다. 기본적으로 도메인 컨트롤러 구성에서 디스크 쓰기 캐시 불가능 합니다.

중요: 유사한 문제는 모든 섀도 복사본이 삭제 되 고이 문서의 앞부분에 나열 된 이벤트 로그 오류가 기록 되는 작은 클러스터 크기를 사용 하 여 볼륨을 조각 모음 하 여 발생 합니다. 디스크 조각 모음 하는 동안 섀도 복사본이 손실에 대 한 자세한 내용은 Microsoft 기술 자료의 다음 문서 번호를 클릭 합니다.:

312067 볼륨을 조각 모음 할 때 섀도 복사본이 손실 될 수 있습니다.

또한 이벤트 오류 ID 2004 있을 때 기록 될 수 있습니다 NTFS 파일 시스템 볼륨이 손상. 이것이 문제 인지를 확인 하려면 /f 스위치와 함께 Chkdsk.exe 프로그램을 실행 합니다.

큰 감사 로그

시스템 상태를 백업 하는 동안 작성자 시간 초과 오류가 나타날 수도 감사 로그가 매우 클 경우. 백업 또는 감사 로그를 정기적으로 청소 하는 데 가장 좋습니다.

해결 방법

중요: "핫픽스 정보" 절에 설명 되어 있는 핫픽스는 다음 Microsoft 기술 자료 문서에서 설명 하는 업데이트에 포함 됩니다.

833167 A 볼륨 섀도 복사본 서비스 (VSS) 업데이트 패키지를 Windows Server 2003에 사용할 수 있는


이 문서 및 기타 VSS 관련 문제를 설명 하는 문제를 해결 하려면이 업데이트를 설치 하는 것이 좋습니다.

핫픽스 정보

이 문제를 해결 하려면 Windows Server 2003 용 최신 서비스 팩을 구하십시오. 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료의 다음 문서를 확인하십시오.

889100 는 Windows Server 2003 용 최신 서비스 팩을 구하는 방법
지원되는 핫픽스를 Microsoft에서 구할 수 있습니다. 그러나 이 핫픽스는 오직 이 문서에서 설명하는 문제를 해결하는 작업에만 사용됩니다. 이 문제가 발생하는 시스템에만 이 핫픽스를 적용해야 합니다. 이 핫픽스는 추가 테스트가 필요할 수도 있습니다. 따라서, 이 문제로 심각하게 영향을 받지 않는 경우 이 핫픽스가 포함된 다음 소프트웨어 업데이트가 나올 때까지 기다리는 것이 좋습니다.

핫픽스를 다운로드할 수 있는 경우, 이 기술 자료 문서의 상단에 "핫픽스 다운로드 가능" 섹션이 있습니다. 이 섹션이 나타나지 않으면, Microsoft 고객 지원에 문의하여 핫픽스를 얻으십시오.

참고: 추가 문제가 발생하거나 문제 해결이 필요한 경우, 별도로 서비스를 요청해야 할 수도 있습니다. 추가 지원 질문과 이 특정 핫픽스가 필요하지 않은 문제에는 일반 지원 비용이 적용됩니다. Microsoft 고객 지원 전화 번호의 전체 목록을 확인하거나 별도 서비스 요청을 만들려면 다음 Microsoft 웹 사이트를 방문하십시오.

http://support.microsoft.com/contactus/?ws=support참고: "핫픽스 다운로드 사용 가능" 형식은 핫픽스 사용이 가능한 언어를 표시합니다. 사용자 언어가 표시되지 않는 것은 핫픽스를 해당 언어로 사용할 수 없기 때문입니다.

전제 조건

전제 조건이 없습니다.

다시 시작 요구 사항

이 핫픽스를 적용 한 후 컴퓨터를 다시 시작 해야 합니다.

핫픽스 대체 정보

이 핫픽스는 다른 핫픽스를 대체하지 않습니다.

파일 정보

이 핫픽스의 영어 버전은 다음 표에 열거된 파일 특성 (또는 그 이후의 파일 특성)을 가지고 있습니다. 이러한 파일의 시간과 날짜는 협정 세계시(UTC)로 나열되었습니다. 파일 정보를 볼 때는 로컬 시간으로 변환됩니다. UTC와 로컬 시간의 시차를 찾으려면 제어판의 날짜 및 시간 항목에서 표준 시간대 탭을 사용 합니다.

Windows Server 2003, Microsoft Windows 소기업 서버 2003
Date         Time   Version      Size       File name
-------------------------------------------------------------
28-Aug-2003 19:37 5.2.3790.81 1,054,720 Esent.dll
28-Aug-2003 18:51 5.2.3790.81 271,360 Swprv.dll
28-Aug-2003 18:51 5.2.3790.81 116,736 Volsnap.sys
28-Aug-2003 18:51 5.2.3790.81 642,560 Vssvc.exe
12-Aug-2003 18:54 271 Branches.inf
28-Aug-2003 19:50 10,886 Kb826936.cat
28-Aug-2003 19:39 354 Updatebr.inf
28-Aug-2003 19:39 5,697 Update_rtmqfe.inf
Windows Server 2003 64 비트 버전
Date         Time   Version       Size       File name         Platform
-----------------------------------------------------------------------
28-Aug-2003 19:33 5.2.3790.80 2,604,544 Esent.dll IA-64
28-Aug-2003 19:33 5.2.3790.80 698,368 Swprv.dll IA-64
28-Aug-2003 18:51 5.2.3790.80 347,136 Volsnap.sys
28-Aug-2003 18:51 5.2.3790.80 1,751,040 Vssvc.exe IA-64
12-Aug-2003 18:54 271 Branches.inf
28-Aug-2003 19:49 10,886 Kb826936.cat
28-Aug-2003 19:40 354 Updatebr.inf
28-Aug-2003 19:40 5,717 Update_rtmqfe.inf

자세한 내용

중요: 이 섹션, 방법 또는 작업은 레지스트리를 수정하는 방법을 설명하는 단계를 포함합니다. 그러나, 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 따라서 다음 단계를 주의 깊게 수행해야 합니다. 추가 보호 조치로, 해당 레지스트리를 수정하기 전에 미리 백업하세요. 그런 다음, 문제가 발생할 경우 레지스트리를 복원할 수 있습니다. 레지스트리를 백업 및 복원하는 방법에 대한 자세한 내용은, Microsoft 기술 자료의 다음 문서 번호를 클릭합니다.

322756 백업 및 Windows에서 레지스트리를 복원 하는 방법

이 핫픽스는 일부 유형의 기록기 (SQL, Active Directory 및 기타) 시간 초과 오류가 발생할 가능성이 줄어듭니다. 부분적으로이 핫픽스는 입/출력 수준이 높은 경우 기본 섀도 복사 드라이버 (Volsnap.sys) 성능을 향상 하도록 설계 되었습니다. 핫픽스는 또한 섀도 복사본 저장소 영역 큰 초기 크기를 포함: 100 MB 대신 300 MB. 또한 300 MB 초기 크기가 충분 하지 않습니다 및 섀도 복사본 입/출력 수준이 높은 때문에 여전히 손실 되는 경우이 핫픽스가 포함 되어 섀도 복사본 저장소 영역 만들어질 때 섀도 복사본 저장소 영역 초기 크기를 구성할 수 있습니다. . 이 핫픽스가 제공 하는 구성 가능한 레지스트리 키 설정을 사용 하 여 섀도 복사본 저장소 영역 초기 크기를 구성할 수 있습니다.

다음이 단계를 수행 하 고 레지스트리 편집기를 종료 합니다.

  1. 시작 실행을 차례로 누르고 regedit를 입력 한 다음 확인을 누릅니다.

  2. 찾아 레지스트리에서 다음 키를 누릅니다.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VolSnap

  3. 편집 메뉴에서 가리킨
    새로 만들기, DWORD 값을 클릭 하 고.

  4. MinDiffAreaFileSize입력 하 고 enter 키를 누릅니다.

  5. 편집 메뉴를 클릭합니다
    수정합니다.

  6. 섀도 복사본 저장소 영역에 대해 원하는 크기를 입력 한 다음 확인을 클릭 합니다.

섀도 복사본 저장소 영역;의 최소 크기를 지정 하는 MinDiffAreaFileSize 레지스트리 키 기본 설정은 300 MB 이며 최대 설정은 3 기가바이트 (GB)입니다. 정확한 프로그램 설정 지정 300MB;의 배수가 되는 값 그렇지 않은 경우 300 MB의 배수로 선택 됩니다. 값이 300 300 MB 같은지 및 3, 000의 값 3 GB 같습니다.

참고: 경우 섀도 복사본이 제대로 작동 하지 않을의 값은
MinDiffAreaFileSize 레지스트리 하위 키의 섀도 복사본 저장소 영역 최대 크기 보다 큽니다. 예를 들어, 레지스트리 설정을 1024 MB로 설정 하면 백업 소프트웨어 200 MB 시스템 파티션의 스냅숏을 생성 하지 않습니다. 따라서 MinDiffAreaFileSize 레지스트리 하위 키를 만들기 전에 diff 영역 파일 300 MB 보다 큰 또는 diff 영역 파일이 레지스트리에 지정 된 값 보다 크면 있는지 확인 합니다. 또한 섀도 복사본 저장소 볼륨에 여유 공간이 300MB 이상 있는지 확인 하십시오.

상태

Microsoft는 "적용 대상" 절에 나열 된 제품의 문제 임을 확인 했습니다. 이 문제는 Windows Server 2003 서비스 팩 1에서 처음 수정 되었습니다.

도움이 더 필요하세요?

더 많은 옵션을 원하세요?

구독 혜택을 살펴보고, 교육 과정을 찾아보고, 디바이스를 보호하는 방법 등을 알아봅니다.

커뮤니티를 통해 질문하고 답변하고, 피드백을 제공하고, 풍부한 지식을 갖춘 전문가의 의견을 들을 수 있습니다.

이 정보가 유용한가요?

언어 품질에 얼마나 만족하시나요?
사용 경험에 어떠한 영향을 주었나요?
제출을 누르면 피드백이 Microsoft 제품과 서비스를 개선하는 데 사용됩니다. IT 관리자는 이 데이터를 수집할 수 있습니다. 개인정보처리방침

의견 주셔서 감사합니다!

×