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증상

다음과 같은 경우를 생각해 볼 수 있습니다.

  • Microsoft Forefront Threat Management Gateway 2010 SP1(서비스 팩 1)에서 도입된 차단된 범주 기능에 대한 사용자 오버라이드를 사용하도록 Microsoft Forefront Threat Management Gateway 2010을 구성합니다.

  • 거부 규칙을 다시 정하는 사용자를 모니터링할 수 있도록 보고서를 생성하도록 Forefront Threat Management Gateway 2010을 구성합니다.


이 시나리오에서는 맨 위에 다시 든 URL 테이블 및 최상위 규칙 사용자 테이블에 대한 요약 정보가 잘못된 정보를 표시하고 값이 예상보다 훨씬 크게 보이는 것을 발견할 수 있습니다.

원인

이 문제는 이 정보를 요약하는 저장 프로시저가 값을 잘못 누적하여 이전 날의 값이 다음 날의 값으로 롤링될 수 있기 때문에 발생합니다.

해결 방법

이 문제를 해결하려면 다음 Microsoft 기술 자료 문서에 설명된 핫픽스 패키지를 설치합니다.

2649961 이 픽스를 사용하도록 설정하려면 Forefront TMG(Threat Management Gateway) 2010 서비스 팩 2에 대한 롤업 1을 사용하여 forefront Threat Management Gateway 서버 중 하나에서 FixSoftBlockSummaries.js 스크립트를 실행합니다. Forefront Threat Management Gateway 서버, 배열 노드 또는 엔터프라이즈 관리 서버에서 이 스크립트를 실행할 수 있습니다.

이 스크립트는 사용 가능한 모든 배열을 열회하고 요약 정보가 올바르게 생성될 수 있도록 저장 프로시저를 수정합니다. 새 배열이 저장소에 추가된 경우 스크립트를 다시 실행해야 할 수 있습니다.


이 수정을 사용하도록 설정하려면 "수정"섹션으로이동하세요. 이 수정을 직접 사용하도록 설정하려면 "직접 해결"섹션으로이동하세요.

해결 지원



이 수정을 자동으로 사용하려면 수정 단추 또는 링크를 클릭합니다. 그런 다음 파일 다운로드 대화 상자에서 실행을 클릭하고 Fix it 마법사의 단계를 따릅니다.




참고 사항

  • 이 해결 솔루션을 실행하기 전에 Microsoft KB(기술 자료) 문서 2649961에 설명된 핫픽스를 설치합니다.

  • 이 마법사는 영어로만 제공될 수 있습니다. 그러나 다른 언어 버전의 Windows에서도 자동 해결 기능을 사용할 수 있습니다.

  • 현재 문제가 있는 컴퓨터에서 작업하고 있지 않은 경우 문제 수정 솔루션을 플래시 드라이브 또는 CD에 저장한 후 문제가 있는 컴퓨터에서 실행하세요.


그런 다음 "이 문제가해결되지 않았나요?" 섹션으로 이동하세요.



직접 해결

  1. 메모장 시작 메모장 시작을 클릭하고 실행을 클릭하고열기 상자에 notepad.exe 입력한 다음 확인을 클릭합니다.

  2. 다음 스크립트를 새 메모장 파일에 붙여넣습니다.

    var guidGenerator = new ActiveXObject("Scriptlet.TypeLib");
    var fpcRoot = new ActiveXObject("FPC.Root");
    try
    {
    WScript.Echo("Enumerating arrays:");
    var arraysCollection = new Enumerator(fpcRoot.Arrays);
    for (; !arraysCollection.atEnd(); arraysCollection.moveNext())
    {
    try
    {
    var array = arraysCollection.item();
    var found = false;
    WScript.Echo(" " + array.Name);
    var sumDefsCollection = new Enumerator(array.Reports.ReportSummaryDefinitions);
    for(; !sumDefsCollection.atEnd(); sumDefsCollection.moveNext())
    {
    var sumDef = sumDefsCollection.item();
    if(sumDef.Name != "spTrimArraySoftBlockSummary")
    {
    continue;
    }

    if (sumDef.AggregationStatement.indexOf("@ToDate AS [Date]") < 0)
    {
    WScript.Echo("---- spTrimArraySoftBlockSummary.AggregationStatement already contains fix, skipping array");
    break;
    }

    found = true;
    WScript.Echo("Found summary definition " + sumDef.Name + ", will fix the AggregationStatement");
    WScript.Echo("---- Old version start");
    WScript.Echo(sumDef.AggregationStatement);
    WScript.Echo("---- Old version end");
    sumDef.AggregationStatement = sumDef.AggregationStatement.replace(/@ToDate AS \[Date\]/g, "@FromDate AS [Date]");
    WScript.Echo("---- New version start");
    WScript.Echo(sumDef.AggregationStatement);
    WScript.Echo("---- New version end");
    break;
    }
    if (found)
    {
    WScript.Echo("Updating configuration ID...");
    WScript.Echo("Old configuration ID:" + array.Reports.ReportingServicesProperties.ReportingServicesConfigurationId);
    array.Reports.ReportingServicesProperties.ReportingServicesConfigurationId = guidGenerator.Guid;
    WScript.Echo("New configuration ID:" + array.Reports.ReportingServicesProperties.ReportingServicesConfigurationId);

    WScript.Echo("Saving the current configuration...");
    array.Save();
    WScript.Echo("Waiting for configuration reload...");
    array.WaitForReload();
    }
    }
    catch (err)
    {
    WScript.Echo("An error occurred. Error Decscription: " + err.description);
    WScript.Echo("Try running the script as an administrator");
    }
    }
    }
    catch (err)
    {
    WScript.Echo("An error occurred. Error Decscription: " + err.description);
    WScript.Echo("Try running the script as an administrator");
    }
  3. 파일을 파일 FixSoftBlockSummaries.js 메모장에서 종료합니다.

  4. 서버에서 관리 명령 프롬프트를 열 수 있습니다.

  5. 다음 명령을 사용하여 스크립트를 실행합니다.

    cscript.exe FixSoftBlockSummaries.js

스크립트가 완료될 때까지 기다렸다가 구성이 동기화됩니다. 그 후 거부 규칙을 다시 만든 사용자에 대한 정보가 올바르게 만들어집니다. 스크립트는 이전 요약 데이터에 대해 이 문제를 해결할 수 없습니다.

문제가 해결되었습니까?

  • 문제가 해결되었는지 확인합니다. 문제가 해결된 경우 이 섹션을 완료합니다. 문제가 해결되지 않은 경우에는 기술 지원 서비스에 문의할 수 있습니다.

  • 여러분의 의견을 기다립니다. 의견을 보내거나 이 해결 방법에 대한 문제점을 보고하려면 "Fix it for me" 블로그에 의견을 남겨 주시거나 전자 메일을 보내 주세요.

상태

Microsoft는 "적용 대상" 절에 나열한 제품에서 이 문제를 확인했습니다.

참조

소프트웨어 업데이트 용어에 대한 자세한 내용은 Microsoft 기술 자료에서 문서를 보려면 다음 문서 번호를 클릭하세요.

824684 Microsoft 소프트웨어 업데이트를 설명하는 데 사용되는 표준 용어에 대한 설명

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