Applies ToWindows Server 2019 Windows Server 2016 Windows Server 2012 R2 Windows Server 2012 Windows Server 2008 R2

증상

수백만 개의 개체를 포함 하는 대규모 포리스트의 글로벌 관련 식별자 (RID) 풀이 모두 사용 된다고 가정 합니다. 이 경우 로컬 RID 풀을 모두 사용 하는 도메인 컨트롤러에는 보안 사용자를 만들 수 없습니다. 예를 들어 사용자, 컴퓨터 또는 그룹을 만들 수 없습니다. 참고 RID 풀이 소진 되 면 경고가 표시 되지 않으며 도메인 컨트롤러에 로그가 기록 되지 않습니다. 이 핫픽스는 31 비트의 잠금을 해제 하 여 전역 RID 풀의 크기를 20억 개체로 확장할 수 있는 기능을 추가 합니다. 글로벌 RID 풀의 크기를 20억 개체로 확장 하는 지원은 Windows Server 2012, 2012 R2, 2016, 2019 이상 버전의 RTM 릴리스에 포함 되어 있습니다.

원인

이 문제는 RID 중 30 비트만 사용할 수 있기 때문에 발생 합니다.

해결 방법

이 문제를 해결 하려면 도메인 컨트롤러에서 (9 월 2016, KB3185278) 다음에 릴리스된 최신 월간 업데이트를 설치한 다음, 30 비트의 RID를 해제 합니다. 이렇게 하려면 다음 단계를 수행하세요.

  1. 도메인 컨트롤러에서 시작, 실행을 차례로 클릭 하 고 Ldp.exe를 입력 한 다음 확인을 클릭 합니다.

  2. 연결 메뉴에서 연결을 클릭 한 다음 엔터프라이즈 관리자 계정을 사용 하 여 로컬에서 연결 합니다.

  3. 찾아보기 메뉴에서 수정을 클릭 합니다.

  4. 항목 속성 편집 상자에 다음 항목을 추가 하 여 sidcompatibilityversion 특성을 1로 변경 합니다. [Add] sidCompatibilityVersion: 1

  5. Enter 키를누른 다음 실행을 클릭 합니다.

참고

  • I 번째 RID의 30 비트 잠금을 해제 하면 RID 풀 크기 한도가 20억로 확장 됩니다.

  • RID 풀 크기 제한을 구성 하려면 다음 레지스트리 키 아래의 도메인 컨트롤러에서 RID 블록 크기 값을 편집 합니다.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\RID Values\

핫픽스 정보

Microsoft에서 지원 되는 핫픽스를 구할 수 있습니다. 그러나이 핫픽스는이 문서에서 설명 하는 문제만 해결 하기 위한 것입니다. 이 문서에서 설명 하는 문제가 발생 하는 시스템에만이 핫픽스를 적용 하세요. 이 핫픽스에는 추가 테스트가 표시 될 것입니다. 따라서이 문제의 영향이 심각 하지 않으면이 핫픽스를 포함 하는 다음 소프트웨어 업데이트가 나올 때까지 기다리는 것이 좋습니다. 핫픽스를 다운로드할 수 있는 경우이 기술 자료 문서 맨 위에 있는 "핫픽스 다운로드 가능" 섹션을 참조 하세요. 이 섹션이 표시 되지 않으면 Microsoft 고객 지원 서비스에 문의 하 여 핫픽스를 구합니다. 참고 추가 문제가 발생 하거나 문제 해결이 필요한 경우 별도의 서비스 요청을 만들어야 할 수 있습니다. 이 특정 핫픽스에 한정 되지 않는 추가 지원 질문 및 문제에는 일반적인 지원 비용이 적용 됩니다. Microsoft 고객 서비스의 전체 목록 및 지원 전화 번호를 확인 하거나 별도의 서비스 요청을 만들려면 다음 Microsoft 웹 사이트를 방문 하세요.

http://support.microsoft.com/contactus/?ws=support 참고 "핫픽스 다운로드 가능" 양식에는 핫픽스를 사용할 수 있는 언어가 표시 됩니다. 언어가 표시 되지 않으면 해당 언어에 대 한 핫픽스를 사용할 수 없기 때문입니다.

레지스트리 정보

이 패키지에 핫픽스를 적용 하려면 레지스트리를 변경할 필요가 없습니다.

다시 시작 요구 사항

이 핫픽스를 적용 한 후에는 컴퓨터를 다시 시작 해야 합니다.

핫픽스 대체 정보

이 핫픽스는 이전에 릴리스된 핫픽스를 대체 하지 않습니다.

 

상태

Microsoft는 "적용 대상" 절에 나열한 제품에서 이 문제를 확인했습니다.

도움이 더 필요하세요?

더 많은 옵션을 원하세요?

구독 혜택을 살펴보고, 교육 과정을 찾아보고, 디바이스를 보호하는 방법 등을 알아봅니다.

커뮤니티를 통해 질문하고 답변하고, 피드백을 제공하고, 풍부한 지식을 갖춘 전문가의 의견을 들을 수 있습니다.