FIX:.NET Framework 3.5 s p 1에서 NetDataContractSerializer serializer와 예상 대로 버전 허용 직렬화 기능이 작동 하지 않습니다.

Microsoft 365를 사용하여 어디에서나 모든 장치에서 작업 가능

Microsoft 365으로 업그레이드하여 최신 기능 및 업데이트를 통해 어디서나 작업하세요.

지금 업그레이드

증상

Microsoft.NET Framework 3.5 서비스 팩 1 (SP1)에서 다음 시나리오를 고려 하십시오.

  • NetDataContractSerializer 클래스를 사용 하 여 제네릭 형식의 다른 버전을 가진 가능.

  • 한 버전의 제네릭 형식을 변경 하려면 버전 허용 직렬화 (VTS) 기능을 사용 합니다. 이 형식은 다른 버전과 호환 되도록 이렇게 합니다.

이 시나리오에서는 기능이 예상 대로 작동 하지 않습니다. 역직렬화에 실패 하 고 변경 된 제네릭 형식을 deserialize 될 때 예외가 발생 합니다.

해결 방법

Windows Server 2000, Windows Server 2003 및 Windows XP

이 문제를 해결 하려면 Microsoft 기술 자료 문서 976570 설명 되어 있는 핫픽스를 설치 합니다. 자세한 내용은 Microsoft 기술 자료의 다음 문서 번호를 클릭 합니다.

Windows xp 및 Windows Server 2003 용.NET Framework 3.0 SP2 호환성 업데이트 976570 설명

상태

Microsoft는 이 문제가 '적용 대상' 섹션에 나열된 Microsoft 제품의 문제임을 확인했습니다.

자세한 내용

VTS에 대 한 자세한 내용은 다음 Microsoft Developer Network (MSDN) 웹 사이트를 방문 하십시오.

버전 허용 직렬화NetDataContractSerializer 클래스에 대 한 자세한 내용은 다음 MSDN 웹 사이트를 방문 하십시오.

NetDataContractSerializer 클래스

추가 도움이 필요하신가요?

기술 향상
교육 살펴보기
새로운 기능 우선 가져오기
Microsoft Insider 참가

이 정보가 유용한가요?

소중한 의견에 감사드립니다.

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×