FIX: Visual Basic 프로젝트를 빌드하려면 Visual Studio 2008을 사용 하면 IDE에서 성능 문제를 발생할 수 있습니다.

증상

다음 시나리오를 고려하십시오.

  • Microsoft Visual Studio 2008를 사용 하 여 Microsoft Visual Basic 프로젝트를 빌드합니다.

  • Visual Basic 프로젝트에 하나의 파일에 여러 XML 주석이 포함 되어 있습니다.

  • 디자이너에서 생성 된 파일 또는 웹 참조를 데이터 집합에 대 한 때문일 수 있습니다.

이 시나리오에서는 IDE에서 다음과 같은 성능 문제가 발생할 수 있습니다.

  • IDE는 오랫동안 솔루션을 작성 하 고 솔루션을 다시 빌드해야 합니다.

  • 디버깅을 시작 하려면 F5 키를 눌러 느린 응답 시간을 발생 합니다.

  • 코드 편집기에서 느린 응답 시간을 발생합니다.

  • IntelliSense는 느린 응답 시간이 발생합니다.

원인

Visual Studio 2008 컴파일러가 XML 문서를 포함 하는 큰 파일을 처리 하는 방법을 때문에이 문제가 발생 합니다.

해결 방법

핫픽스 정보



지원되는 핫픽스를 Microsoft에서 구할 수 있습니다. 그러나 이 핫픽스는 오직 이 문서에서 설명하는 문제를 해결하는 작업에만 사용됩니다. 이 문제가 발생하는 시스템에만 이 핫픽스를 적용해야 합니다. 이 핫픽스는 추가 테스트가 필요할 수도 있습니다. 따라서, 이 문제로 심각하게 영향을 받지 않는 경우 이 핫픽스가 포함된 다음 소프트웨어 업데이트가 나올 때까지 기다리는 것이 좋습니다.

MSDN 코드 갤러리에서이 핫픽스를 다운로드 하려면 다음 Microsoft 웹 사이트를 방문 하십시오.

http://code.msdn.microsoft.com/KB946344
참고: MSDN 코드 갤러리 핫픽스를 사용할 수 있는 언어가 표시 됩니다. 나열 된 언어를 표시 되지 않으면 코드 갤러리 리소스 페이지를 해당 언어에 사용할 수 없기 때문에입니다.


참고: 추가 문제가 발생하거나 문제 해결이 필요한 경우, 별도로 서비스를 요청해야 할 수도 있습니다. 추가 지원 질문과 이 특정 핫픽스가 필요하지 않은 문제에는 일반 지원 비용이 적용됩니다. Microsoft 고객 지원 전화 번호의 전체 목록을 확인하거나 별도 서비스 요청을 만들려면 다음 Microsoft 웹 사이트를 방문하십시오.

http://support.microsoft.com/contactus/?ws=support

이 핫픽스의 영어 버전은 다음 표에 열거된 파일 특성 (또는 그 이후의 파일 특성)을 가지고 있습니다. 이러한 파일의 시간과 날짜는 협정 세계시(UTC)로 나열되었습니다. 파일 정보를 볼 때는 로컬 시간으로 변환됩니다. UTC와 로컬 시간의 시차는 제어판의 날짜 및 시간 항목에서 표준 시간대 탭을 사용하여 찾을 수 있습니다.

파일 이름

파일 버전

파일 크기

날짜

시간

Avvspkdh.dll

9.0.21022.43

34,816

29-Jan-2008

03:17

Mcee.dll

9.0.21022.43

367,608

29-Jan-2008

03:17

Mpishim.exe

9.0.21022.43

26,112

29-Jan-2008

03:17

Msvb7.dll

9.0.21022.43

4,069,880

29-Jan-2008

03:17

Msvsmon.exe

9.0.21022.43

3,004,416

29-Jan-2008

03:17

해결 방법

이 문제를 해결 하려면 다음 방법 중 하나를 사용 합니다.

방법 1: XML 주석 생성 비활성화

프로젝트에 대 한 XML 주석이 생성을 해제 하려면 다음 절차 중 하나를 사용 합니다.

Visual Studio 2008

  1. 솔루션 탐색기에서 p r o j마우스 오른쪽 단추로 누른 다음 등록 정보를 합니다.

  2. 컴파일 탭에서 XML 문서 파일 생성 확인란의 선택을 취소 하려면 클릭 합니다.

  3. 파일 메뉴에서 모두 저장을 클릭 합니다.

Visual Basic 2008 Express Edition

  1. 프로젝트의 백업을 만듭니다.

  2. 메모장에서 프로젝트의.vbproj 파일을 엽니다.

  3. 찾아 다음 < DocumentationFile > 요소.vbproj 파일을 삭제 합니다.

    참고: 일반적으로,.vbproj 파일의 두 요소는 삭제 됩니다.

방법 2: XML 주석 제거

XML 주석을 제거 하려면 디자이너에서 생성 된 파일에 대 한 다음이 단계를 수행 합니다.

  1. 편집 메뉴에서 찾기 및 바꾸기를 가리킨 다음 빠른 바꾸기를 클릭 하 고

  2. 찾을 내용 상자에 입력 ' '.

  3. 바꿀 내용 상자에 "를 입력 하 고 모두 바꾸기를 클릭 합니다.

참고: 다음 작업 중 하나를 수행 하는 경우이 단계를 반복 해야 합니다.

방법 3: XML 주석이 있는 파일을 저장할 별도 프로젝트 만들기

디자이너에서 생성 된 파일을 저장할 새 클래스 라이브러리 프로젝트를 만듭니다. 다음 절차는이 예로:

  1. 데이터 집합을 포함 하는 또는 웹 참조를 포함 하는 파일을 저장할 새 클래스 라이브러리 프로젝트를 만듭니다.

  2. 원래 Visual Basic 프로젝트에 새 클래스 라이브러리 프로젝트에 대 한 참조를 추가 합니다.

  3. 방법 1을 사용 하 여 XML 문서 파일 사용 안 함.

참고: Visual Basic 코드에 import 문을 추가 해야 할 수 있습니다.

상태

Microsoft는 이 문제가 '적용 대상' 섹션에 나열된 Microsoft 제품의 문제임을 확인했습니다.

자세한 내용

자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료의 다음 문서를 확인하십시오.

Microsoft 소프트웨어 업데이트를 설명 하는 데 사용 되는 표준 용어에 대 한 824684 설명

프로젝트의 XML 문서를 생성 하는 방법에 대 한 자세한 내용은 다음 Microsoft Developer Network (MSDN) 웹 사이트를 방문 하십시오.

http://msdn2.microsoft.com/en-us/library/x4sa0ak0(VS.90).aspx

추가 도움이 필요하신가요?

기술 향상
교육 살펴보기
새로운 기능 우선 가져오기
Microsoft Insider 참가

이 정보가 유용한가요?

소중한 의견에 감사드립니다.

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×