증상

Linux에서 SQL Server 2017을 사용 한다고 가정 합니다. SQL Server 누적 업데이트를 설치 또는 제거 하는 경우 일부 업그레이드 또는 다운 그레이드 스크립트 (sqlscriptupgrade 또는 sqlscriptdowngrade 파일의 경우)가 예상 대로 실행 되지 않습니다. 따라서 데이터베이스 스키마를 업그레이드 하거나 다운 그레이드 하는 것이 적절 하지 않습니다.

참고 누적   업데이트를 설치 하면이 업데이트의 업그레이드 스크립트가 실행 됩니다. 그러나 이전 누적 업데이트는 여전히 같은 방식으로 동작 합니다. 따라서이 업데이트 이전의 누적 업데이트는 적용 하지 않는 것이 좋습니다.

해결 방법

이 수정은 SQL Server 2017의 누적 업데이트 4 에 포함 되어 있습니다.

SQL Server 2017 빌드 정보

각각의 SQL Server 2017 새 빌드에는 이전 빌드에 있던 모든 핫픽스와 보안 수정 사항이 포함 되어 있습니다. SQL Server 2017에 대 한 최신 빌드를 설치 하는 것이 좋습니다.

상태

Microsoft는 "적용 대상" 절에 나열한 제품에서 이 문제를 확인했습니다.

추가 정보

이 업데이트를 시작으로 sql Server 에이전트는 SQL Server와 함께 자동으로 설치 됩니다. Mssql-서버-에이전트 패키지를 별도로 설치 하는 것은 더 이상 필요 하지 않습니다 (또는 가능). SQL Server 에이전트는 기본적으로 비활성화 되어 있습니다. 이 기능을 사용 하도록 설정 하려면 다음 구성 명령을 실행 합니다.

mssql-회의 설정 sqlagent true

에이전트를 사용 하지 않도록 설정 하려면 다음을 실행 합니다.

mssql-회의 집합 sqlagent. false를 설정 합니다.

또는 환경 변수 MSSQL_AGENT_ENABLEDTrue 또는 False 로 설정 하 여 각각 에이전트를 사용 하거나 사용 하지 않도록 설정할 수 있습니다.

참고SQL Server를 다시 시작 해야 새 설정이 적용 됩니다.

이전 버전의 SQL Server를 업그레이드 하는 경우 mssql-Server 에이전트 패키지 (있는 경우)가 자동으로 제거 되 고 SQL Server 에이전트를 사용할 수 있게 됩니다. 업데이트 중에 SQL Server 에이전트 패키지가 없으면 SQL Server 에이전트는 사용 하지 않도록 설정 된 상태로 유지 됩니다.

SQL Server 에이전트를 사용 하지 않도록 설정한 경우 해당 구성은 제거 되지 않으며 해당 작업은 그대로 유지 됩니다. SQL Server 에이전트를 다시 사용 하도록 설정 하면 비활성화 되기 전과 동일한 상태로 전환 됩니다.

참조

Microsoft에서 소프트웨어 업데이트를 설명 하는 데 사용 하는 용어 에 대해 알아봅니다.

추가 도움이 필요하신가요?

기술 향상
교육 살펴보기
새로운 기능 우선 가져오기
Microsoft Insider 참가

이 정보가 유용한가요?

언어 품질에 얼마나 만족하시나요?
사용 경험에 어떠한 영향을 주었나요?

의견 주셔서 감사합니다!

×