Microsoft로 로그인
로그인하거나 계정을 만듭니다.
안녕하세요.
다른 계정을 선택합니다.
계정이 여러 개 있음
로그인할 계정을 선택합니다.

증상

StorSimple 볼륨 ESX 서버에 연결 하려고 할 때 간헐적인 연결 문제가 발생할 수 있습니다. 이 문제는 액세스 제어 기록 (ACRs) IP 주소를 사용 하 여 ESX 서버에 대해 구성 된 경우 발생 합니다.

이 문제 및 모범 사례를 자세히 설명 합니다. 여기서는 StorSimple v1.2.1 v2.0.1와 v2.1.1 적용 됩니다.

원인

StorSimple 볼륨에 대 한 액세스를 사용 하기 전에 acr은 ESX 서버에 IP 주소를 사용 하 여 구성 되 면 수행 됩니다 일치 하는 IP 주소. 즉, 특정 IP 주소와 일치 하는 연결에만 볼륨을 액세스할 수 있습니다. 해당 서버는 여러 IP 주소는 네트워크의 모든 경로가 포함 되도록 구성 ACRs의 경우, 사용자는 연결 문제가 발생할 수 있습니다.

예를 들어, 호스트 서버에 두 개의 IP 주소는 10.2.43.60 (iSCSI) 및 10.2.43.61 (관리). 이러한 각 StorSimple 볼륨에 연결 하 여 사용할 수 있습니다. 그런 다음 사용자는 acr은 만들어지고 연결 IP 주소 중 하나를 사용 하 여 — 예: 10.2.43.60. 이 시나리오에서는 없음 acr은 정의 대 한 네트워크 경로 (예: 10.2.43.61) 있어서. 서버에 네트워크 경로 여러 개 있는 경우 해당 ACRs 모든 경로 포함 하도록 구성 되어야 합니다.

사용자는이 구성을, 님은 연결 문제가 발생할 수 있습니다. 예를 들어, iSCSI IP를 사용 하는 사용자의 초기자 연결을 처리 하는 경우 초기자 관리 IP 주소 (가상 머신 커널을 사용) 사용 하 여 다시 연결이 현재를 연결할 수 있습니다. 그러나 StorSimple 볼륨 표시 되지 않습니다. 따라서 볼륨 사라집니다.

해결 방법

이 문제를 해결 하려면 iSCSI는 IP 주소 대신 일치 하는 정규화 된 이름 (IQN)를 사용 하는 acr은 구성 합니다. 이렇게 하면 커널 VM 포트에서 제공 되는 연결을 볼륨에 액세스할 수 있어야 합니다.

이 해상도 두 단계로 필요합니다.

1 단계: 찾기 IQN ESX 서버에

  1. StorSimple 볼륨에 저장 되어 있는 모든 실행 중인 Vm을 종료 합니다.

  2. ESX 서버 iSCSI 초기자의 IQN을 추출 하려면 ESX 서버에 액세스 합니다. 이렇게 하려면, 다음 단계를 수행하십시오.

    1. VSphere에 로그온 합니다.

    2. 재고 을 다음 호스트 및 클러스터를클릭 합니다.

    3. 탐색 창에서 ESX 서버를 선택 합니다. 세부 정보 창에서 구성 탭을 클릭 합니다.

    4. 스토리지 어댑터를 선택 합니다.

    5. 소프트웨어 어댑터 iSCSI 장치에서 vmhba # #을 누릅니다. 세부 정보 창에서 속성을 클릭 합니다.

    6. 속성 창에서 표시 된 IQN을 선택한 다음 복사 합니다.

  3. 모든 ESX 서버에 2 단계를 반복 합니다.


웹 사용자 인터페이스 (UI) 구성 해야 합니다. 이렇게 하려면 iqn은 고유 StorSimple 장비의 웹 UI에 액세스 제어 레코드에서 적용 되어야 합니다.

  1. StorSimple 웹 UI 로그온 합니다.

  2. 보안 설정 구성을 누른 다음 액세스 제어 레코드.

  3. 2 단계에 나와 있는 ESX 서버에 대해 지정 된 액세스 제어 레코드는 "1 단계: 찾기 IQN ESX 서버에" 섹션에서 편집 아이콘을 클릭 합니다.

  4. IP 주소 상자에 IP 주소는 asterick (*)를 포함 하는 삭제 하 고 다음 상자에 붙여 넣고 IQN 의 2F 단계에서에서 복사한 IQN은 "1 단계: 찾기 IQN ESX 서버에" 섹션.

  5. 액세스 제어 레코드를 저장 하 고 녹색 확인 표시를 클릭 합니다.

모든 ESX 서버에서이 단계를 반복 합니다.

참고: ESX 서버에서 iSCSI 연결 끊어지고 다시 연결 해야 합니다.

도움이 더 필요하세요?

더 많은 옵션을 원하세요?

구독 혜택을 살펴보고, 교육 과정을 찾아보고, 디바이스를 보호하는 방법 등을 알아봅니다.

커뮤니티를 통해 질문하고 답변하고, 피드백을 제공하고, 풍부한 지식을 갖춘 전문가의 의견을 들을 수 있습니다.

이 정보가 유용한가요?

언어 품질에 얼마나 만족하시나요?
사용 경험에 어떠한 영향을 주었나요?
제출을 누르면 피드백이 Microsoft 제품과 서비스를 개선하는 데 사용됩니다. IT 관리자는 이 데이터를 수집할 수 있습니다. 개인정보처리방침

의견 주셔서 감사합니다!

×