Noen ganger må du sjekke om en celle er tom, vanligvis fordi du ikke vil at en formel skal vise et resultat uten inndata.

Formelen i celle E2 er =HVIS(D2=1,"Ja",HVIS(D2=2,"Nei","Kanskje"))

I dette tilfellet bruker vi HVIS med ERTOM-funksjonen:

  • =HVIS(ERTOM(D2), "Tom", "Ikke tom")

Som sier HVIS(D2 er tom, returner resultatet «Tom», og hvis ikke, returner «Ikke tom»). Du kan også bruke din egen formel for «Ikke tom»-betingelsen. I neste eksempel bruker vi «» i stedet for ERTOM. I praksis betyr «» «ingenting».

Sjekk om en celle er tom – formel i celle E2 er =HVIS(ERTOM(D2),"Tom","Ikke tom")

=HVIS(D3="","Tom", "Ikke tom")

Denne formelen sier HVIS(D3 er tom, returner resultatet «Tom», og hvis ikke, returner «Ikke tom»). Her er et eksempel på en svært vanlig måte å bruke «» på for å hindre at en formel beregner hvorvidt en underordnet celle er tom:

  • =HVIS(D3="","",DinFormel())

    HVIS(D3 er tom, skal ingenting gis i resultatet, hvis den ikke er tom, beregnes en egen formel).

Trenger du mer hjelp?

Utvid ferdighetene dine
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Microsoft Office Insider-deltakere

Var denne informasjonen nyttig?

Hvor fornøyd er du med språkkvaliteten?
Hva påvirket opplevelsen din?

Takk for tilbakemeldingen!

×