Formler og funksjoner

Funksjonen HVIS

HVIS (funksjon)

HVIS-funksjonen er en av de mest populære funksjonene i Excel, og du kan foreta logiske sammenligninger mellom en verdi og det du forventer.

Et HVIS-uttrykk kan derfor ha to resultater. Det første resultatet er hvis sammenligningen er SANN, og det andre er hvis den er USANN.

For eksempel =HVIS(C2=«Ja»,1,2) sier at HVIS(C2 = Ja, returner en 1, hvis ikke, returner en 2).

Nettleseren støtter ikke video.

Bruk HVIS-funksjonen, en av de logiske funksjonene, for å returnere én verdi hvis en betingelse er sann, og en annen verdi hvis den er usann.

HVIS(logisk_test; verdi_hvis_sann; [verdi_hvis_usann])

Eksempel:

  • =HVIS(A2>B2;"Over budsjettet";"OK")

  • =HVIS(A2=B2,B4-A4,"")

Argumentnavn

Beskrivelse

logisk_test    (obligatorisk)

Betingelsen du vil teste.

verdi_hvis_sann    (obligatorisk)

Verdien som returneres hvis resultatet av logisk_test er SANN.

verdi_hvis_usann    (valgfritt)

Verdien som returneres hvis resultatet av logisk_test er USANN.

Enkle HVIS-eksempler

Cell D2 inneholder en formel =HVIS(C2="Ja",1,2)
  • =HVIS(C2="ja",1,2)

I eksemplet ovenfor sier celle D2: HVIS(C2 = Ja, returner deretter en 1, hvis ikke, returner en 2)

Celle D2 inneholder formelen =HVIS(C2=1,"JA","NEI")
  • =HVIS(C2=1,"ja","nei")

I dette eksemplet sier formelen i celle D2: HVIS(C2 = 1,og deretter returnerer du Ja, ellers returnerer du Nei) Som du ser, kan HVIS-funksjonen brukes til å evaluere både tekst og verdier. Den kan også brukes til å evaluere feil. Du er ikke begrenset til bare å kontrollere om én ting er lik en annen og returnere et enkelt resultat, du kan også bruke matematiske operatorer og utføre flere beregninger avhengig av vilkårene. Du kan også neste flere HVIS-funksjoner sammen for å utføre flere sammenligninger.

Formelen i celle D2 er = HVIS(C2>B2; "Over budsjett"; "Innenfor budsjett")
  • = HVIS(C2>B2,"Over budsjett","Innenfor budsjett")

I eksemplet ovenfor sier HVIS-funksjonen i D2 HVIS(C2 er større enn B2, returner da «Over budsjett", hvis ikke, returner "Innenfor budsjettet")

Formelen i celle E2 er =HVIS(C2>B2; C2-B2,"")
  • = HVIS(C2>B2,C2-B2,0)

I illustrasjonen ovenfor skal vi returnere en matematisk beregning i stedet for å returnere et tekstresultat. Formelen i E2 sier at HVIS(faktisk er høyere enn budsjettert, trekk da budsjettert beløp fra det faktiske beløpet. Hvis ikke returneres ingenting).

Formelen i celle F7 er HVIS(E7="Ja",F5*0,0825,0)
  • =HVIS(E7="ja",F5*0,0825,0)

I dette eksemplet sier formelen i F7 HVIS(E7 = "Ja", beregn da totalbeløpet i F5* 8,25 %, hvis ikke, skal Ingen salgsavgifter til forfall returnere 0)

Obs!: Hvis du skal bruke tekst i formler, må du bryte teksten i anførselstegn (for eksempel «Tekst»). Det eneste unntaket til dette er å bruke SANN eller USANN, som Excel forstår automatisk.

Vanlige problemer

Problem

Hva gikk galt

0 (null) i celle

Det var ikke noe argument for argumentet verdi_hvis_sann eller verdi_hvis_usann. Legg til argumentteksten i de to argumentene eller legg til SANN eller USANN i argumentet, slik at riktig verdi blir returnert.

#NAVN? i celle

Dette betyr vanligvis at formelen er feilstavet.

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excels tekniske fellesskap eller få hjelp i Svar-fellesskapet.

Se også

Beregningsoperatorer og prioritet i Excel

Bruke nestede funksjoner i en formel

Bruke HVIS til å sjekke om en celle er tom

Video: Avanserte HVIS-funksjoner

HVIS.SETT (Microsoft 365, Excel 2016 og nyere)

Avanserte HVIS-funksjoner – arbeide med nestede formler og unngå feller

Opplæringsvideoer: Avanserte HVIS-funksjoner

ANTALL.HVIS-funksjonen teller verdier basert på ett enkelt vilkår

ANTALL.HVIS.SETT-funksjonen teller verdier basert på flere vilkår

SUMMERHVIS-funksjonen summerer verdier basert på ett enkelt vilkår

SUMMER.HVIS.SETT-funksjonen summerer verdier basert på flere vilkår

OG-funksjonen

ELLER-funksjonen

FINN.RAD-funksjonen

Oversikt over formler i Excel

Unngå formler med feil

Oppdage feil i formler

Logiske funksjoner

Funksjoner i Excel

Excel-funksjoner (etter kategori)

Trenger du mer hjelp?

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

×