Ingen spørringsresultater returneres når du bruker Internet Explorer 8 til å opprette Microsoft Dynamics CRM 2013-dialogbokser

Gjelder for
Dynamics CRM 2013

Symptom

Tenk deg følgende:

  • Du oppretter en dialogboks for kontaktenheten i Microsoft Dynamics CRM 2013 fra en datamaskin der Windows Internet Explorer 8 er installert.

    Obs! En del av dialogbokskravene er at CRM-data spørres og presenteres som en nedtrekksmeny.

  • Du legger til et crm-datatrinn for spørring når du oppretter dialogboksen.

  • Filtrene for spørringen er dynamiske (FirstName -> equals -> {FirstName(Contact)}).

  • Det neste trinnet i dialogboksen er en side som inneholder en ledetekst og et svar der ledeteksten er satt til {FirstName(Contact)}, og svaret er satt til Alternativsett, der de tilgjengelige alternativene fylles ut fra spørringen.

  • Du kjører dialogboksen mot én enkelt kontaktoppføring.

I denne situasjonen finnes det ingen tilgjengelige alternativer i alternativsettet For spørsmål og svar .  

Årsak

Dette problemet oppstår fordi Internet Explorer 8 fører til at det legges til et mellomrom foran verdiene som settes inn i en spørring ved hjelp av dynamiske snegler.  

Oppløsning

Du kan løse dette problemet ved å bruke Windows Internet Explorer 9 til å opprette og publisere dialogbokser som inneholder CRM-spørringstrinn.