Applies ToExchange Server 2019

Symptomer

Når du har installert Microsoft Exchange Server kumulativ oppdatering 13 for 2019 (CU13), returnerer klientsøk i Microsoft Outlook som bruker Exchange Web Services (EWS) ufullstendige søkeresultater og en «HTTP 503»-feilkode. Du kan også få følgende feilmelding:

Vi har problemer med å hente resultater fra serveren.

Årsak

Dette problemet oppstår vanligvis når du sender en e-postmelding som inneholder svaralternativer og har sporing aktivert, eller hvis du har talepostelementer i postboksen.

Løsning

Hvis du vil omgå dette problemet, utfører du søket ved hjelp av Outlook i tilkoblet modus eller Outlook på nettet (OWA). Hvis du vil bekrefte at du opplever dette problemet, kan du se etter et HTTP 503-svar på en EWS-forespørsel om postboksen som søkes i. Følg deretter trinnene på serversiden i neste del.

Mer informasjon

Administratorer kan bruke Exchange Management Shell (EMS) på serveren som brukerens database er montert på, for å bekrefte at brukere støter på dette problemet. Kjør følgende kommando for å bekrefte serveren først:

Get-MailboxDatabaseCopyStatus (Get-Mailbox "AffectedUserAlias").Database.Name | ? {$_. Status -eq "Mounted"}

Serveren identifiseres i <DatabaseName\ServerName>-format. Kjør deretter følgende kommandoer på den samme serveren: 

CD-$ExScripts . .\ManagedStoreDiagnosticFunctions.ps1

$MBX = Get-Mailbox "MailboxNameHere" $DB = $MBX.Database.Name $Display = $MBX. Displayname

$MailboxNumber = Get-StoreQuery -Database $DB -Query "SELECT MailboxNumber,DisplayName FROM Mailbox" -Unlimited | ? {$_. DisplayName -like $Display} $Result = Get-StoreQuery -Database $DB -Query "SELECT MessageClass,FolderID,p10800003 FROM Message WHERE MailboxNumber=$($MailboxNumber.MailboxNumber) AND (p10800003=258 OR p10800003=259 OR p10800003=260 OR p10800003=263 OR p10800003=264 OR p10800003=266 ELLER p10800003=270 ELLER p10800003=283 ELLER p10800003=284 ELLER p10800003=304)" -Unlimited

Hvis $Result-variabelen returnerer noen resultater, støter du (eller en bruker) på dette problemet. I dette tilfellet åpner du en billett med Microsoft Kundestøtte, og inkluderer «PR_ICON_INDEX» i sakstittelen for å få hjelp med dette kjente problemet.

Trenger du mer hjelp?

Vil du ha flere alternativer?

Utforsk abonnementsfordeler, bla gjennom opplæringskurs, finn ut hvordan du sikrer enheten og mer.