Symptomer
Tenk deg følgende:
-
Du kjører Microsoft System Center Configuration Manager versjon 1511.
-
Du kan opprette et stort antall pakker (for eksempel flere hundre) og distribuere dem til mange pull distribusjonspunkter (for eksempel tusenvis av dem).
Når DistMgr behandler .pul filer fra pull-distribusjonspunkter (DPs) i dette scenariet, kjører DistMgr følgende spørring, som tar 3-4 sekunder å kjøre når det er mange rader i tabellen PkgStatus:
select s.ID, s.PkgServer, s.SiteCode, p.StoredPkgVersion, s.Status, r.PkgVersion, r.ActionState, r.ActionData, p.PkgFlags, p.ShareType
from PullDPResponse r join PkgStatus s on r.PkgStatusID = s.PKID AND r.PkgStatusID = PUL_ID join SMSPackages p on s.ID = p.PkgID
Årsak
Dette problemet oppstår fordi PkgStatus-visningen bruker en ISNULL-setning, og dette fører til SQL til å utføre en indeks Søk i stedet for å prøve en indeks.
Løsning
Når du har installert denne hurtigreparasjonen, og DistMgr behandler .pul filer fra pull DPs, kjører DistMgr følgende spørring, som tar omtrent 28 millisekunder, til å kjøre:
select s.ID, s.PkgServer, s.SiteCode, p.StoredPkgVersion, s.Status, r.PkgVersion, r.ActionState, r.ActionData, p.PkgFlags, p.ShareType
from PkgStatus2 s join PullDPResponse r on r.PkgStatusID = s.PKID AND s.PKID = 72057594038363660 join SMSPackages p on s.ID = p.PkgID
Informasjon om hurtigreparasjon
En støttet hurtigreparasjon er tilgjengelig fra Microsoft Support. Denne hurtigreparasjonen er imidlertid ment å løse problemet som er beskrevet i denne artikkelen. Bruk denne hurtigreparasjonen bare på systemer som har problemet som er beskrevet i denne artikkelen. Denne hurtigreparasjonen kan gjennomgå ytterligere testing. Hvis du ikke er alvorlig påvirket av dette problemet, anbefaler vi derfor at du venter på neste programvareoppdatering som inneholder denne hurtigreparasjonen.
Hvis hurtigreparasjonen er tilgjengelig for nedlasting, ligger den under delen "Hotfix Download Available" øverst i denne Knowledge Base-artikkelen. Hvis denne delen ikke vises, kan du kontakte Microsofts kundeservice og kundestøtte for å få hurtigreparasjonen. Obs! Hvis det oppstår andre problemer, eller hvis feilsøkingstips, må du kanskje opprette en separat forespørsel om. Vanlige kundestøttekostnader gjelder for ytterligere kundestøttespørsmål og problemer som ikke dekkes av denne oppdateringen. For en fullstendig liste over telefonnumre for Microsofts kundeservice og kundestøtte eller opprette en separat forespørsel om, kan du gå til følgende Microsoft-webområde:http://support.microsoft.com/contactus/?ws=supportObs! Hotfix Download Available-skjemaet viser språkene som hurtigreparasjonen er tilgjengelig på. Hvis du ikke ser språket ditt, er det fordi en hurtigreparasjon ikke er tilgjengelig for dette språket.
Forutsetninger
Hvis du vil bruke denne hurtigreparasjonen, må du ha System Center Configuration Manager versjon 1511 installert.
Informasjon om omstart
Du trenger ikke å starte datamaskinen på nytt etter at du har installert denne hurtigreparasjonen.
Informasjon om erstatning av hurtigreparasjoner
Denne hurtigreparasjonen erstatter ikke andre oppdateringer.
Den engelskspråklige versjonen av denne hurtigreparasjonen har filattributtene (eller senere filattributter) som er oppført i følgende tabell. Datoene og klokkeslettene for disse filene er oppført i Coordinated Universal Time (UTC). Når du viser filinformasjonen, konverteres den til lokal tid. Hvis du vil finne forskjellen mellom UTC og lokal tid, kan du bruke kategorien tidssone under dato og klokkeslett i Kontrollpanel.
Filnavn |
Filversjon |
Filstørrelse |
Dato |
Tid |
Plattform |
---|---|---|---|---|---|
Update.sql |
Ikke tilgjengelig |
2,046 |
24-Nov-2015 |
01:00 |
Ikke tilgjengelig |
Status
Microsoft har bekreftet at dette er et problem i Microsoft-produktene som er oppført i delen "Gjelder for".
Referanser
Lær mer om terminologien som Microsoft bruker til å beskrive oppdateringer av programvare.