Symptomer
Tenk deg følgende:
-
En webproxyklient etablerer en SSL-tilkobling (secure socket layer) til en ekstern nettserver ved hjelp av en server som kjører Microsoft Forefront Threat Management Gateway 2010.
-
HTTPS-inspeksjon er ikke involvert. Derfor opprettes det en ende-til-ende SSL-relasjon mellom klienten og nettserveren.
-
I denne etablerte tilkoblingen laster klienten opp data til nettserveren.
-
Tilkoblingen og TCP-flyten til nettserveren er treg.
I dette scenarioet fullføres ikke opplastingen riktig under visse omstendigheter.
Årsak
Dette problemet oppstår etter at klienten har sendt alle sine data til TMG-proxyserveren Klienten gjør dette selv om TMG-proxyserveren ennå ikke har sendt alle dataene til mål-nettserveren på grunn av treg båndbredde mellom TMG-proxyserveren og mål-nettserveren.
I dette tilfellet håndterer ikke TMG-proxyserveren påminnelsesbufferen som skal sendes til mål-nettserveren, og TCP-tilkoblingen lukkes for tidlig.
Løsning
Du kan løse dette problemet ved å installere oppdateringspakken som er beskrevet i følgende Microsoft Knowledge Base-artikkel:
2555840 Beskrivelse av Service Pack 2 for Microsoft Forefront Threat Management Gateway 2010Note Hvis du vil aktivere denne hurtigreparasjonen, må du kjøre setProxySocketSendBufSize.vbs-skriptet på serveren som kjører Forefront Threat Management Gateway 2010.
Hvis du vil at vi setProxySocketSendBufSize.vbs skriptet for deg, kan du gå til delenFix it for me. Hvis du foretrekker å opprette og kjøre skriptet selv, kan du gå til delen«La meg rette det selv».
Løs det for meg
Hvis du vil løse dette problemet automatisk, klikker du Løs det-knappen eller -koblingen. Klikk deretter Kjør i dialogboksen Filnedlasting, og følg fremgangsmåten i Fix it-veiviseren.
Merknader
-
Det kan hende at denne veiviseren bare er tilgjengelig på engelsk. Den automatiske reparasjonsløsningen fungerer imidlertid også for andre språkversjoner av Windows.
-
Hvis du ikke er på datamaskinen som har problemet, lagrer du Fix it-løsningen på en flash-enhet eller CD, og deretter kjører du den på datamaskinen som har problemet.
Gå deretter til delen«Løste dette problemet?».
La meg løse det selv
Følg disse trinnene for å opprette og kjøre skriptet:
-
Start Notisblokk. Dette gjør du ved å klikke Start,klikkeKjør, skrive notepad.exe i Åpne-boksen og deretter klikke OK.
-
Lim inn følgende skript i den nye Notisblokk-filen:
Const SE_VPS_GUID = "{143F5698-103B-12D4-FF34-1F34767DEabc}"
Const SE_VPS_NAME = "ProxySocketSendBufSize"
Const SE_VPS_VALUE = 8192
Sub SetValue()
' Create the root object.
Dim root ' The FPCLib.FPC root object
Set root = CreateObject("FPC.Root")
'Declare the other objects that are needed.
Dim array ' An FPCArray object
Dim VendorSets ' An FPCVendorParametersSets collection
Dim VendorSet ' An FPCVendorParametersSet object
' Obtain references to the array object
' and the network rules collection.
Set array = root.GetContainingArray
Set VendorSets = array.VendorParametersSets
On Error Resume Next
Set VendorSet = VendorSets.Item( SE_VPS_GUID )
If Err.Number <> 0 Then
Err.Clear
' Add the item
Set VendorSet = VendorSets.Add( SE_VPS_GUID )
CheckError
WScript.Echo "New VendorSet added... " & VendorSet.Name
Else
WScript.Echo "Existing VendorSet found... value- " & VendorSet.Value(SE_VPS_NAME)
End If
if VendorSet.Value(SE_VPS_NAME) <> SE_VPS_VALUE Then
Err.Clear
VendorSet.Value(SE_VPS_NAME) = SE_VPS_VALUE
If Err.Number <> 0 Then
CheckError
Else
VendorSets.Save false, true
CheckError
If Err.Number = 0 Then
WScript.Echo "Done with " & SE_VPS_NAME & ", saved!"
End If
End If
Else
WScript.Echo "Done with " & SE_VPS_NAME & ", no change!"
End If
End Sub
Sub CheckError()
If Err.Number <> 0 Then
WScript.Echo "An error occurred: 0x" & Hex(Err.Number) & " " & Err.Description
Err.Clear
End If
End Sub
SetValue -
Klikk Lagre som på Fil-menyen,og lagre deretter skriptet som setProxySocketSendBufSize.vbs.
-
Klikk på Avslutt på Fil-menyen for å avslutte Notisblokk.
-
Dobbeltklikk VBS-filen du lagret i trinn 3.
Løste dette problemet?
-
Kontroller om problemet er løst. Hvis problemet er løst, er du ferdig med denne delen. Hvis problemet ikke er løst, kan du kontakte kundestøtte.
-
Vi setter pris på tilbakemeldingene dine. Hvis du vil gi tilbakemelding eller rapportere problemer med denne løsningen, kan du kommentere bloggen eller sende oss en e-post.
Status
Microsoft har bekreftet at dette er et problem i Microsoft-produkter som er oppført under Gjelder for.
Referanser
Hvis du vil ha mer informasjon om terminologi for programvareoppdatering, kan du klikke følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
824684 Beskrivelse av standardtermen som brukes til å beskrive programvareoppdateringer fra Microsoft