Symptomer
Enkelte tilkoblingsproblemer med Microsoft Outlook-klientprogrammer oppstår når mange tjenestetråder for Microsoft Exchange RPC Client Access som finnes i en fellesmappe, venter på svar fra tilgjengelighetstjenesten. Dette problemet oppstår for eksempel når mer enn 500 tråder venter på svar på en fellesmappe.
Merknader-
Det finnes ikke noe alternativ for å deaktivere tilgjengelighetstjenesten på en server som kjører Exchange Server 2010 Service Pack (SP1).
-
Hvis du starter Exchange RPC Client Access-tjenesten på fellesmappeserveren for Exchange Server 2010 SP1 på nytt, er dette problemet midlertidig løst.
Årsak
Dette problemet oppstår på grunn av en ny funksjon i Exchange Server 2010 SP1. Denne nye funksjonen bruker Microsoft Exchange RPC Client Access-tjenesten som proxy for tidligere versjoner av tilgjengelighetstjenesten (informasjon om ledig/opptatt). Hvis du har en fellesmappe som er installert på en Exchange Server 2010 SP1-server, fanger derfor Microsoft Exchange RPC Client Access-tjenesten seg av informasjonsforespørsler om ledig/opptatt.
Løsning
Bruk en av følgende metoder for å løse dette problemet.
Metode 1
Oppgrader alle klienter til Outlook 2007 eller en nyere versjon som bruker Exchange Web Services (EWS) for å foreta tilgjengelighetstjenesteanrop direkte til Exchange Client Access-serveren.
Metode 2
Installer følgende oppdatering på Exchange Server 2010 SP1-postboksserverne som er vert for en fellesmappedatabase:
2497453 LØSNING: Programmet kan slutte å svare etter at flere HTTP-forespørsler avbrytes hvis du bruker HttpWebRequest-klassen til å sende forespørsler i .NET Framework
Metode 3
Viktig Denne delen, metoden eller oppgaven inneholder trinn som forteller deg hvordan du endrer registeret. Det kan imidlertid oppstå alvorlige problemer hvis du endrer registret på feil måte. Sørg derfor for at du følger fremgangsmåten nøye. Husk å ta sikkerhetskopi av registret før du endrer det, som en ekstra beskyttelse. Da kan du gjenopprette registret hvis det skulle oppstå problemer. Hvis du vil ha mer informasjon om hvordan du sikkerhetskopierer og gjenoppretter registeret, klikker du følgende artikkelnummer for å vise artikkelen i Microsoft Knowledge Base:
322756 Slik sikkerhetskopierer og gjenoppretter du registeret i Windows Forsiktig! Følgende problemer kan oppstå hvis du bruker denne metoden:
-
I en hybriddistribusjon for Office 365 og lokal Exchange Server, eller i organisasjoner i forbund, vil eldre klienter, for eksempel Microsoft Office Outlook 2007 eller Microsoft Office Outlook 2003, ikke lenger motta ledige/opptatte tidspunkter fra skynettstedet eller fra den eksterne organisasjonen.
-
De nyeste dataene om ledige/opptatte tidspunkt rapporteres ikke for eldre klienter. Dataene kan være opptil 15 minutter utdatert.
Du kan løse dette problemet ved å følge disse trinnene på postboksserveren som er vert for en database for fellesmapper:
-
Klikk følgende artikkelnummer for å gå til artikkelen i Microsoft Knowledge Base, og installer deretter den samlede oppdateringen som er beskrevet i artikkelen:
2579150 Beskrivelse av samleoppdatering 4 for Exchange Server 2010 Service Pack 1
-
Deaktiver tilgjengelighetstjenesten.for meg. Hvis du foretrekker å deaktivere tilgjengelighetstjenesten selv, kan du gå til delen Lameg rette det selv.
Hvis du vil at vi skal deaktivere tilgjengelighetstjenesten for deg etter at du har installert samleoppdatering 2579150, kan du gå til delen ReparerLøs dette for meTo disable the Availability service automatically, click the Fix it button or link. Klikk deretter Kjør i dialogboksen Last ned fil, og følg fremgangsmåten i Fix it-veiviseren.
-
Det kan hende at denne veiviseren bare er tilgjengelig på engelsk. Den automatiske reparasjonsløsningen fungerer imidlertid også for andre språkversjoner av Windows.
-
Hvis du ikke er på datamaskinen som har problemet, lagrer du Fix it-løsningen på en flash-enhet eller CD, og deretter kjører du den på datamaskinen som har problemet.
La meg løse det selv Når du har installert oppdateringen, følger du disse trinnene for å deaktivere tilgjengelighetstjenesten:
-
Klikk Start,skriv inn regedit i Start søkeboksen, og klikk deretter regedit.exe.
-
Finn og klikk følgende registerundernøkkel:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\
-
Pek på Ny på Rediger-menyen,og klikk deretter Nøkkel.
-
Skriv inn ParametersSystem, og trykk deretter ENTER.
-
Finn og klikk følgende registerundernøkkel:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem
-
Pek på Ny på Rediger-menyen, og klikk deretter Dword-verdi.
-
Skriv inn DisableAvailabilityServiceCalls, og trykk deretter ENTER.
-
Høyreklikk DisableAvailabilityServiceCallsi detaljruten,og klikk deretter Endre.
-
Skriv inn 1 i Verdidata-boksen, og klikk deretter OK.
-
Avslutt Registerredigering.
-
Løste dette problemet?
-
Kontroller om problemet er løst. Hvis problemet er løst, er du ferdig med denne delen. Hvis problemet ikke er løst, kan du kontakte kundestøtte.
-
Vi setter pris på tilbakemeldingene dine. Hvis du vil gi tilbakemelding eller rapportere problemer med denne løsningen, kan du kommentere bloggen eller sende oss en e-postmelding.
Status
Microsoft har bekreftet at dette er et problem i Microsoft-produkter som er oppført under Gjelder for.
Mer informasjon
Hvis du vil ha mer informasjon om tilgjengelighetstjenesten, kan du gå til følgende Microsoft TechNet-nettsted: