Jak używać funkcji korespondencji seryjnej w programie Word do tworzenia i drukowania listów seryjnych, które używają danych z arkusza programu Excel


Streszczenie


W tym artykule wyjaśniono, jak używać funkcji korespondencji seryjnej w programie Microsoft Word do tworzenia i drukowania listów przy użyciu danych z arkusza programu Microsoft Excel.

Korzystając z funkcji korespondencji seryjnej programu Word, program Word scala dokument główny z listy adresatów , aby wygenerować zestaw dokumentów wyjściowych:
  • Dokument główny zawiera podstawowy tekst, który jest taki sam we wszystkich dokumentach wyjściowych. Może on zawierać nagłówek listowy, tekst oraz instrukcje w pola korespondencji seryjnej do wstawiania tekstu (np. nazwiska i adresy adresatów), które różnią się w poszczególnych dokumentach wyjściowych.
  • Lista adresatów jest bazą danych, który zawiera dane, które mają być scalane w dokumentach wyjściowych. Na przykład lista adresatów jest plikiem bazy danych programu Microsoft Access lub arkusza programu Excel.

    Ta baza danych jest zazwyczaj listy nazwy, adresy, numery telefonów i inne rodzaje informacji osobistych.
  • Dokumenty wyjściowe są wynikiem procesu generowania korespondencji seryjnej. Tekst w dokumencie wyjściowym może być taki sam we wszystkich dokumentach wyjściowych, ale można zastosować formatowanie do określonych dokumentów.

Krok 1: Konfigurowanie pliku danych programu Excel

Przed przystąpieniem do Kreatora korespondencji seryjnej, upewnij się, że arkusz programu Excel jest dobrze przygotowany w tym celu. Należy uwzględnić następujące wymagania dotyczące tabeli danych:
  • Pierwszy wiersz powinien zawierać nazwy pól dla każdej kolumny — na przykład tytuł, zwrot grzecznościowy, imię, drugie imię, nazwisko, Adres1 i Adres2.
  • Każda nazwa pola powinna być unikatowa.
  • Każdy wiersz powinien dostarczać informacji dotyczących określonego elementu. Na przykład na liście adresowej każdy wiersz może zawierać informacje dotyczące określonego adresata.
  • Tabela nie powinna zawierać pustych wierszy.
Tworzenie pliku danych programu Excel i rozmieść je przy użyciu pola, które chcesz użyć do Pańskiego listu, jak pokazano w następującym przykładowym pliku danych.

Po utworzeniu pliku danych programu Excel, zapisz go, a następnie zamknij plik danych.

Aby uzyskać więcej informacji dotyczących sposobu tworzenia listy adresów korespondencji seryjnej kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

294688 jak projektować i tworzyć listy adresów korespondencji seryjnej w programie Word 2002 i nowszych wersjach programu Word

Krok 2: Przygotuj dokument główny

  1. W programie Microsoft Office Word 2003 i starszych wersjach programu Word w menu Narzędzia wskaż polecenie listy i dokumenty wysyłkowe , a następnie kliknij polecenie Kreator korespondencji seryjnej.

    W programie Microsoft Office Word 2007 kliknij przycisk Rozpocznij korespondencję seryjną w grupie Rozpocznij korespondencję seryjną na dokumenty wysyłkowe , a następnie kliknij Krok po kroku przez Kreatora korespondencji seryjnej.
  2. W obszarze Wybierz typ dokumentukliknij polecenie listy.

    Aktywny dokument staje się głównym dokumentem. Dokument główny zawiera tekst i grafikę, które są takie same dla każdej wersji scalonego dokumentu. Na przykład adres zwrotny lub zwrot grzecznościowy w liście seryjnym są takie same dla każdej wersji.
  3. Kliknij Następny: dokument początkowy.
  4. Użyj jednej z następujących metod:
    • Rozpoczynanie od dokumentu aktualnie wyświetlane w oknie dokumentu. Aby to zrobić, kliknij opcję Użyj bieżącego dokumentu.

      Możesz można następnie wpisać treść listu w oknie dokumentu lub poczekać, aż Kreator monituje o to zrobić w późniejszym etapie.
    • Rozpoczynanie od szablonu. Aby to zrobić, wykonaj następujące kroki:
      1. Kliknij przycisk Rozpocznij od szablonu.
      2. Kliknij przycisk Wybierz szablon.
      3. Na karcie Korespondencja seryjna wybierz szablon, który ma w oknie dialogowym Wybierz szablon , a następnie kliknij przycisk OK.
    • Rozpocznij od istniejącego dokumentu. Aby to zrobić, wykonaj następujące kroki:
      1. Kliknij przycisk Rozpocznij od istniejącego dokumentu.
      2. W polu Rozpocznij od istniejącego dokumentu, który chcesz zaznaczyć, a następnie kliknij Otwórz.
      3. Jeśli dokument nie jest widoczny, kliknij przycisk więcej plików, a następnie kliknij Otwórz. W oknie dialogowym Otwórz zlokalizuj dokument, który chcesz, a następnie kliknij przycisk Otwórz.
  5. Kliknij Następny: Wybierz adresatów.

Krok 3: Określ źródło danych programu Excel

  1. W obszarze Wybierz adresatówkliknij przycisk Użyj istniejącej listy.
  2. Kliknij przycisk Przeglądaj.
  3. W oknie dialogowym Wybierz źródło danych zlokalizuj, a następnie kliknij arkusz programu Excel, którego chcesz używać.

    Domyślnie program Word otwiera folder "Moje źródła danych".
  4. Kliknij przycisk Otwórz.
  5. Jeśli arkusz programu Excel zawiera informacje o kilku kartach, wybierz kartę zawierającą żądane informacje, a następnie kliknij OK.
  6. Wszystkie wpisy w źródle danych pojawiają się w oknie dialogowym Adresaci korespondencji seryjnej . W tym miejscu można dostosować listę adresatów korespondencji seryjnej.

Krok 4: Wybierz adresatów

  1. W oknie dialogowym Adresaci korespondencji seryjnej Wybierz adresatów, których chcesz uwzględnić. Aby to zrobić, użyj jednej z następujących metod:
    • Użyj pól wyboru do wyznaczenia adresatów.

      Ta metoda jest użyteczna, gdy lista jest krótka. Kliknij, aby zaznaczyć pola wyboru obok adresatów, których chcesz uwzględnić, a następnie kliknij, aby wyczyścić pola wyboru obok adresatów, których chcesz wykluczyć.

      Uwaga Jeśli wiesz, że chcesz uwzględnić większość elementów listy podczas scalania, kliknij przycisk Zaznacz wszystko, a następnie kliknij odznaczanie poszczególnych pozycji. Podobnie jeśli chcesz uwzględnić tylko kilka rekordów listy, kliknij przycisk Wyczyść wszystko, a następnie wybierz rekordy, które chcesz.
    • Sortowanie elementów na liście.

      Ta metoda jest przydatna, jeśli chcesz wyświetlić elementy w porządku alfabetycznym lub numerycznym. Kliknij nagłówek kolumny elementu, według którego chcesz sortować. Na przykład jeśli chcesz wyświetlić listę alfabetycznie według nazwiska, kliknij nagłówek kolumny Nazwisko .
    • Filtrowanie elementów na liście.

      Ta metoda jest przydatna, jeśli lista zawiera rekordy, które wiadomo, że nie chcesz wyświetlać lub uwzględnić w korespondencji seryjnej. Po przefiltrowaniu listy można użyć pól wyboru w celu uwzględnienia bądź wykluczenia rekordów, zgodnie z wcześniejszym opisem. Aby filtrować listę, wykonaj następujące kroki:
      1. Kliknij strzałkę obok nagłówka kolumny elementu, który chcesz filtrować według.
      2. Kliknij dowolną z następujących czynności:
        • (Puste): Ta opcja wyświetla wszystkie rekordy, w których odpowiednie pole jest puste.
        • (Niepuste): opcja ta wyświetla wszystkie rekordy, w których odpowiednie pole zawiera informacje.
        • Jeśli źródło danych zawiera rekordy współdzielące tę samą informację i w kolumnie istnieje 10 lub mniej unikatowych wartości, można filtrować według określonej informacji. Na przykład jeśli istnieje wiele adresów zawierających ciąg Australia jako kraj, można filtrować przez Australię.
    • Okno dialogowe Adresaci korespondencji seryjnej zostaną wyświetlone tylko wyznaczone rekordy. Aby ponownie wyświetlić wszystkie rekordy, kliknij przycisk (wszystkie).
    Uwagi
    • Dla zaawansowanego sortowania i filtrowania, kliknij strzałkę obok nazwy kolumny, a następnie kliknij (zaawansowane). Aby zdefiniować sortowania lub filtrowania żądaną kwerendę użyj kart Filtrowanie rekordów i Sortowanie rekordów .
    • Jeśli zainstalowano oprogramowanie do sprawdzania poprawności adresów, kliknij przycisk Sprawdź poprawność w oknie dialogowym Adresaci korespondencji seryjnej , aby sprawdzić poprawność adresów odbiorców.
  2. Kliknij przycisk OK , aby powrócić do Kreatora korespondencji seryjnej.

    Program Word użyje listy wyznaczonych adresatów w korespondencji seryjnej.
  3. Kliknij Następny: Napisz list.

Krok 5: Pisanie listu i dodawanie pól korespondencji seryjnej

Jeśli jeszcze nie zostało to zrobione, wpisz tekst, który ma się pojawiać w każdym z listów w dokumencie głównym.

Wstaw pola korespondencji seryjnej

Wstaw pola korespondencji seryjnej, gdzie mają się pojawić nazwiska, adresy i inne informacje ze źródła danych. Aby wstawić pola korespondencji seryjnej, wykonaj następujące kroki:
  1. W dokumencie głównym kliknij miejsce wstawienia pola.
  2. Włóż jedną z następujących czynności:
    • Blok adresu z nazwa, adres i inne informacje:
      1. Kliknij Blok adresu.
      2. W oknie dialogowym Wstawianie bloku adresu zaznacz elementy, które mają zostać uwzględnione i formaty, które chcesz, a następnie kliknij przycisk OK. Aby uzyskać pomoc dotyczącą opcji kliknij znak zapytania, a następnie kliknij żądaną opcję.

      3. Aby uzyskać pomoc dotyczącą opcji kliknij znak zapytania, a następnie kliknij żądaną opcję. Jeśli pojawi się okno dialogowe Dopasowywanie pól , program Word może być nie można odnaleźć części informacji wymaganych dla bloku adresu. Kliknij strzałkę znajdującą się obok
        (niedostępne), a następnie wybierz pole ze źródła danych zgodne z polem wymaganym do korespondencji seryjnej.
    • Wiersz pozdrowienia:
      1. Kliknij przycisk Wiersz pozdrowienia.
      2. Wybierz format wiersza pozdrowienia, który zawiera zwrot grzecznościowy, format nazwy i znaki interpunkcyjne.
      3. Zaznacz tekst, który ma być wyświetlany w przypadkach, w których program Word nie może zinterpretować nazwiska adresata. Na przykład program Word nie może zinterpretować nazwę, gdy źródło danych nie zawiera imienia ani nazwiska adresata, lecz tylko nazwę firmy.
      4. Kliknij przycisk OK.
      5. Jeśli pojawi się okno dialogowe Dopasowywanie pól , program Word może być nie można odnaleźć części informacji wymaganych dla wiersza pozdrowienia. Kliknij strzałkę znajdującą się obok (niedostępne), a następnie wybierz pole ze źródła danych odpowiadające polu wymaganemu w korespondencji seryjnej.
    • Inne pola informacji:
      1. Kliknij przycisk więcej elementów.
      2. Użyj jednej z następujących metod:
        • Kliknij przycisk Pola adresu , aby wybrać pola adresu, które będą automatycznie mapowane na odpowiednie pola w źródle danych, nawet jeśli pola źródła danych mają taką samą nazwę niż pola użytkownika.
        • Kliknij przycisk Pola bazy danych , aby wybrać pola, które zawsze pobierają dane bezpośrednio z kolumny w bazie danych.
      3. W polu pola kliknij żądane pole.
      4. Kliknij przycisk Wstaw, a następnie kliknij przycisk Zamknij.
      5. Jeśli pojawi się okno dialogowe Dopasowywanie pól , program Word nie może być móg³ znaleŸæ niektórych informacji wymaganych do wstawienia pola. Kliknij strzałkę znajdującą się obok (niedostępne), a następnie wybierz pole ze źródła danych odpowiadające polu wymaganemu w korespondencji seryjnej.

        Uwaga Jeśli użytkownik wstawi pole z listy Pola bazy danych i późniejsze przełączenie do źródła danych, które nie zawiera kolumny o tej samej nazwie, program Word nie może wstawić informacji z tego pola do scalonego dokumentu.
    • Elektroniczna opłata pocztowa:

      Aby dodać elektroniczną opłatę pocztową, należy najpierw zainstalować program elektronicznej opłaty pocztowej, taki, który można zakupić od dostawcy innych firm w sieci Web. Aby korzystać z elektronicznej opłaty pocztowej, wykonaj następujące kroki:
      1. Kliknij przycisk elektronicznej opłaty pocztowej.

        Jeśli nie masz zainstalowanego programu do obsługi elektronicznej opłaty pocztowej, program Word wyświetli monit o jego zainstalowanie i propozycja połączenia z następującą witrynę sieci Web Microsoft Office:
      2. Wstaw opłatę pocztową zgodnie z instrukcjami programu.
    • Aby dodać elektroniczną opłatę pocztową, należy najpierw zainstalować program elektronicznej opłaty pocztowej, taki, który można zakupić od dostawcy innych firm w sieci Web. Aby korzystać z elektronicznej opłaty pocztowej, wykonaj następujące kroki: pocztowy kod kreskowy: należy wybrać typ literę lub koperty, który obsługuje kod kreskowy POSTNET. Aby korzystać z pocztowego kodu kreskowego, wykonaj następujące kroki:
      1. Kliknij przycisk pocztowy kod kreskowy.
      2. W oknie dialogowym Wstaw pocztowy kod kreskowy wybierz odpowiednie pola adresu.

        Uwaga Opcja pocztowy kod kreskowy pojawia się tylko wtedy, gdy używasz wersja programu Word dla języka US.
      3. Powtórz kroki i b dla wszystkich pól, które chcesz wstawić. Uwagi:
        • Nie można wpisywać znaków pól scalania ("") lub wstawiać ich przy użyciu polecenia Symbol na menu Wstaw .
        • Jeśli pola korespondencji seryjnej są wyświetlane wewnątrz nawiasów klamrowych, na przykład {MERGEFIELD miejscowość}, program Word wyświetla kody pól zamiast wyników pól. Nie wpływa to na scalanie, jednak jeżeli chcesz wyœwietlenie wyników, kliknij prawym przyciskiem myszy kod pola i następnie w menu skrótów kliknij polecenie Przełącz kody pól .
      Na przykład za pomocą przedstawiona przykładowa baza danych, list może zawierać pola AddressBlock i GreetingLine, i w związku z tym pierwsza strona zostanie wyświetlony podobny do następującego:
      26 lutego 2002 r.

      Blok adresów

      GreetingLine

      Wpisz treść listu w tym miejscu.

      Z poważaniem,

      Wpisz tutaj swoje imię

    Uwaga Aby wstawić pola korespondencji seryjnej, pracować z dokumentem głównym korespondencji seryjnej lub uruchomić korespondencji seryjnej umożliwia także paska narzędzi Korespondencja seryjna . Aby wyświetlić pasek narzędzi Korespondencja seryjna , w menu Narzędzia wskaż polecenie listy i dokumenty wysyłkowe , a następnie kliknij polecenie Pokaż pasek narzędzi korespondencji seryjnej.


    Pasek narzędzi Korespondencja seryjna dostarcza dodatkowe polecenia, które nie są uwzględnione w okienkach zadań Kreatora korespondencji seryjnej. Na przykład można użyć menu Wstaw pole programu Word na pasku narzędzi Korespondencja seryjna do wstawiania pól programu Word służących do kontrolowania procesu scalania. Na przykład można wstawić pole IF wstawia tekst tylko wtedy, gdy określone pole scalania zawiera określoną wartość, że.

    Alternatywnie można kliknąć Sprawdzanie błędów , aby program Word uruchomić korespondencji seryjnej i zgłaszać wszelkie błędy, które są zawarte w dokumencie głównym.

Zmienić Format scalanych danych

Aby sformatować scalone dane, należy sformatować pola scalania w dokumencie głównym. Nie należy formatować danych w źródle danych, ponieważ formatowanie nie jest zachowywane podczas scalania danych w dokumencie. Aby zmienić format scalanych danych, wykonaj następujące kroki:
  1. W dokumencie głównym zaznacz pole zawierające informacje, które chcesz sformatować, wraz z otaczający znakami pola korespondencji seryjnej (<> <>).
  2. W programie Word 2003 i starszych wersjach programu Word w Format menu kliknij polecenie Czcionka , a następnie wybierz żądane opcje.

    W programie Word 2007 kliknij opcję, która ma w polu Czcionki motywu w grupie Czcionka na karcie Narzędzia główne .

Formatowanie przy użyciu kodów pól

Aby kontrolować inne aspekty formatowania, naciśnij klawisze ALT + F9, aby wyświetlić kody pól, a następnie dodać przełączniki do pól korespondencji seryjnej. Podczas pracy z polami przełącznik to specjalna instrukcja, która powoduje, że wykonanie określonej akcji. Ogólnie rzecz biorąc przełącznik jest dodawany do pola w celu modyfikacji wyniku.

Przykłady sposobów korzystania z przełączników:
  • Aby wyświetlić numer 34987.89 jako 34 987,89 zł, należy dodać przełącznik formatu numerycznego (\ #).
  • Aby wydrukować nazwiska klientów wersalikami, należy dodać przełącznik formatu (\ *).
  • Aby upewnić się, że scalone informacje ma tę samą czcionkę i rozmiar czcionki, który można zastosować do pola korespondencji seryjnej, należy dodać przełącznik Charformat (\ *).

Krok 6: Zapisz dokument

Po przygotowaniu dokumentu głównego i wstawieniu wszystkich pól scalania, upewnij się, że zapisać dokument przed kontynuowaniem. Aby to zrobić, wykonaj następujące kroki:
  1. W programie Word 2003 i starszych wersjach programu Word kliknij polecenie Zapisz jako w menu plik .

    W programie Word 2007 kliknij Przycisk pakietu Microsoft Office, a następnie kliknij przycisk Zapisz jako.
  2. Wpisz nazwę dokumentu, a następnie kliknij przycisk Zapisz.
  3. Kliknij Następny: Przejrzyj listy.

Krok 7: Przeglądanie listów i dostosowywanie listy adresatów

Kiedy Kreator wyświetli okienko zadań "krok 5 korespondencji seryjnej", kreator zastępuje wszystkie pola korespondencji seryjnej w dokumencie głównym, który ma rzeczywistym tekstem z pierwszego wpisu listy adresatów. W związku z tym można zobaczyć, jak będzie wyglądał pierwszego dokumentu wyjściowego.

Na przykład, gdyby w dalszym ciągu używać przedstawiona przykładowa baza danych, pierwszej strony powinien być podobny następującą stronę po kliknięciu Następny: Przejrzyj listy:
26 lutego 2002 r.

Andrew Fuller
Sposób kapitału W. 908
Tacoma 98401

Szanowny Andrew Fuller,

Wpisz treść listu w tym miejscu.

Z poważaniem,

Wpisz tutaj swoje imię
Aby wyświetlić podgląd dodatkowych wpisów, użyj jednej z następujących metod:
  • Aby wyświetlić podgląd kolejnych elementów w kolejności, kliknij przyciski Strzałka w lewo lub w prawo.
  • Aby zlokalizować i przejrzeć okreolony element, kliknij przycisk Znajdź adresata, a następnie wprowadź kryteria wyszukiwania w oknie dialogowym Znajdowanie pozycji .
Jeśli chcesz, należy dostosować listę adresatów. Aby to zrobić, użyj jednej z następujących metod:
  • Aby wykluczyć określonego adresata z operacji scalania, kliknij przycisk Wyklucz tego adresata.
  • Aby zmienić listę adresatów, kliknij przycisk Edytuj listę adresatów, a następnie wprowadź zmiany w oknie dialogowym Adresaci korespondencji seryjnej .

Krok 8: Ukończ scalanie

Aby ukończyć scalanie, użyj dowolnej z następujących metod.

Personalizowanie poszczególnych listów

Aby spersonalizować poszczególne elementy, zakończyć scalanie, a następnie edytować żądane informacje w wynikowym scalonym dokumencie. Aby to zrobić, wykonaj następujące kroki:
  1. Kliknij przycisk Edytuj poszczególne listy.
  2. W oknie dialogowym Scal z nowym dokumentem wybierz rekordy, które chcesz scalić.
  3. Kliknij przycisk OK.

    Program Word tworzy i otwiera nowy scalony dokument. Dokument główny również pozostaje otwarty i można przełączyć się do tego, aby zmienić wszystkie dokumenty.
  4. Przewiń do informacji, które chcesz edytować, a następnie wprowadź odpowiednie zmiany.
  5. Wydrukuj lub Zapisz dokument, tak jak każdy zwyczajny dokument.

Wydrukować listy

Aby wydrukować listy, użyj jednej z następujących metod:
  • Jeśli elementy zostały spersonalizowane i scalony dokument jest aktywny, wykonaj następujące kroki:
    1. W programie Word 2003 i starszych wersjach programu Word w menu plik kliknij polecenie Drukuj .

      W programie Word 2007 kliknij Przycisk pakietu Microsoft Office, a następnie kliknij przycisk Drukuj.
    2. Wybierz żądane opcje.
  • Jeśli chcesz drukować bezpośrednio z Kreatora korespondencji seryjnej, wykonaj następujące kroki:
    1. W kroku 6 Kreatora korespondencji seryjnej (Zakończenie scalania) kliknij przycisk Drukuj.
    2. W oknie dialogowym Scal na drukarkę użyj jednej z następujących metod, a następnie kliknij OK:
      • Aby wydrukować wszystkie dokumenty, kliknij przycisk wszystko.
      • Aby wydrukować dokument widoczny w oknie dokumentu, kliknij opcję bieżący rekord.
      • Aby wydrukować zakres dokumentów, kliknij przycisk od, a następnie wpisz numery rekordów w polach od i do .
    3. W oknie dialogowym Drukuj wybierz żądane opcje.

Zapisywanie scalonych listów w celu późniejszego użycia

Jeśli chcesz edytować scalone listy lub zapisane w celu póYniejszego użytku, można zebrać je w jednym dokumencie. Aby to zrobić, wykonaj następujące kroki:
  1. Kliknij przycisk Edytuj poszczególne listy.
  2. W oknie dialogowym Scal z nowym dokumentem należy użyć jednej z następujących metod, a następnie kliknij OK:
    • Aby scalić wszystkie dokumenty, kliknij przycisk wszystko.
    • Aby scalić tylko dokument widoczny w oknie dokumentu, kliknij opcję bieżący rekord.
    • Aby scalić zakres dokumentów, kliknij przycisk od, a następnie wpisz numery rekordów w polach od i do .
  3. Program Word otwiera pojedynczy nowy dokument zawierający wszystkie poszczególne listy. Można zapisać dokument w celu póYniejszego użytku, tak jak każdy zwyczajny dokument.

Powiązane artykuły


Aby uzyskać więcej informacji kliknij następujące numery artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:

318115 jak utworzyć list seryjny przy użyciu informacji z bazy danych programu Access w programie Word 2002

318112 sposób używania adresów z bazy danych programu Access 2002 do tworzenia etykiet w programie Word 2002

294686 jak używać korespondencji seryjnej do tworzenia listy sortowanej według kategorii w programie Word 2002 i starszych wersjach programu Word

290408 często zadawane pytania dotyczące korespondencji seryjnej w programie Word 2002

294688 jak projektować i tworzyć listy adresów korespondencji seryjnej w programie Word 2002 i nowszych wersjach programu Word

294693 jak używać korespondencji seryjnej do tworzenia katalogu w programie Word 2002 i nowszych wersjach programu Word

294683 jak używać korespondencji seryjnej do tworzenia listów seryjnych w programie Word 2002 i nowszych wersjach programu Word