Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Podczas wprowadzania formuły tablicowejnajczęściej używa się zakresu komórek w arkuszu, ale nie trzeba tego zrobić. Możesz także użyć stałych tablicowych— wartości właśnie wprowadzanych na pasku formuły wewnątrz nawiasów klamrowych: {}. Następnie możesz określić nazwę stałej, aby była łatwiejsza do użycia ponownie.

Stałych można używać w formułach tablicowych lub samodzielnie.

  1. W formule tablicowej wpisz otwierający nawias klamrowy, poszukiwane wartości i zamykający nawias klamrowy. Oto przykład: =SUMA(A1:E1*{1;2;3;4;5})

    Stała znajduje się wewnątrz nawiasów klamrowych ({)} i tak, naprawdę należy ręcznie wpisać te nawiasy klamrowe.

  2. Wprowadź pozostałą część formuły i naciśnij klawisze Ctrl+Shift+Enter.

    Formuła będzie wyglądać podobnie do {=SUMA(A1:E1*{1;2;3;4;5})},a wyniki będą wyglądać tak:


    Stała tablicowa zagnieżdżona w formule SUMA

    Formuła pomnożona przez formułę A1 przez 1 i B1 przez 2 itd., dzięki temu nie trzeba umieszczać w komórkach arkusza 1,2;3;4,5.

Wprowadzanie wartości w kolumnie przy użyciu stałej

Aby wprowadzić wartości w pojedynczej kolumnie, takiej jak 3 komórki w kolumnie C, należy:

  1. Zaznacz komórki, których chcesz użyć.

  2. Wprowadź znak równości i stałą. Wartości w stałej rozdziel średnikami, a nie przecinkami, a jeśli wprowadzasz tekst, ujmij je w cudzysłowy podwójne. Na przykład: ={"Kwartał 1";" Kwartał2";" Kwartał 3"}

  3. Naciśnij klawisze Ctrl+Shift+Enter. Stała wygląda następująco:

    Pionowa stała tablicowa z tekstem

    W przypadku maniaków jest to jednowymiarowa stała pionowa.

Wprowadzanie wartości w wierszu przy użyciu stałej

Aby szybko wprowadzić wartości w jednym wierszu, takim jak komórki F1, G1 i H1, należy:

  1. Zaznacz komórki, których chcesz użyć.

  2. Wprowadź znak równości i stałą, ale tym razem wartości rozdzielisz średnikami, a nie średnikami. Na przykład: ={1;2;3;4;5}

  3. Naciśnij klawisze Ctrl+Shift+Enter, a stała będzie wyglądać następująco:

    Jednowymiarowa pozioma stała tablicowa

    W przypadku maniaków jest to jednowymiarowa stała pozioma.

Wprowadzanie wartości w wielu kolumnach i wierszach przy użyciu stałej

  1. Zaznacz odpowiednie komórki.

    Upewnij się, że liczba wybranych wierszy i kolumn odpowiada liczbie wartości w stałej. Jeśli na przykład stała będzie zapisywać dane w czterech kolumnach i trzech wierszach, zaznacz tę liczbę kolumn i wierszy.

  2. Wprowadź znak równości i stałą. W tym przypadku należy oddzielić wartości w każdym wierszu średnikami i użyć średnika na końcu każdego wiersza. Na przykład:

    ={1\2\3\4;5\6\7\8;9\10\11\12}

  3. Naciśnij klawisze Ctrl+Shift+Enter i:

    Dwuwymiarowa stała tablicowa

    W przypadku maniaków jest to stała dwuwymiarowa, która wypełnia kolumny i wiersze. Jeśli się zastanawiasz, nie możesz utworzyć stałej trójwymiarowej, co oznacza, że nie możesz zagnieździć stałej wewnątrz innej.

Używanie stałej w formule

Teraz, gdy znasz już stałe tablicowe, oto przykład roboczy.

  • W dowolnej pustej komórce wprowadź (lub skopiuj i wklej) tę formułę, a następnie naciśnij klawisze Ctrl+Shift+Enter:

    =SUMA(A1:E1*{1\2\3\4\5})

    W komórce A3 zobaczysz wartość 85.

    Co się stało? Pomnożyliśmy wartość z komórki A1 przez 1, wartość w komórce B2 przez 2 i tak dalej, a następnie funkcja SUMA dodała te wyniki. Można również wprowadzić formułę w następujący sposób: =SUMA(A1*1;B1*2;C1*3;D1*4;E1*5)

Jeśli chcesz, możesz wprowadzić oba zestawy wartości jako stałe tablicowe:

=SUMA({3\4\5\6\7}*{1\2\3\4\5})

Aby to wypróbować, skopiuj formułę, zaznacz pustą komórkę i wklej formułę na pasku formuły, a następnie naciśnij klawisze Ctrl+Shift+Enter. Zostanie wyświetlony taki sam wynik.

Uwagi: Jeśli stałe nie działają, poszukaj tych problemów:

  • Upewnij się, że wartości są oddzielone odpowiednim znakiem. Jeśli pominiesz średnik lub umieścisz go w nieodpowiednim miejscu, stała tablicowa może nie wyglądać dobrze lub może zostać wyświetlony komunikat ostrzegawczy.

  • Być może zaznaczono zakres komórek, który nie odpowiada liczbie elementów w stałej. Jeśli na przykład zaznaczysz sześć komórek w kolumnie do użycia z pięciokomórkową stałą, w pustej komórce pojawi się błąd #N/A. Jeśli nie zaznaczysz odpowiedniej liczby komórek, Excel wartości, które nie mają odpowiadających im komórek.

  • Aby uzyskać więcej informacji o formułach tablicowych:

Początek strony

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów Microsoft Office

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×