Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Opis

Funkcja ZAOKR zaokrągla liczbę do określonej liczby cyfr. Aby na przykład zaokrąglić liczbę 23,7825 znajdującą się w komórce A1 do dwóch miejsc dziesiętnych, można użyć następującej formuły:

=ZAOKR(A1;2)

Wynikiem funkcji będzie liczba 23,78.

Składnia

ZAOKR(liczba;liczba_cyfr)

W składni funkcji ZAOKR występują następujące argumenty:

  • number    Argument wymagany. Liczba, która ma zostać zaokrąglona.

  • num_digits    Argument wymagany. Liczba cyfr, do której liczba ma zostać zaokrąglony argument number.

Spostrzeżenia

  • Jeśli argument liczba_cyfr jest większy od zera, liczba jest zaokrąglana do wybranej liczby miejsc dziesiętnych.

  • Jeśli argument liczba_cyfr wynosi zero, liczba jest zaokrąglana do najbliższej liczby całkowitej.

  • Jeśli argument liczba_cyfr jest mniejszy od zera, liczba jest zaokrąglana do wartości z lewej strony przecinka dziesiętnego.

  • Aby zawsze zaokrąglać w górę (w kierunku od zera), należy użyć funkcji ZAOKR.GÓRA.

  • Aby zawsze zaokrąglać w dół (w kierunku zera), należy użyć funkcji ZAOKR.DÓŁ.

  • Aby zaokrąglić liczbę do określonej wielokrotności (na przykład do wielokrotności 0,5), należy użyć funkcji ZAOKR.DO.WIELOKR.

Przykład

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

Formuła

Opis

Wynik

=ZAOKR(2,15;1)

Zaokrągla liczbę 2,15 do jednego miejsca dziesiętnego

2,2

=ZAOKR(2,149;1)

Zaokrągla liczbę 2,149 do jednego miejsca dziesiętnego

2,1

=ZAOKR(-1,475;2)

Zaokrągla liczbę -1,475 do dwóch miejsc dziesiętnych

-1,48

=ZAOKR(21,5;-1)

Zaokrągla liczbę 21,5 do jednego miejsca dziesiętnego po lewej stronie przecinka

20

=ZAOKR(626,3;-3)

Zaokrągla liczbę 626,3 do najbliższej wielokrotności liczby 1000.

1000

=ZAOKR(1,98;-1)

Zaokrągla liczbę 1,98 do najbliższej wielokrotności liczby 10

0

=ZAOKR(-50,55;-2)

Zaokrągla liczbę -50,55 do najbliższej wielokrotności liczby 100

-100

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów Microsoft Office

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×